summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-08-05 08:50:26 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-08-06 09:29:58 -0300
commit3b698004698742130f87dd4d9edaabdf58c4e079 (patch)
tree5e722e51b9ce14dc5def3e9350a357146ca3835d /recipes-multimedia
parent860d66d32f3071dbd07f21c73ec1e06d5566c5ca (diff)
downloadmeta-fsl-arm-3b698004698742130f87dd4d9edaabdf58c4e079.tar.gz
Drop Freescale official Linux kernel for i.MX23, i.MX28 and i.MX5 SoC families
The Linux kernel provided by Freescale for i.MX28 and i.MX5 is too old (2.6.35.3) and there are no plans to upgrade it, as the OE-Core is going to use GCC 5.2 as default compiler soon and it is not possible to compile this kernel with the new toolchain, thus the removal. The metadata related to the i.MX23, i.MX28 and i.MX5 SoC family, which is dependant of this Linux kernel support, has been removed in this commit so if someone ever wants to bring it back it is easy to find out all the necessary changes. The recipes affected are: - alsa-state - amd-gpu-x11-bin - gtk+3 - imx-lib - imx-test - imx-vpu - libfslcodec - linux-imx - mesa - qt4-embedded-free - qt4-x11-free - qtbase - xf86-video-imxfb Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Acked-by: Daiane Angolini <daiane.angolini@freescale.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend4
-rw-r--r--recipes-multimedia/libfslcodec/libfslcodec.inc6
2 files changed, 0 insertions, 10 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
index 5b939d4..766971f 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
@@ -1,10 +1,6 @@
1 1
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3 3
4SRC_URI_append_mxs = " file://gstplaybin-enable-native-video.patch"
5SRC_URI_append_mx5 = " file://gstplaybin-enable-native-video.patch"
6SRC_URI_append_mx6 = " file://gstplaybin-enable-native-video.patch" 4SRC_URI_append_mx6 = " file://gstplaybin-enable-native-video.patch"
7 5
8PACKAGE_ARCH_mxs = "${MACHINE_SOCARCH}"
9PACKAGE_ARCH_mx5 = "${MACHINE_SOCARCH}"
10PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}" 6PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}"
diff --git a/recipes-multimedia/libfslcodec/libfslcodec.inc b/recipes-multimedia/libfslcodec/libfslcodec.inc
index 3936258..9d08c39 100644
--- a/recipes-multimedia/libfslcodec/libfslcodec.inc
+++ b/recipes-multimedia/libfslcodec/libfslcodec.inc
@@ -15,7 +15,6 @@ EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--
15PACKAGECONFIG ?= "" 15PACKAGECONFIG ?= ""
16PACKAGECONFIG_mx6q = "vpu" 16PACKAGECONFIG_mx6q = "vpu"
17PACKAGECONFIG_mx6dl = "vpu" 17PACKAGECONFIG_mx6dl = "vpu"
18PACKAGECONFIG_mx5 = "vpu"
19 18
20PACKAGECONFIG[vpu] = "--enable-vpu,--disable-vpu,imx-vpu" 19PACKAGECONFIG[vpu] = "--enable-vpu,--disable-vpu,imx-vpu"
21 20
@@ -31,11 +30,6 @@ do_install_append() {
31 30
32} 31}
33 32
34do_install_append_mx5() {
35 # FIXME: The binary files depends on libvpu.so.4 which is i.MX6 only
36 rm -r ${D}${datadir}/imx-mm/*/examples/*/bin
37}
38
39python __set_insane_skip() { 33python __set_insane_skip() {
40 # Ensure we have PACKAGES expanded 34 # Ensure we have PACKAGES expanded
41 bb.build.exec_func("read_subpackage_metadata", d) 35 bb.build.exec_func("read_subpackage_metadata", d)