diff options
author | Daiane Angolini <daiane.angolini@freescale.com> | 2012-11-19 05:06:40 -0600 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2012-11-27 15:19:43 -0200 |
commit | 609e1b1207b14c37919d5023f6e29ff67123fa12 (patch) | |
tree | 8847eae639d49e1a53180600305e0fde1c4db164 /recipes-multimedia/libfslparser/libfslparser_3.0.1.bb | |
parent | 0a299749703e5d7523fb0598cf5ec28d333243c6 (diff) | |
download | meta-fsl-arm-609e1b1207b14c37919d5023f6e29ff67123fa12.tar.gz |
libfslparser: Add libfslparser 3.0.1 support
This package if only compatible for imx6.
fsl-mm-codeclib was divided in 3 pieces,
libfslcodec libfslvpuwrap and libfslparser.
Change-Id: If661edd86add2a0bcff3b3c38b394a5bdb63394e
Signed-off-by: Daiane Angolini <daiane.angolini@freescale.com>
Diffstat (limited to 'recipes-multimedia/libfslparser/libfslparser_3.0.1.bb')
-rw-r--r-- | recipes-multimedia/libfslparser/libfslparser_3.0.1.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-multimedia/libfslparser/libfslparser_3.0.1.bb b/recipes-multimedia/libfslparser/libfslparser_3.0.1.bb new file mode 100644 index 0000000..4276784 --- /dev/null +++ b/recipes-multimedia/libfslparser/libfslparser_3.0.1.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | # Copyright (C) 2012 Freescale Semicondutors | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | DESCRIPTION = "Freescale Multimedia parser libs" | ||
4 | LICENSE = "Proprietary" | ||
5 | SECTION = "multimedia" | ||
6 | LIC_FILES_CHKSUM = "file://EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01" | ||
7 | |||
8 | inherit fsl-eula-unpack autotools pkgconfig | ||
9 | |||
10 | SRC_URI[md5sum] = "52a72680d4c1db4b9fadcae56980a8ae" | ||
11 | SRC_URI[sha256sum] = "50b514fe3e9912ac24e9da81de5e713bf42e1a7d3a41ae6f221258c2f8539194" | ||
12 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" | ||
13 | |||
14 | PACKAGES_DYNAMIC = "${PN}-*" | ||
15 | |||
16 | do_install_append() { | ||
17 | # FIXME: The only parser outside imx-mm/parse is the mp3 so move it | ||
18 | mv ${D}${libdir}/*mp3* ${D}${libdir}/imx-mm/parser/ | ||
19 | } | ||
20 | |||
21 | python populate_packages_prepend() { | ||
22 | parserdir = bb.data.expand('${libdir}/imx-mm/parser', d) | ||
23 | do_split_packages(d, parserdir, '^lib_(.*)_elinux\.so\.', | ||
24 | aux_files_pattern_verbatim='${libdir}/imx-mm/parser/lib_%s_elinux.so.*', | ||
25 | output_pattern='libfslparser-%s', recursive=True, | ||
26 | description='Freescale IMX Parser (%s)', | ||
27 | extra_depends='', prepend=True) | ||
28 | |||
29 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | ||
30 | # the source we cannot fix it. Disable the insane check for now. | ||
31 | for p in d.getVar('PACKAGES', True).split(): | ||
32 | d.setVar("INSANE_SKIP_%s" % p, "ldflags") | ||
33 | } | ||
34 | |||
35 | # Ensure we get warnings if we miss something | ||
36 | FILES_${PN} = "" | ||
37 | |||
38 | FILES_${PN}-dev += "${libdir}/imx-mm/*/*${SOLIBSDEV}" | ||
39 | |||
40 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
41 | COMPATIBLE_MACHINE = "(mx6)" | ||