summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2016-01-08 09:43:25 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2016-01-11 10:19:59 -0200
commitcf7a088215da7f85efdcdabbe6dce8d7120cf53a (patch)
tree0c0ecdb9b96eb39007c8a31b9a43fbb5a0cd3e6b /recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb
parent1dd6a5b87947e17e986e4326bee277f7bfef0be5 (diff)
downloadmeta-fsl-arm-cf7a088215da7f85efdcdabbe6dce8d7120cf53a.tar.gz
gstreamer1.0-plugins-imx: Update to version 0.12.0
Changes: * vpu: - Completely rewritten plugin code; elements now based on libimxvpuapi instead of libfslvpuwrap - imxvpuenc_h264 inserts SPS/PPS data in front of I/IDR frames - imxvpuenc_mjpeg's quality factor actually has an effect, and is equivalent to the libjpeg's quality factor (it is used in exactly the same way to scale the quantization matrix' coefficients) - the encoder's output buffers no longer have to use DMA memory; they use regular system memory instead - new support in imxvpudec (referred to as "chroma interleaving") for NV12, NV16, NV24 as output formats as an alternative to the I420, Y42B, Y444 formats - removed all of the system frame number tracking code, since it is unnecessary; Instead, the libimxvpuapi's context fields are used to associate input/output frames with GstVideoCodecFrame system frame numbers - fix memory leaks related to missing buffer pool unref'ing * imxv4l2videosrc: - support for crop metadata - element uses the width, height, etc. of the format that the device actually uses during operation (instead of default values) - autofocus control support via GstPhotography - fix incorrect GLib warnings - fix segmentation fault when shutting down the element * eglvivsink: - remove extra g_free() calls, which lead to runtime errors - remove GLESv2 VIVANTE link dependencies - add Android platform - manually retrieve VIV direct texture functions with this and the link dependency elimination, this means that for platforms except the framebuffer one, no Vivante specific headers and libraries are needed anymore - fix blocking issue in the Wayland platform mainloop * improved and expanded documentation * pxp: NV16 *is* supported after all (it was actually a bug in GStreamer pre-1.5.91) NOTE: this does not break compatibility with GStreamer versions older than 1.5.91 * compositor: Update backported aggregator code to GStreamer 1.6 * blitter: - error handling improvements - add missing buffer pool unref'ing, which lead to memory leaks - add missing compositor dependency to blitter base * uniaudio: - only build the uniaudio plugin if at least one codec was found during configuration - disable plugin if the gstaudio library is not available - add AAC profile field to the sink caps with GStreamer >= 1.4.4 to ensure the uniaudio decoder is only used for AAC-LC data * ipu: increase fill frame width from 8 to 64 pixels to make IPU fill operations work with pre-3.14 Freescale kernels * g2d: use padding pixels when setting surface parameters, fixing G2D failures with frame sizes that aren't aligned * wscript: - improve Android support - fix installation paths for the common, blitter, compositor libraries Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb45
1 files changed, 0 insertions, 45 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb
deleted file mode 100644
index b168ef7..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
2LICENSE = "LGPLv2+"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
4SECTION = "multimedia"
5DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base imx-gpu-viv libfslcodec libfslvpuwrap virtual/kernel virtual/egl \
6 virtual/libgles2 ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
7# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers
8# for the uniaudio decoder, videoparsersbad for the VPU video decoder
9# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good and -bad recipes are built
10RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good gstreamer1.0-plugins-bad"
11RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers"
12RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad"
13
14SRCBRANCH ?= "master"
15SRCREV = "6cbb90f51b12588bb4cb146cb229bf3bad39afc4"
16SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
17
18S = "${WORKDIR}/git"
19
20inherit waf
21
22do_compile[depends] += "virtual/kernel:do_shared_workdir"
23
24# configure the eglvivsink element to use the appropriate EGL platform code
25# X11 if x11 is present in DISTRO_FEATURES
26# Wayland if x11 is not present in DISTRO_FEATURES, but wayland is
27# Framebuffer otherwise
28EGLVIVSINK_PLATFORM = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', \
29 base_contains('DISTRO_FEATURES', 'wayland', 'wayland', \
30 'fb', d),d)}"
31
32EXTRA_OECONF = "--egl-platform=${EGLVIVSINK_PLATFORM} --kernel-headers=${STAGING_KERNEL_DIR}/include"
33
34# LIBV is used by gst-plugins-package.inc to specify the GStreamer version (0.10 vs 1.0)
35LIBV = "1.0"
36require recipes-multimedia/gstreamer/gst-plugins-package.inc
37
38# the following line is required to produce one package for each plugin
39PACKAGES_DYNAMIC = "^${PN}-.*"
40
41COMPATIBLE_MACHINE = "(mx6)"
42
43# disable the false alarm (the "it isn't a build dependency" QA warning)
44INSANE_SKIP_gstreamer1.0-plugins-imx-imxaudio = "build-deps"
45INSANE_SKIP_gstreamer1.0-plugins-imx-imxvpu = "build-deps"