diff options
author | Adrian Alonso <aalonso00@gmail.com> | 2011-10-19 00:10:05 -0500 |
---|---|---|
committer | Adrian Alonso <aalonso00@gmail.com> | 2011-10-19 00:10:05 -0500 |
commit | 45de8e9a0ebc4a57f6092a0cea68f736f759b667 (patch) | |
tree | 1c74a350d760e7efbdb74067ba8e224fe263e547 /recipes-multimedia/gst-plugins | |
parent | 5b1514657ed17f7447d09f19755c92f1035817de (diff) | |
download | meta-fsl-arm-45de8e9a0ebc4a57f6092a0cea68f736f759b667.tar.gz |
gst-fsl-plugin: define extra packaged files
* Define extra packaged libraries and utilities
* gst-fsl-plugin.inc file defines additional files to be
shipped.
* Define run time dependency on fsl-mm-codeclib
* Bump PR.
Signed-off-by: Adrian Alonso <aalonso00@gmail.com>
Diffstat (limited to 'recipes-multimedia/gst-plugins')
-rw-r--r-- | recipes-multimedia/gst-plugins/gst-fsl-plugin.inc | 20 | ||||
-rw-r--r-- | recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.1.bb | 15 |
2 files changed, 24 insertions, 11 deletions
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin.inc b/recipes-multimedia/gst-plugins/gst-fsl-plugin.inc new file mode 100644 index 0000000..15635dd --- /dev/null +++ b/recipes-multimedia/gst-plugins/gst-fsl-plugin.inc | |||
@@ -0,0 +1,20 @@ | |||
1 | # Copyright (C) 2011 Freescale Semiconductor | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | PACKAGES += "${PN}-libmfwsconf ${PN}-libgplaycore \ | ||
5 | ${PN}-libme ${PN}-libgstbufmeta ${PN}-libmfwba \ | ||
6 | ${PN}-libfwvss ${PN}-gplay" | ||
7 | |||
8 | FILES_${PN} = "${libdir}/gstreamer-0.10/*.so" | ||
9 | FILES_${PN}-dbg = "${libdir}/gstreamer-0.10/.debug \ | ||
10 | ${libdir}/.debug" | ||
11 | FILES_${PN}-dev = "${libdir}/gstreamer-0.10/*.la \ | ||
12 | {libdir}/*.la" | ||
13 | |||
14 | FILES_${PN}-gplay = "${bindir}/gplay" | ||
15 | FILES_${PN}-libmfwsconf = "${libdir}/libmfwsconf.so.*" | ||
16 | FILES_${PN}-libgplaycore = "${libdir}/libgplaycore.so.*" | ||
17 | FILES_${PN}-libme = "${libdir}/libme.so.*" | ||
18 | FILES_${PN}-libgstbufmeta = "${libdir}/libgstbufmeta.so.*" | ||
19 | FILES_${PN}-libmfwba = "${libdir}/libmfwba.so.*" | ||
20 | FILES_${PN}-libfwvss = "${libdir}/libmfwvss.so.*" | ||
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.1.bb b/recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.1.bb index 932f82d..8e2338c 100644 --- a/recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.1.bb +++ b/recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.1.bb | |||
@@ -1,13 +1,15 @@ | |||
1 | # Copyright (C) 2011 Freescale Semicondutor | 1 | # Copyright (C) 2011 Freescale Semicondutor |
2 | # Released under the MIT license (see COPYING.MIT for the terms) | 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
3 | 3 | ||
4 | require gst-fsl-plugin.inc | ||
4 | inherit autotools pkgconfig | 5 | inherit autotools pkgconfig |
5 | 6 | ||
6 | DESCRIPTION = "Gstreamer freescale plugins" | 7 | DESCRIPTION = "Gstreamer freescale plugins" |
7 | LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1" | 8 | LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1" |
8 | SECTION = "multimedia" | 9 | SECTION = "multimedia" |
9 | DEPENDS = "gstreamer gst-plugins-base fsl-mm-codeclib imx-lib" | 10 | DEPENDS = "gstreamer gst-plugins-base fsl-mm-codeclib imx-lib" |
10 | PR = "r2" | 11 | RDEPENDS_${PN} = "fsl-mm-codeclib" |
12 | PR = "r3" | ||
11 | 13 | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ | 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ |
13 | file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | 15 | file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ |
@@ -18,13 +20,4 @@ SRC_URI[md5sum] = "ef414365901a4457d8c091615c0749e0" | |||
18 | SRC_URI[sha256sum] = "99668788886d7a9223c5cc2a408631d6fbf9094894da34c6c00036a9fe1253de" | 20 | SRC_URI[sha256sum] = "99668788886d7a9223c5cc2a408631d6fbf9094894da34c6c00036a9fe1253de" |
19 | 21 | ||
20 | # Todo add a mechanism to map posible build targets | 22 | # Todo add a mechanism to map posible build targets |
21 | EXTRA_OECONF = "PLATFORM=MX53 --disable-valgrind --disable-examples" | 23 | EXTRA_OECONF = "PLATFORM=MX53 --disable-valgrind --disable-examples --disable-debug" |
22 | |||
23 | INSANE_SKIP = "True" | ||
24 | FILES_${PN} += "${bindir}/gplay \ | ||
25 | ${libdir}/gstreamer-0.10/*.so* \ | ||
26 | ${libdir}/*.so*" | ||
27 | FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug" | ||
28 | FILES_${PN}-staticdev += "${libdir}/gstreamer-0.10/*.la \ | ||
29 | ${libdir}/gstreamer-0.10/*.a \ | ||
30 | ${libdir}/*.a ${libdir}/*.la" | ||