summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/alsa
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-07-15 19:58:31 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2013-07-31 16:08:26 -0300
commitc7833030e8d48664a48ba247e8907149867b28c6 (patch)
treec89bbe76c5f03f2ab1e52254e6c83cf3a4bfcc12 /recipes-multimedia/alsa
parentfdf3fe6296790b0c0817a58c064d7da1cca7dd0a (diff)
downloadmeta-fsl-arm-c7833030e8d48664a48ba247e8907149867b28c6.tar.gz
fsl-alsa-plugins: Add 1.0.25 version
This change has been based on changes done in meta-fsl-bsp-release, 3.5.7 dylan branch, by Lauren Post <lauren.post@freescale.com> and Jun Zhu <R01007@freescale.com>. We are not updating to 3.5.7-1.0.0 package as a compare of both sources show only autoconf generated changes (which are useless as we end regenerating them anyway). The diffstat is: ,---- | Makefile.in | 242 | aclocal.m4 |17434 ++++++++++++++++++++++++++++--------------------------- | asrc/Makefile.in | 86 | config.guess | 117 | config.sub | 82 | configure | 673 +- | depcomp | 255 | doc/Makefile.in | 60 | install-sh | 35 | ltmain.sh | 228 | missing | 148 | 11 files changed, 10133 insertions(+), 9227 deletions(-) `---- So we're using the last version which have been made public. Change-Id: I4845341feb8a12bf01a139564959b9ffb8bb940b Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/alsa')
-rw-r--r--recipes-multimedia/alsa/fsl-alsa-plugins_1.0.25.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-multimedia/alsa/fsl-alsa-plugins_1.0.25.bb b/recipes-multimedia/alsa/fsl-alsa-plugins_1.0.25.bb
new file mode 100644
index 0000000..3fa01b4
--- /dev/null
+++ b/recipes-multimedia/alsa/fsl-alsa-plugins_1.0.25.bb
@@ -0,0 +1,27 @@
1# Copyright (C) 2013 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Freescale alsa-lib plugins"
5LICENSE = "GPLv2"
6SECTION = "multimedia"
7DEPENDS = "alsa-lib virtual/kernel"
8
9LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f"
10
11inherit autotools pkgconfig
12
13SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.tar.gz"
14SRC_URI[md5sum] = "b1ca7a250a8cd5da07062081b30b4118"
15SRC_URI[sha256sum] = "902df92255d755e8eb08b3c3db0c7b9d70d26d9659b219373bee425ffdc34245"
16
17INCLUDE_DIR = "-I${STAGING_KERNEL_DIR}/include"
18EXTRA_OECONF = "CFLAGS="${INCLUDE_DIR}""
19
20INSANE_SKIP_${PN} = "dev-so"
21
22FILES_${PN} += "${libdir}/alsa-lib/libasound_*.so"
23FILES_${PN}-dbg += "${libdir}/alsa-lib/.debug"
24FILES_${PN}-dev += "${libdir}/alsa-lib/*.la"
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27COMPATIBLE_MACHINE = "(mx6)"