summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-03-19 14:13:17 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2013-03-19 15:44:54 -0300
commitd685258d90faf07317a7a39b353b1155270a384a (patch)
treeb785a3adc33a65ba300f7a2a93fcdd2b08ca247e /recipes-kernel
parent310a9faafa2f4ef3449decf73818b1be5fa7c02c (diff)
downloadmeta-fsl-arm-d685258d90faf07317a7a39b353b1155270a384a.tar.gz
linux-imx (2.6.35.3): Fix perf build due new Linux headers use
As Yocto now use a newer Linux headers package we end having a build failure in perf as 'stddef.h' has changed and does not provide NULL definiton anymore. To workaround it we add the srcdir onto search path for include files, before sysroot one. Change-Id: I87e2ee7626f2399ab726c9d1ed0f32f18e6d2948 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/perf-avoid-use-sysroot-headers.patch33
-rw-r--r--recipes-kernel/linux/linux-imx_2.6.35.3.bb3
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/perf-avoid-use-sysroot-headers.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-avoid-use-sysroot-headers.patch
new file mode 100644
index 0000000..7d12941
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-avoid-use-sysroot-headers.patch
@@ -0,0 +1,33 @@
1From 9a06d08e43923f8ce35f1c649334f14d2e81941b Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Tue, 19 Mar 2013 14:04:08 -0300
4Subject: [PATCH] perf: Avoid use of sysroot's Linux headers
5
6As Yocto now use a newer Linux headers package we end having a build
7failure in perf as 'stddef.h' has changed and does not provide NULL
8definiton anymore. To workaround it we add the srcdir onto search path
9for include files, before sysroot one.
10
11Upstream-Status: Inappropriate [build system specific change]
12
13Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
14---
15 tools/perf/Makefile | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/tools/perf/Makefile b/tools/perf/Makefile
19index 854652a..9605d46 100644
20--- a/tools/perf/Makefile
21+++ b/tools/perf/Makefile
22@@ -301,7 +301,7 @@ endif
23 # Those must not be GNU-specific; they are shared with perl/ which may
24 # be built by a different compiler. (Note that this is an artifact now
25 # but it still might be nice to keep that distinction.)
26-BASIC_CFLAGS = -Iutil/include -Iarch/$(ARCH)/include
27+BASIC_CFLAGS = -Iutil/include -Iarch/$(ARCH)/include -I../../include
28 BASIC_LDFLAGS =
29
30 # Guard against environment variables
31--
321.8.1
33
diff --git a/recipes-kernel/linux/linux-imx_2.6.35.3.bb b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
index edfbc74..692a290 100644
--- a/recipes-kernel/linux/linux-imx_2.6.35.3.bb
+++ b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
@@ -1,7 +1,7 @@
1# Copyright (C) 2011-2012 Freescale Semiconductor 1# Copyright (C) 2011-2012 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4PR = "${INC_PR}.21" 4PR = "${INC_PR}.22"
5 5
6include linux-imx.inc 6include linux-imx.inc
7 7
@@ -17,6 +17,7 @@ LOCALVERSION_mx5 = "-11.09.01+yocto"
17 17
18SRC_URI += "file://NFS-Fix-nfsroot-support.patch \ 18SRC_URI += "file://NFS-Fix-nfsroot-support.patch \
19 file://NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch \ 19 file://NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch \
20 file://perf-avoid-use-sysroot-headers.patch \
20" 21"
21 22
22SRC_URI_append_mxs = " \ 23SRC_URI_append_mxs = " \