summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-10-27 09:15:49 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-10-28 11:08:07 -0200
commitb7a1a91c6bdafd331446c4c0faa4bc98681973e7 (patch)
tree319760d79340a177ee6048bea021011d6960000d /recipes-kernel
parent980d924a798aacaaf6e1c9ddd33f5121788d4005 (diff)
downloadmeta-fsl-arm-b7a1a91c6bdafd331446c4c0faa4bc98681973e7.tar.gz
Remove Vybrid mcc related recipes
The mqxboot and mcc Linux kernel module requires the Timesys kernel to work. The kernel is not in use in meta-fsl-arm anymore and in long term the Vybrid will be using the remoteproc mechanism to share resources across the different CPU, inside of the SoC. As consequence of the update for the Linux 4.1 kernel, those recipes ought to move for meta-fsl-arm-extra where 3rd party boards can keep using them. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-mcc/mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch51
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-mcc_1.06.bb20
2 files changed, 0 insertions, 71 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-mcc/mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch b/recipes-kernel/kernel-modules/kernel-module-mcc/mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch
deleted file mode 100644
index 570edaa..0000000
--- a/recipes-kernel/kernel-modules/kernel-module-mcc/mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From 17e04c68557c4c9cb1a0112717019329a0cc3f96 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Tue, 6 Jan 2015 13:39:50 -0200
4Subject: [PATCH] mcc_config.h: Only include mvf_sema4.h if building in kernel
5Organization: O.S. Systems Software LTDA.
6
7When mcc_config.h is used to make application we shouldn't include
8mvf_sema4.h as it is an internal symbol of kernel and shouldn't be
9directly referenced by user space applications using the MCC
10interface.
11
12This patch puts a guard using __KERNEL__ define, avoiding the include
13and the definition of MCC_SHMEM_SEMAPHORE_NUMBER as
14MVF_SHMEM_SEMAPHORE_NUMBER would be undefined.
15
16Upstream-Status: Pending
17
18Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
19---
20 mcc_config.h | 8 +++++---
21 1 file changed, 5 insertions(+), 3 deletions(-)
22
23diff --git a/mcc_config.h b/mcc_config.h
24index 6a12c6d..3887aad 100644
25--- a/mcc_config.h
26+++ b/mcc_config.h
27@@ -18,8 +18,13 @@
28 #ifndef __MCC_CONFIG__
29 #define __MCC_CONFIG__
30
31+#ifdef __KERNEL__
32 #include <linux/mvf_sema4.h>
33
34+/* semaphore number */
35+#define MCC_SHMEM_SEMAPHORE_NUMBER (MVF_SHMEM_SEMAPHORE_NUMBER)
36+#endif
37+
38 /* used OS */
39 #define MCC_OS_USED (MCC_LINUX)
40
41@@ -47,7 +52,4 @@
42 /* other cores, besides this participating in mcc */
43 #define MCC_OTHER_CORES {1}
44
45-/* semaphore number */
46-#define MCC_SHMEM_SEMAPHORE_NUMBER (MVF_SHMEM_SEMAPHORE_NUMBER)
47-
48 #endif /* __MCC_CONFIG__ */
49--
502.1.4
51
diff --git a/recipes-kernel/kernel-modules/kernel-module-mcc_1.06.bb b/recipes-kernel/kernel-modules/kernel-module-mcc_1.06.bb
deleted file mode 100644
index db3eb02..0000000
--- a/recipes-kernel/kernel-modules/kernel-module-mcc_1.06.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1# Copyright (C) 2013 Timesys Corporation
2SUMMARY = "Multicore communication kernel module"
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c8959abcbbe4d6676c58eab9354019e6"
5
6PROVIDES = "virtual/kernel-module-mcc"
7RPROVIDES_${PN} = "virtual/kernel-module-mcc"
8RPROVIDES_${PN}-dev = "virtual/kernel-module-mcc-dev"
9
10inherit module
11
12SRC_URI = "http://repository.timesys.com/buildsources/m/mcc-kmod/mcc-kmod-${PV}/mcc-kmod-${PV}.tar.bz2 \
13 file://mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch"
14
15SRC_URI[md5sum] = "d0507968592af5d8781e8bdbbb249e7d"
16SRC_URI[sha256sum] = "43f834ddf9845da843c7790a307a0dbc8b04a40deed06aed7c3c99ad3a273f6c"
17
18S = "${WORKDIR}/mcc-kmod-${PV}"
19
20COMPATIBLE_MACHINE = "(vf60)"