summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-03-07 16:10:49 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2013-03-08 15:09:11 -0300
commit6034979b860dd8e969d6277d35b1379cfc2375cf (patch)
treee08a52010d3e43f67c4accdebe357715508ea1c7 /recipes-kernel
parent4f22d7f72bd1fe331b1630c28404f988ec943904 (diff)
downloadmeta-fsl-arm-6034979b860dd8e969d6277d35b1379cfc2375cf.tar.gz
linux-fslc: Ensure we have the GIT hash in kernel version
The kernel version ought to show the GIT hash from git repository so it can be used to identify the exact version of code user/customer is using. Change-Id: I19f0ededeb86d54982267d895bb5833ed7bb915c Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-fslc_3.8.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-fslc_3.8.bb b/recipes-kernel/linux/linux-fslc_3.8.bb
index 6cb4511..4b2a020 100644
--- a/recipes-kernel/linux/linux-fslc_3.8.bb
+++ b/recipes-kernel/linux/linux-fslc_3.8.bb
@@ -12,7 +12,7 @@ inherit kernel
12require recipes-kernel/linux/linux-dtb.inc 12require recipes-kernel/linux/linux-dtb.inc
13 13
14PV = "3.8+git${SRCPV}" 14PV = "3.8+git${SRCPV}"
15PR = "r1" 15PR = "r2"
16 16
17# patches-3.8 17# patches-3.8
18SRCREV = "34f2768ffece87712ddfe753e52daf036c57eb29" 18SRCREV = "34f2768ffece87712ddfe753e52daf036c57eb29"
@@ -23,6 +23,11 @@ SRC_URI = "git://github.com/Freescale/linux-mainline.git \
23 23
24S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
25 25
26do_configure_append () {
27 # Ensure we have a proper GIT hash in kernel version
28 rm ${S}/.scmversion
29}
30
26# We need to pass it as param since kernel might support more then one 31# We need to pass it as param since kernel might support more then one
27# machine, with different entry points 32# machine, with different entry points
28EXTRA_OEMAKE += "LOADADDR=${UBOOT_ENTRYPOINT}" 33EXTRA_OEMAKE += "LOADADDR=${UBOOT_ENTRYPOINT}"