summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAndy Voltz <andy.voltz@timesys.com>2013-08-24 19:37:04 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2013-08-29 16:14:22 -0300
commit153fa5053f3cf137e70941c01822972658142740 (patch)
tree7e27eb22965550e323e1613e760f4da349a2d727 /recipes-kernel
parent9d5b271bcfb23f19b17c8e924a07d6a569e82c16 (diff)
downloadmeta-fsl-arm-153fa5053f3cf137e70941c01822972658142740.tar.gz
kernel-module-mcc: Add package
This module is used for communication and synchronization between MQX applications (running on the M4) and Linux (on A5) for Freescale Vybrid platforms. Change-Id: Id37530cc5d5a125e0ef9e3d0f52fce068fef7dff Signed-off-by: Andy Voltz <andy.voltz@timesys.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/kernel-module-mcc/kernel-module-mcc/mcc-kmod-oe-module-makefile.patch37
-rw-r--r--recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.03.bb17
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-module-mcc/kernel-module-mcc/mcc-kmod-oe-module-makefile.patch b/recipes-kernel/kernel-module-mcc/kernel-module-mcc/mcc-kmod-oe-module-makefile.patch
new file mode 100644
index 0000000..dc4b947
--- /dev/null
+++ b/recipes-kernel/kernel-module-mcc/kernel-module-mcc/mcc-kmod-oe-module-makefile.patch
@@ -0,0 +1,37 @@
1OE-Core uses "make modules && make modules install" for kernel modules
2It also uses KERNEL_SRC to specify the kernel source tree location
3
4This patch adds support for modules and modules_install targets, and
5adds logic to pickup INSTALL_MOD_PATH and use KERNEL_SRC
6
7Upstream-status: Pending
8
9diff -Nuarp mcc-kmod-1.03-orig/Makefile mcc-kmod-1.03/Makefile
10--- mcc-kmod-1.03-orig/Makefile 2013-08-12 14:11:56.439711957 -0400
11+++ mcc-kmod-1.03/Makefile 2013-08-12 14:16:03.472603053 -0400
12@@ -3,17 +3,19 @@ mcc-y = mcc_linux.o mcc_shm_linux.o mcc_
13
14 PWD := $(shell pwd)
15
16-EXTRA_CFLAGS += -I$(KERNELDIR)/include -Wno-format
17+EXTRA_CFLAGS += -I$(KERNEL_SRC)/include -Wno-format
18
19-all:
20- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules
21+DESTDIR ?= $(INSTALL_MOD_PATH)
22
23-install: all
24- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install INSTALL_MOD_PATH=$(DESTDIR)
25+modules all:
26+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules
27+
28+modules_install install: all
29+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules_install INSTALL_MOD_PATH=$(DESTDIR)
30 @echo Copying mcc headers to toolchain
31 mkdir -p $(DESTDIR)/usr/include/linux
32 cp -f {mcc_linux.h,mcc_common.h,mcc_config.h} $(DESTDIR)/usr/include/linux/
33
34
35 clean:
36- $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
37+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) clean
diff --git a/recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.03.bb b/recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.03.bb
new file mode 100644
index 0000000..a7fe8e4
--- /dev/null
+++ b/recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.03.bb
@@ -0,0 +1,17 @@
1# Copyright (C) 2013 Timesys Corporation
2SUMMARY = "MCC KERNEL MODULE"
3DESCRIPTION = "Timesys Multicore communication kernel module"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c8959abcbbe4d6676c58eab9354019e6"
6
7inherit module
8
9SRC_URI = "http://repository.timesys.com/buildsources/m/mcc-kmod/mcc-kmod-${PV}/mcc-kmod-${PV}.tar.bz2 \
10 file://mcc-kmod-oe-module-makefile.patch"
11
12SRC_URI[md5sum] = "046b0a86d70b9e3424efc86f442bc335"
13SRC_URI[sha256sum] = "44ed7f812625ef764d62ff0871784ceb155ef86df8932e91830f9222adbf3a9e"
14
15S = "${WORKDIR}/mcc-kmod-${PV}"
16
17COMPATIBLE_MACHINE = "(vf60)"