summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2015-07-24 10:40:48 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-27 17:53:09 -0300
commitcd149228cafda69d75bc959bfdccd3fe43aefad5 (patch)
tree4995ddb8b2b5fc72fb997a52ee3d95f81010fb09 /recipes-graphics
parentf7029f9680ad1052892047e143a5c86acb9f7b1e (diff)
downloadmeta-fsl-arm-cd149228cafda69d75bc959bfdccd3fe43aefad5.tar.gz
mesa-demos: Fix so patches only install for SoC with GPU
Only install patches for SoC with a GPU. Future i.MX 6UltraLite does not have a GPU. Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa-demos_%.bbappend10
1 files changed, 8 insertions, 2 deletions
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend
index 9f675a2..65f3d53 100644
--- a/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -1,6 +1,12 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI_append_mx6 = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ 3MESA-DEMO-PATCH = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \
4 file://fix-clear-build-break.patch" 4 file://fix-clear-build-break.patch"
5
6# only apply patches on mx6 that have a GPU
7SRC_URI_append_mx6q = " ${MESA-DEMO-PATCH}"
8SRC_URI_append_mx6dl = " ${MESA-DEMO-PATCH}"
9SRC_URI_append_mx6sx = " ${MESA-DEMO-PATCH}"
10SRC_URI_append_mx6sl = " ${MESA-DEMO-PATCH}"
5 11
6PACKAGECONFIG_remove_mx6sl = "gles1 gles2" 12PACKAGECONFIG_remove_mx6sl = "gles1 gles2"