summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-20 19:30:38 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 14:07:16 -0300
commit7fd852118c38424e3de4721989f1ae4ac2b5dfd9 (patch)
tree791117251e34572a1750d2e6e76fb18c30b2cd99 /recipes-graphics
parentc996de73838c020a61f5adc87fb668c759e768db (diff)
downloadmeta-fsl-arm-7fd852118c38424e3de4721989f1ae4ac2b5dfd9.tar.gz
mesa: Avoid Vivante GPU headers conflict for gl.h and glext.h
The new GPU release include new GL headers which conflict with the ones provided by mesa. The build fails with: ,---- | ERROR: The recipe imx-gpu-viv is trying to install files into a shared | area when those files already exist. Those files and their manifest | location are: | | .../build-framebuffer/tmp/sysroots/imx6qsabresd/usr/include/GL/gl.h | Matched in manifest-imx6qsabresd-mesa.populate_sysroot | | .../build-framebuffer/tmp/sysroots/imx6qsabresd/usr/include/GL/glext.h | Matched in manifest-imx6qsabresd-mesa.populate_sysroot `---- This removes of the mesa's headers so the ones provided by Vivante are used instead. Fixes [Yocto: #5098]. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 6cc7de7..5030e7a 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -21,7 +21,9 @@ USE_VIV_LIBGL_mx6sx = "yes"
21# FIXME: Dirty hack to allow use of Vivante GPU libGL binary 21# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
22do_install_append_mx6 () { 22do_install_append_mx6 () {
23 if [ "${USE_VIV_LIBGL}" = "yes" ]; then 23 if [ "${USE_VIV_LIBGL}" = "yes" ]; then
24 rm -f ${D}${libdir}/libGL.* 24 rm -f ${D}${libdir}/libGL.* \
25 ${D}${includedir}/GL/gl.h \
26 ${D}${includedir}/GL/glext.h
25 fi 27 fi
26} 28}
27EXTRA_OECONF_mx6 := "${@'${EXTRA_OECONF}'.replace('--enable-glx-tls','--enable-glx')}" 29EXTRA_OECONF_mx6 := "${@'${EXTRA_OECONF}'.replace('--enable-glx-tls','--enable-glx')}"