summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-31 16:49:07 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-08-04 12:33:22 -0300
commit5335986ab1cad7593292f5cb5daa4607535cb7e8 (patch)
treeb22ea1655e771c83867dde3800c54267ec62f2a8 /recipes-graphics
parent48d7e70398f0f9f337b9edaeb29901c9bd895282 (diff)
downloadmeta-fsl-arm-5335986ab1cad7593292f5cb5daa4607535cb7e8.tar.gz
packagegroup-core-directfb: Change override for i.MX6 SoCs with GPU
Fix to support future mx6 i.MX 6UltraLite which does not have a GPU. This SoC will use mesa so mesa changes before should be more SoC specific to allow future mx6 SoC without GPU to use software rendering. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/packagegroups/packagegroup-core-directfb.bbappend13
1 files changed, 11 insertions, 2 deletions
diff --git a/recipes-graphics/packagegroups/packagegroup-core-directfb.bbappend b/recipes-graphics/packagegroups/packagegroup-core-directfb.bbappend
index a95af53..20aa642 100644
--- a/recipes-graphics/packagegroups/packagegroup-core-directfb.bbappend
+++ b/recipes-graphics/packagegroups/packagegroup-core-directfb.bbappend
@@ -1,3 +1,12 @@
1# i.MX6 has DirectFB acceleration support, so add it 1# i.MX6 has DirectFB acceleration support, so add it
2RDEPENDS_${PN}_append_mx6 = " libvivante-dfb-mx6" 2RDEPENDS_${PN}_append_mx6q = " libvivante-dfb-mx6"
3PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}" 3PACKAGE_ARCH_mx6q = "${MACHINE_ARCH}"
4
5RDEPENDS_${PN}_append_mx6dl = " libvivante-dfb-mx6"
6PACKAGE_ARCH_mx6dl = "${MACHINE_ARCH}"
7
8RDEPENDS_${PN}_append_mx6sx = " libvivante-dfb-mx6"
9PACKAGE_ARCH_mx6sx = "${MACHINE_ARCH}"
10
11RDEPENDS_${PN}_append_mx6sl = " libvivante-dfb-mx6"
12PACKAGE_ARCH_mx6sl = "${MACHINE_ARCH}"