diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2013-06-07 14:06:39 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2013-06-07 14:06:39 -0300 |
commit | 60becee986ea14ac1297ccf45879808e67fea239 (patch) | |
tree | dcae7b1da0fee696898b01b4e56f48ec4f7b67bf /recipes-graphics/mesa/mesa_9.1.3.bbappend | |
parent | b6f498097e13d1b4ac1d8b881d39ae8f613f7ffc (diff) | |
download | meta-fsl-arm-60becee986ea14ac1297ccf45879808e67fea239.tar.gz |
mesa: Update bbappend to 9.1.3 version
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/mesa/mesa_9.1.3.bbappend')
-rw-r--r-- | recipes-graphics/mesa/mesa_9.1.3.bbappend | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa_9.1.3.bbappend b/recipes-graphics/mesa/mesa_9.1.3.bbappend new file mode 100644 index 0000000..765e2f8 --- /dev/null +++ b/recipes-graphics/mesa/mesa_9.1.3.bbappend | |||
@@ -0,0 +1,36 @@ | |||
1 | # FIXME: We may need to disable EGL, GL ES1 and GL ES2 | ||
2 | python __anonymous () { | ||
3 | import re | ||
4 | |||
5 | # SoC families to work on | ||
6 | families = ['mx5', 'mx6'] | ||
7 | cur_soc_families = d.getVar('SOC_FAMILY', True) | ||
8 | if cur_soc_families and \ | ||
9 | any(map(lambda x: x in cur_soc_families.split(':'), families)): | ||
10 | # Remove egl gles1 and gles2 configure options | ||
11 | extra_oeconf = d.getVar('EXTRA_OECONF', True).split() | ||
12 | take_out = ['--enable-egl', '--enable-gles1', '--enable-gles2'] | ||
13 | put_in = ['--disable-egl', '--disable-gles1', '--disable-gles2'] | ||
14 | pattern = re.compile("--with-egl-platforms") | ||
15 | new_extra_oeconf = [] | ||
16 | for i in extra_oeconf: | ||
17 | if i not in take_out and not pattern.match(i): | ||
18 | new_extra_oeconf.append(i) | ||
19 | for i in put_in: | ||
20 | new_extra_oeconf.append(i) | ||
21 | |||
22 | d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf)) | ||
23 | |||
24 | # Remove itens from provides | ||
25 | provides = d.getVar('PROVIDES', True).split() | ||
26 | take_out = ['virtual/libgles1', 'virtual/libgles2', 'virtual/egl'] | ||
27 | new_provides = [] | ||
28 | for i in provides: | ||
29 | if i not in take_out: | ||
30 | new_provides.append(i) | ||
31 | |||
32 | d.setVar('PROVIDES', ' '.join(new_provides)) | ||
33 | |||
34 | # We are now machine specific | ||
35 | d.setVar('PACKAGE_ARCH', d.getVar('MACHINE_ARCH')) | ||
36 | } | ||