summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/gpu-viv-bin-mx6q
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-07-18 12:19:54 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2013-08-29 16:14:23 -0300
commitdeb0bf5d6fd0da826b96cd4d6fe9784df4a9fa11 (patch)
tree56a417b526036157c840fd81381a464afe1171d7 /recipes-graphics/gpu-viv-bin-mx6q
parent1e4b13cfee96a2f16cea667e3589b2eff5ca54f3 (diff)
downloadmeta-fsl-arm-deb0bf5d6fd0da826b96cd4d6fe9784df4a9fa11.tar.gz
gpu-viv-bin-mx6q (3.5.7-1.0.0-alpha.2): Add Hard and Soft Float-Point releases
Include the 3.5.7-1.0.0-alpha.2 version of GPU and the mechanism to allow this to be matched for compatibility. When adding a package of: Hard Float-Point, set: PACKAGE_FP_TYPE = "hardfp" Soft Float-Point, set: PACKAGE_FP_TYPE = "softfp" This GPU driver includes following changes/improvements: - GLES20 window mode performance is optimized for improved performance. - glmark2-es2 crashed fixed as documented: Workaround [YOCTO: #4954] so it outputs an error. A fix for it is being developed. - glmark2-es2 performance in windowed mode. Fixes [YOCTO: 4950] This change has been based on changes done in meta-fsl-bsp-release, 3.5.7 dylan branch, by Lauren Post <lauren.post@freescale.com> and Evan Kotara <evan.kotara@freescale.com>. Change-Id: If71a18df232282862ecd551d96e627b975238134 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/gpu-viv-bin-mx6q')
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc12
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.0.35-4.0.0.bb17
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-hfp.bb12
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-sfp.bb12
4 files changed, 36 insertions, 17 deletions
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
index d9032b2..0a53900 100644
--- a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
+++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
@@ -43,6 +43,18 @@ PACKAGES =+ "libclc-mx6 libclc-mx6-dev libclc-mx6-dbg \
43 libwayland-egl-mx6-dev \ 43 libwayland-egl-mx6-dev \
44" 44"
45 45
46# Skip package if it does not match the machine float-point type in use
47python __anonymous () {
48 is_machine_hardfp = base_contains("TUNE_FEATURES", "callconvention-hard", True, False, d)
49 is_package_hardfp = d.getVar("PACKAGE_FP_TYPE", True) == "hardfp"
50
51 if is_package_hardfp != is_machine_hardfp:
52 PN = d.getVar("PN", True)
53 PV = d.getVar("PV", True)
54 bb.debug(1, "Skipping %s (%s) as machine and package float-point does not match" % (PN, PV))
55 raise bb.parse.SkipPackage("Package Float-Point is not compatible with the machine")
56}
57
46USE_X11 = "${@base_contains("DISTRO_FEATURES", "x11", "yes", "no", d)}" 58USE_X11 = "${@base_contains("DISTRO_FEATURES", "x11", "yes", "no", d)}"
47USE_DFB = "${@base_contains("DISTRO_FEATURES", "directfb", "yes", "no", d)}" 59USE_DFB = "${@base_contains("DISTRO_FEATURES", "directfb", "yes", "no", d)}"
48USE_WL = "${@base_contains("DISTRO_FEATURES", "wayland", "yes", "no", d)}" 60USE_WL = "${@base_contains("DISTRO_FEATURES", "wayland", "yes", "no", d)}"
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.0.35-4.0.0.bb b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.0.35-4.0.0.bb
deleted file mode 100644
index d8e00ef..0000000
--- a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.0.35-4.0.0.bb
+++ /dev/null
@@ -1,17 +0,0 @@
1# Copyright (C) 2012-2013 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4PR = "r5.0"
5
6include gpu-viv-bin-mx6q.inc
7
8SRC_URI += "file://0001-change-header-path-to-HAL.patch \
9 file://gc_hal_eglplatform-remove-xlib-undefs.patch \
10 file://fix-conflicting-TLS-definition.patch"
11
12SRC_URI[md5sum] = "2bb7d2f4bdff79ae99ce0c9fc2540701"
13SRC_URI[sha256sum] = "48d04d11c6fec11411bcd97c47199caea517ebcd86db6c70f1964b3358a68924"
14
15# FIXME: 3.0.35-4.0.0 BSP release uses DirectFB 1.4 and Yocto has 1.6 so
16# disable it for now
17USE_DFB = "no"
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-hfp.bb b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-hfp.bb
new file mode 100644
index 0000000..a55e988
--- /dev/null
+++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-hfp.bb
@@ -0,0 +1,12 @@
1# Copyright (C) 2013 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4include gpu-viv-bin-mx6q.inc
5
6SRC_URI += "file://0001-change-header-path-to-HAL.patch \
7 file://gc_hal_eglplatform-remove-xlib-undefs.patch"
8
9SRC_URI[md5sum] = "f5f4e2e7767c784315461c132929e7d3"
10SRC_URI[sha256sum] = "f16747ee5ae2e88631cc1494db98f7b5762940c7db25795906b7cc8f87405caf"
11
12PACKAGE_FP_TYPE = "hardfp"
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-sfp.bb b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-sfp.bb
new file mode 100644
index 0000000..2383fb7
--- /dev/null
+++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-sfp.bb
@@ -0,0 +1,12 @@
1# Copyright (C) 2013 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4include gpu-viv-bin-mx6q.inc
5
6SRC_URI += "file://0001-change-header-path-to-HAL.patch \
7 file://gc_hal_eglplatform-remove-xlib-undefs.patch"
8
9SRC_URI[md5sum] = "ef08a4ad04c7886a44af16e826d0f444"
10SRC_URI[sha256sum] = "e212e361044eb1f9089761e115e71b27dab67c832ebb1ddbc830c17d2b1e2fba"
11
12PACKAGE_FP_TYPE = "softfp"