summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2015-01-08 15:07:12 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-13 11:07:12 -0200
commitbff60d68c91f3affea33295779acf4c47d20b3bd (patch)
tree15662abb0e7ce6df12c15421a2f96ec3142005df /recipes-devtools
parent568439bd74971f28aafa2baa608ded9b37f93fa6 (diff)
downloadmeta-fsl-arm-bff60d68c91f3affea33295779acf4c47d20b3bd.tar.gz
cst: add recipes for Layerscape1 support
cst is the utility for security boot. Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/cst/cst_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-devtools/cst/cst_git.bb b/recipes-devtools/cst/cst_git.bb
new file mode 100644
index 0000000..0684a26
--- /dev/null
+++ b/recipes-devtools/cst/cst_git.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "CST Tool"
2SECTION = "cst"
3LICENSE = "BSD"
4
5# TODO: fix license - this file is not a license
6LIC_FILES_CHKSUM = "file://RELEASENOTES;beginline=8;endline=43;md5=5a7b22a2c96b5f94e0498c5f413aa8d3"
7
8DEPENDS += "openssl"
9
10inherit kernel-arch
11
12SRC_URI = "git://git.freescale.com/ppc/sdk/cst.git;branch=sdk-v1.7.x"
13SRCREV = "2d35e98539c0daa2bc8049e3bd44994d3d93bbe7"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
18
19PARALLEL_MAKE = ""
20
21do_install () {
22 oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir}
23}
24
25FILES_${PN}-dbg += "${bindir}/cst/.debug"
26BBCLASSEXTEND = "native nativesdk"