summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorHector Palacios <hector.palacios@digi.com>2016-03-03 17:29:54 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2016-03-11 08:00:16 -0300
commit37564e6801ce82fad979b4f57151c676d80e8a6c (patch)
treec3277d02768f102ccb8596e59b715b89fc68c4fa /recipes-devtools
parent3154c40c3ee7cf43fdb2b0e787898e7aa3ee5dd5 (diff)
downloadmeta-fsl-arm-37564e6801ce82fad979b4f57151c676d80e8a6c.tar.gz
imx-usb-loader: add recipe
This includes into the SDK Boundary Devices i.MX/Vybrid recovery utility, a host tool which allows to boot an image via USB in serial downloader mode. It currently supports i.MX5, i.MX6, i.MX7, and Vybrid families. Signed-off-by: Hector Palacios <hector.palacios@digi.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb b/recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb
new file mode 100644
index 0000000..6753f53
--- /dev/null
+++ b/recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "i.MX/Vybrid recovery utility"
2SECTION = "devel"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6DEPENDS = "libusb"
7
8SRCREV = "349286e25c3fd9b2d31b31e962340123bbc62d44"
9SRC_URI = "git://github.com/boundarydevices/imx_usb_loader.git;protocol=http"
10
11PV = "1.0+${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15do_install () {
16 oe_runmake DESTDIR=${D} install
17}
18
19BBCLASSEXTEND = "native nativesdk"