summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-03-24 18:23:00 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2012-03-24 18:28:14 +0000
commitd75b5339c2721ac32156ac5481628d8a40ad6d22 (patch)
treede5552d01597fc213529b6faedc60961e85c57ab /recipes-core
parent0485c60ff7794de5a2f2af0ddb9e8e6b78ecdbc1 (diff)
downloadmeta-fsl-arm-d75b5339c2721ac32156ac5481628d8a40ad6d22.tar.gz
udev: remove OE-Core 164 release
OE-Core will be branching to Yocto's 2012 first release soon and udev version won't be change until that. We are currently focusing this release and removing this duplicated source avoids the need of udev fixes done in Yocto's branch to be backported. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/udev/udev.inc83
-rw-r--r--recipes-core/udev/udev/devfs-udev.rules108
-rw-r--r--recipes-core/udev/udev/init59
-rw-r--r--recipes-core/udev/udev/links.conf21
-rw-r--r--recipes-core/udev/udev/local.rules35
-rw-r--r--recipes-core/udev/udev/mount.sh68
-rw-r--r--recipes-core/udev/udev/network.sh55
-rw-r--r--recipes-core/udev/udev/permissions.rules131
-rw-r--r--recipes-core/udev/udev/run.rules14
-rw-r--r--recipes-core/udev/udev/udev-166-v4l1-1.patch50
-rw-r--r--recipes-core/udev/udev/udev-cache20
-rw-r--r--recipes-core/udev/udev/udev.rules116
-rw-r--r--recipes-core/udev/udev_164.bb8
13 files changed, 0 insertions, 768 deletions
diff --git a/recipes-core/udev/udev.inc b/recipes-core/udev/udev.inc
deleted file mode 100644
index 0e571d6..0000000
--- a/recipes-core/udev/udev.inc
+++ /dev/null
@@ -1,83 +0,0 @@
1SUMMARY = "/dev/ and hotplug management daemon"
2DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \
3/dev/, handles hotplug events and loads drivers at boot time."
4HOMEPAGE = "http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
5LICENSE = "GPLv2.0+ & LGPLv2.1+"
6LICENSE_${PN} = "GPLv2.0+"
7LICENSE_libudev = "LGPLv2.1+"
8LICENSE_libgudev = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
10 file://libudev/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
11 file://extras/gudev/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
12
13DEPENDS = "acl glib-2.0 libusb usbutils pciutils gperf-native libxslt-native"
14RPROVIDES_${PN} = "hotplug"
15RRECOMMENDS_${PN} += "udev-extraconf udev-cache usbutils-ids pciutils-ids"
16RDEPENDS_libudev = "${PN} (= ${EXTENDPKGV})"
17
18SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
19 file://run.rules \
20 file://udev.rules \
21 file://devfs-udev.rules \
22 file://links.conf \
23 file://permissions.rules \
24 file://mount.sh \
25 file://network.sh \
26 file://local.rules \
27 file://udev-cache \
28 file://init"
29
30inherit autotools pkgconfig update-rc.d
31
32# udevd/udevadm -> /sbin/, libudev.so.* -> /lib/
33sbindir = "${base_sbindir}"
34libexecdir = "${base_libdir}/udev"
35EXTRA_OECONF = "--disable-introspection --with-rootlibdir=${base_libdir} \
36 --with-pci-ids-path=${datadir}/pci.ids"
37
38PACKAGES =+ "udev-acl udev-consolekit udev-utils"
39PACKAGES =+ "udev-cache libudev libudev-dev libudev-dbg"
40PACKAGES =+ "libgudev libgudev-dev libgudev-dbg"
41
42INITSCRIPT_PACKAGES = "udev udev-cache"
43INITSCRIPT_NAME_udev = "udev"
44INITSCRIPT_PARAMS_udev = "start 03 S ."
45INITSCRIPT_NAME_udev-cache = "udev-cache"
46INITSCRIPT_PARAMS_udev-cache = "start 36 S ."
47
48FILES_${PN} += "${libexecdir} ${libdir}/ConsoleKit"
49RRECOMMENDS_${PN} += "udev-utils"
50
51FILES_${PN}-dbg += "${libexecdir}/.debug"
52FILES_${PN}-dev = "${datadir}/pkgconfig/udev.pc"
53FILES_libudev = "${base_libdir}/libudev.so.*"
54FILES_libudev-dbg = "${base_libdir}/.debug/libudev.so.*"
55FILES_libudev-dev = "${includedir}/libudev.h ${libdir}/libudev.so ${libdir}/libudev.la \
56 ${libdir}/libudev.a ${libdir}/pkgconfig/libudev.pc"
57FILES_libgudev = "${base_libdir}/libgudev*.so.* ${libdir}/libgudev*.so.*"
58FILES_libgudev-dbg = "${base_libdir}/.debug/libgudev*.so.* ${libdir}/.debug/libgudev*.so.*"
59FILES_libgudev-dev = "${includedir}/gudev* ${libdir}/libgudev*.so ${libdir}/libgudev*.la \
60 ${libdir}/libgudev*.a ${libdir}/pkgconfig/gudev*.pc"
61FILES_udev-cache = "${sysconfdir}/init.d/udev-cache"
62
63FILES_udev-acl = "${base_libdir}/udev/udev-acl ${base_libdir}/udev/rules.d/70-acl.rules"
64
65FILES_udev-utils = "${bindir}/udevinfo ${bindir}/udevtest ${base_sbindir}/udevadm"
66
67RDEPENDS_udev-consolekit += "udev-acl"
68FILES_udev-consolekit = "${libdir}/ConsoleKit"
69
70do_install_append () {
71 install -d ${D}${sysconfdir}/init.d
72 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/udev
73 install -m 0755 ${WORKDIR}/udev-cache ${D}${sysconfdir}/init.d/udev-cache
74
75 install -d ${D}${sysconfdir}/udev/rules.d/
76
77 install -m 0644 ${WORKDIR}/local.rules ${D}${sysconfdir}/udev/rules.d/local.rules
78
79 install -d ${D}${sysconfdir}/udev/scripts/
80
81 install -m 0755 ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh
82 install -m 0755 ${WORKDIR}/network.sh ${D}${sysconfdir}/udev/scripts
83}
diff --git a/recipes-core/udev/udev/devfs-udev.rules b/recipes-core/udev/udev/devfs-udev.rules
deleted file mode 100644
index 0ba1ad4..0000000
--- a/recipes-core/udev/udev/devfs-udev.rules
+++ /dev/null
@@ -1,108 +0,0 @@
1# The use of these rules is not recommended or supported.
2# In a world where devices can come and go at any time, the devfs scheme
3# of simple device enumeration does not help _anything_. Just forget about
4# it. Use custom rules to name your device or look at the persistent device
5# naming scheme, which is implemented for disks and add your subsystem.
6
7# ide block devices
8BUS="ide", KERNEL="hd*", PROGRAM="/etc/udev/ide-devfs.sh %k %b %n", NAME="%k", SYMLINK="%c{1} %c{2}"
9
10# md block devices
11KERNEL="md[0-9]*", NAME="md/%n"
12
13# floppy devices
14KERNEL="fd[0-9]*", NAME="floppy/%n"
15
16# tty devices
17KERNEL="tty[0-9]*", NAME="vc/%n", SYMLINK="%k"
18KERNEL="ttyS[0-9]*", NAME="tts/%n", SYMLINK="%k"
19KERNEL="ttyUSB[0-9]*", NAME="tts/USB%n"
20
21# vc devices
22KERNEL="vcs", NAME="vcc/0"
23KERNEL="vcs[0-9]*", NAME="vcc/%n"
24KERNEL="vcsa", NAME="vcc/a0"
25KERNEL="vcsa[0-9]*", NAME="vcc/a%n"
26
27# v4l devices
28KERNEL="video[0-9]*", NAME="v4l/video%n"
29KERNEL="radio[0-9]*", NAME="v4l/radio%n"
30KERNEL="vbi[0-9]*", NAME="v4l/vbi%n"
31KERNEL="vtx[0-9]*", NAME="v4l/vtx%n"
32
33# dm devices (ignore them)
34KERNEL="dm-[0-9]*", NAME=""
35
36# i2c devices
37KERNEL="i2c-[0-9]*", NAME="i2c/%n", SYMLINK="%k"
38
39# loop devices
40KERNEL="loop[0-9]*", NAME="loop/%n", SYMLINK="%k"
41
42# ramdisks
43KERNEL="ram[0-9]*", NAME="rd/%n", SYMLINK="%k"
44
45# framebuffer devices
46KERNEL="fb[0-9]*", NAME="fb/%n", SYMLINK="%k"
47
48# misc
49KERNEL="rtc", NAME="misc/%k", SYMLINK="%k"
50KERNEL="psaux", NAME="misc/%k", SYMLINK="%k"
51KERNEL="agpgart", NAME="misc/%k", SYMLINK="%k"
52KERNEL="rtc", NAME="misc/%k", SYMLINK="%k"
53KERNEL="psaux", NAME="misc/%k", SYMLINK="%k"
54KERNEL="uinput", NAME="misc/%k", SYMLINK="%k"
55
56# alsa devices
57KERNEL="controlC[0-9]*", NAME="snd/%k"
58KERNEL="hw[CD0-9]*", NAME="snd/%k"
59KERNEL="pcm[CD0-9cp]*", NAME="snd/%k"
60KERNEL="midi[CD0-9]*", NAME="snd/%k"
61KERNEL="timer", NAME="snd/%k"
62KERNEL="seq", NAME="snd/%k"
63
64# oss devices
65KERNEL="audio*", NAME="sound/%k", SYMLINK="%k"
66KERNEL="dmmidi", NAME="sound/%k", SYMLINK="%k"
67KERNEL="dsp*", NAME="sound/%k", SYMLINK="%k"
68KERNEL="midi*", NAME="sound/%k", SYMLINK="%k"
69KERNEL="mixer*", NAME="sound/%k", SYMLINK="%k"
70KERNEL="sequencer*", NAME="sound/%k", SYMLINK="%k"
71
72# input devices
73KERNEL="mice", NAME="input/%k"
74KERNEL="mouse*", NAME="input/%k"
75KERNEL="event*", NAME="input/%k"
76KERNEL="js*", NAME="input/%k"
77KERNEL="ts*", NAME="input/%k"
78
79# USB devices
80KERNEL="hiddev*", NAME="usb/%k"
81KERNEL="auer*", NAME="usb/%k"
82KERNEL="legousbtower*", NAME="usb/%k"
83KERNEL="dabusb*", NAME="usb/%k"
84BUS="usb", KERNEL="lp[0-9]*", NAME="usb/%k"
85
86# netlink devices
87KERNEL="route", NAME="netlink/%k"
88KERNEL="skip", NAME="netlink/%k"
89KERNEL="usersock", NAME="netlink/%k"
90KERNEL="fwmonitor", NAME="netlink/%k"
91KERNEL="tcpdiag", NAME="netlink/%k"
92KERNEL="nflog", NAME="netlink/%k"
93KERNEL="xfrm", NAME="netlink/%k"
94KERNEL="arpd", NAME="netlink/%k"
95KERNEL="route6", NAME="netlink/%k"
96KERNEL="ip6_fw", NAME="netlink/%k"
97KERNEL="dnrtmsg", NAME="netlink/%k"
98KERNEL="tap*", NAME="netlink/%k"
99
100# CAPI devices
101KERNEL="capi", NAME="capi20", SYMLINK="isdn/capi20"
102KERNEL="capi*", NAME="capi/%n"
103
104# Network devices
105KERNEL="tun", NAME="net/%k"
106
107# raw devices
108KERNEL="raw[0-9]*", NAME="raw/%k"
diff --git a/recipes-core/udev/udev/init b/recipes-core/udev/udev/init
deleted file mode 100644
index 6a4464c..0000000
--- a/recipes-core/udev/udev/init
+++ /dev/null
@@ -1,59 +0,0 @@
1#!/bin/sh -e
2
3### BEGIN INIT INFO
4# Provides: udev
5# Required-Start: mountvirtfs
6# Required-Stop:
7# Default-Start: S
8# Default-Stop:
9# Short-Description: Start udevd, populate /dev and load drivers.
10### END INIT INFO
11
12export TZ=/etc/localtime
13
14[ -d /sys/class ] || exit 1
15[ -r /proc/mounts ] || exit 1
16[ -x /sbin/udevd ] || exit 1
17[ -f /etc/udev/udev.conf ] && . /etc/udev/udev.conf
18
19kill_udevd() {
20 if [ -x /sbin/pidof ]; then
21 pid=`/sbin/pidof -x udevd`
22 [ -n "$pid" ] && kill $pid
23 fi
24}
25
26export ACTION=add
27# propagate /dev from /sys
28echo "Starting udev"
29
30# mount the tmpfs on /dev, if not already done
31LANG=C awk '$2 == "/dev" && ($3 == "tmpfs" || $3 == "devtmpfs") { exit 1 }' /proc/mounts && {
32 mount -n -o mode=0755 -t tmpfs none "/dev"
33}
34[ -e /dev/pts ] || mkdir -m 0755 /dev/pts
35[ -e /dev/shm ] || mkdir -m 1777 /dev/shm
36
37
38if [ -e /etc/dev.tar ]; then
39 (cd /; tar xf /etc/dev.tar 2>&1 | grep -v 'time stamp' || true)
40 not_first_boot=1
41fi
42
43# make_extra_nodes
44kill_udevd > "/dev/null" 2>&1
45
46# trigger the sorted events
47echo -e '\000\000\000\000' > /proc/sys/kernel/hotplug
48/sbin/udevd -d
49
50/sbin/udevadm control --env=STARTUP=1
51if [ "$not_first_boot" != "" ];then
52 /sbin/udevadm trigger --action=add --subsystem-nomatch=tty --subsystem-nomatch=mem --subsystem-nomatch=vc --subsystem-nomatch=vtconsole --subsystem-nomatch=misc --subsystem-nomatch=dcon --subsystem-nomatch=pci_bus --subsystem-nomatch=graphics --subsystem-nomatch=backlight --subsystem-nomatch=video4linux --subsystem-nomatch=platform
53 (/sbin/udevadm settle --timeout=3; /sbin/udevadm control --env=STARTUP=)&
54else
55 /sbin/udevadm trigger --action=add
56 /sbin/udevadm settle
57fi
58
59exit 0
diff --git a/recipes-core/udev/udev/links.conf b/recipes-core/udev/udev/links.conf
deleted file mode 100644
index 8fff922..0000000
--- a/recipes-core/udev/udev/links.conf
+++ /dev/null
@@ -1,21 +0,0 @@
1# This file does not exist. Please do not ask the debian maintainer about it.
2# You may use it to do strange and wonderful things, at your risk.
3
4L fd /proc/self/fd
5L stdin /proc/self/fd/0
6L stdout /proc/self/fd/1
7L stderr /proc/self/fd/2
8L core /proc/kcore
9L sndstat /proc/asound/oss/sndstat
10L MAKEDEV /sbin/MAKEDEV
11
12D pts
13D shm
14
15# Hic sunt leones.
16M ppp c 108 0
17D loop
18M loop/0 b 7 0
19D net
20M net/tun c 10 200
21
diff --git a/recipes-core/udev/udev/local.rules b/recipes-core/udev/udev/local.rules
deleted file mode 100644
index 625e49a..0000000
--- a/recipes-core/udev/udev/local.rules
+++ /dev/null
@@ -1,35 +0,0 @@
1# There are a number of modifiers that are allowed to be used in some
2# of the different fields. They provide the following subsitutions:
3#
4# %n the "kernel number" of the device.
5# For example, 'sda3' has a "kernel number" of '3'
6# %e the smallest number for that name which does not matches an existing node
7# %k the kernel name for the device
8# %M the kernel major number for the device
9# %m the kernel minor number for the device
10# %b the bus id for the device
11# %c the string returned by the PROGRAM
12# %s{filename} the content of a sysfs attribute
13# %% the '%' char itself
14#
15
16# Media automounting
17SUBSYSTEM=="block", ACTION=="add" RUN+="/etc/udev/scripts/mount.sh"
18SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
19
20# Handle network interface setup
21SUBSYSTEM=="net", ACTION=="add" RUN+="/etc/udev/scripts/network.sh"
22SUBSYSTEM=="net", ACTION=="remove" RUN+="/etc/udev/scripts/network.sh"
23
24# The first framebuffer is symlinked to /dev/fb
25KERNEL=="fb0", SYMLINK+="fb"
26
27# The first rtc device is symlinked to /dev/rtc
28KERNEL=="rtc0", SYMLINK+="rtc"
29
30# Try and modprobe for drivers for new hardware
31ACTION=="add", DEVPATH=="/devices/*", ENV{MODALIAS}=="?*", RUN+="/sbin/modprobe $env{MODALIAS}"
32
33# Create a symlink to any touchscreen input device
34SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="input:*-e0*,3,*a0,1,*18,*", SYMLINK+="input/touchscreen0"
35
diff --git a/recipes-core/udev/udev/mount.sh b/recipes-core/udev/udev/mount.sh
deleted file mode 100644
index 53fefa3..0000000
--- a/recipes-core/udev/udev/mount.sh
+++ /dev/null
@@ -1,68 +0,0 @@
1#!/bin/sh
2#
3# Called from udev
4#
5# Attempt to mount any added block devices and umount any removed devices
6
7
8MOUNT="/bin/mount"
9PMOUNT="/usr/bin/pmount"
10UMOUNT="/bin/umount"
11
12for line in `cat /etc/udev/mount.blacklist`
13do
14 if [ ` expr match "$DEVNAME" "$line" ` -gt 0 ];
15 then
16 logger "udev/mount.sh" "[$DEVNAME] is blacklisted, ignoring"
17 exit 0
18 fi
19done
20
21automount() {
22 name="`basename "$DEVNAME"`"
23
24 ! test -d "/media/$name" && mkdir -p "/media/$name"
25
26 if ! $MOUNT -t auto -o sync $DEVNAME "/media/$name"
27 then
28 #logger "mount.sh/automount" "$MOUNT -t auto $DEVNAME \"/media/$name\" failed!"
29 rm_dir "/media/$name"
30 else
31 logger "mount.sh/automount" "Auto-mount of [/media/$name] successful"
32 touch "/tmp/.automount-$name"
33 fi
34}
35
36rm_dir() {
37 # We do not want to rm -r populated directories
38 if test "`find "$1" | wc -l | tr -d " "`" -lt 2 -a -d "$1"
39 then
40 ! test -z "$1" && rm -r "$1"
41 else
42 logger "mount.sh/automount" "Not removing non-empty directory [$1]"
43 fi
44}
45
46if [ "$ACTION" = "add" ] && [ -n "$DEVNAME" ]; then
47 if [ -x "$PMOUNT" ]; then
48 $PMOUNT $DEVNAME 2> /dev/null
49 elif [ -x $MOUNT ]; then
50 $MOUNT $DEVNAME 2> /dev/null
51 fi
52
53 # If the device isn't mounted at this point, it isn't configured in fstab
54 grep -q "^$DEVNAME " /proc/mounts || automount
55fi
56
57
58
59if [ "$ACTION" = "remove" ] && [ -x "$UMOUNT" ] && [ -n "$DEVNAME" ]; then
60 for mnt in `cat /proc/mounts | grep "$DEVNAME" | cut -f 2 -d " " `
61 do
62 $UMOUNT $mnt
63 done
64
65 # Remove empty directories from auto-mounter
66 name="`basename "$DEVNAME"`"
67 test -e "/tmp/.automount-$name" && rm_dir "/media/$name"
68fi
diff --git a/recipes-core/udev/udev/network.sh b/recipes-core/udev/udev/network.sh
deleted file mode 100644
index 5016328..0000000
--- a/recipes-core/udev/udev/network.sh
+++ /dev/null
@@ -1,55 +0,0 @@
1#!/bin/sh
2
3# Do not run when pcmcia-cs is installed
4test -x /sbin/cardctl && exit 0
5
6# We get two "add" events for hostap cards due to wifi0
7echo "$INTERFACE" | grep -q wifi && exit 0
8
9
10# Check if /etc/init.d/network has been run yet to see if we are
11# called by starting /etc/rcS.d/S03udev and not by hotplugging a device
12#
13# At this stage, network interfaces should not be brought up
14# automatically because:
15# a) /etc/init.d/network has not been run yet (security issue)
16# b) /var has not been populated yet so /etc/resolv,conf points to
17# oblivion, making the network unusable
18#
19
20spoofp="`grep ^spoofprotect /etc/network/options`"
21if test -z "$spoofp"
22then
23 # This is the default from /etc/init.d/network
24 spoofp_val=yes
25else
26 spoofp_val=${spoofp#spoofprotect=}
27fi
28
29test "$spoofp_val" = yes && spoofp_val=1 || spoofp_val=0
30
31# I think it is safe to assume that "lo" will always be there ;)
32if test "`cat /proc/sys/net/ipv4/conf/lo/rp_filter`" != "$spoofp_val" -a -n "$spoofp_val"
33then
34 echo "$INTERFACE" >> /dev/udev_network_queue
35 exit 0
36fi
37
38#
39# Code taken from pcmcia-cs:/etc/pcmcia/network
40#
41
42# if this interface has an entry in /etc/network/interfaces, let ifupdown
43# handle it
44if grep -q "iface \+$INTERFACE" /etc/network/interfaces; then
45 case $ACTION in
46 add)
47 ifconfig | grep -q "^$INTERFACE" || ifup $INTERFACE
48 ;;
49 remove)
50 ifdown $INTERFACE
51 ;;
52 esac
53
54 exit 0
55fi
diff --git a/recipes-core/udev/udev/permissions.rules b/recipes-core/udev/udev/permissions.rules
deleted file mode 100644
index 205b733..0000000
--- a/recipes-core/udev/udev/permissions.rules
+++ /dev/null
@@ -1,131 +0,0 @@
1ACTION!="add", GOTO="permissions_end"
2
3# workarounds needed to synchronize with sysfs
4# only needed for kernels < v2.6.18-rc1
5ENV{PHYSDEVPATH}!="?*", ENV{PHYSDEVBUS}=="?*", WAIT_FOR_SYSFS="bus"
6SUBSYSTEM=="scsi", KERNEL=="[0-9]*:[0-9]*", WAIT_FOR_SYSFS="ioerr_cnt"
7# only needed for kernels < 2.6.16
8SUBSYSTEM=="net", WAIT_FOR_SYSFS="address"
9# only needed for kernels < 2.6.17
10SUBSYSTEM=="net", ENV{DRIVER}=="?*", WAIT_FOR_SYSFS="device/driver"
11
12# devices needed to load the drivers providing them
13KERNEL=="tun", OPTIONS+="ignore_remove"
14KERNEL=="ppp", OPTIONS+="ignore_remove"
15KERNEL=="loop[0-9]*", OPTIONS+="ignore_remove"
16
17# default permissions for block devices
18SUBSYSTEM=="block", GROUP="disk"
19# the aacraid driver is broken and reports that disks removable (see #404927)
20SUBSYSTEM=="block", ATTRS{removable}=="1", \
21 DRIVERS!="aacraid", GROUP="floppy"
22# all block devices on these buses are "removable"
23SUBSYSTEM=="block", SUBSYSTEMS=="usb|ieee1394|mmc|pcmcia", GROUP="floppy"
24
25# IDE devices
26KERNEL=="hd[a-z]|pcd[0-9]*", DRIVERS=="ide-cdrom|pcd", \
27 IMPORT{program}="cdrom_id --export $tempnode"
28ENV{ID_CDROM}=="?*", GROUP="cdrom"
29KERNEL=="ht[0-9]*", GROUP="tape"
30KERNEL=="nht[0-9]*", GROUP="tape"
31
32# SCSI devices
33KERNEL=="sr[0-9]*", IMPORT{program}="cdrom_id --export $tempnode"
34SUBSYSTEMS=="scsi", ATTRS{type}=="1", GROUP="tape"
35SUBSYSTEMS=="scsi", ATTRS{type}=="3", ATTRS{vendor}=="HP", GROUP="scanner"
36SUBSYSTEMS=="scsi", ATTRS{type}=="3", ATTRS{vendor}=="Epson", GROUP="scanner"
37SUBSYSTEMS=="scsi", ATTRS{type}=="3", ATTRS{vendor}=="EPSON", GROUP="scanner"
38SUBSYSTEMS=="scsi", ATTRS{type}=="4", GROUP="cdrom"
39SUBSYSTEMS=="scsi", ATTRS{type}=="5", GROUP="cdrom"
40SUBSYSTEMS=="scsi", ATTRS{type}=="6", GROUP="scanner"
41SUBSYSTEMS=="scsi", ATTRS{type}=="8", GROUP="tape"
42
43# USB devices
44KERNEL=="legousbtower*", MODE="0666"
45KERNEL=="lp[0-9]*", SUBSYSTEMS=="usb", GROUP="lp"
46
47# usbfs-like devices
48SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", \
49 MODE="0664"
50
51# iRiver music players
52SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", GROUP="plugdev", \
53 ATTRS{idVendor}=="4102", ATTRS{idProduct}=="10[01][135789]"
54
55# serial devices
56SUBSYSTEM=="tty", GROUP="dialout"
57SUBSYSTEM=="capi", GROUP="dialout"
58SUBSYSTEM=="slamr", GROUP="dialout"
59SUBSYSTEM=="zaptel", GROUP="dialout"
60
61# vc devices (all members of the tty subsystem)
62KERNEL=="ptmx", MODE="0666", GROUP="root"
63KERNEL=="console", MODE="0600", GROUP="root"
64KERNEL=="tty", MODE="0666", GROUP="root"
65KERNEL=="tty[0-9]*", GROUP="root"
66KERNEL=="pty*", MODE="0666", GROUP="tty"
67
68# video devices
69SUBSYSTEM=="video4linux", GROUP="video"
70SUBSYSTEM=="drm", GROUP="video"
71SUBSYSTEM=="dvb", GROUP="video"
72SUBSYSTEM=="em8300", GROUP="video"
73SUBSYSTEM=="graphics", GROUP="video"
74SUBSYSTEM=="nvidia", GROUP="video"
75
76# misc devices
77KERNEL=="random", MODE="0666"
78KERNEL=="urandom", MODE="0666"
79KERNEL=="mem", MODE="0640", GROUP="kmem"
80KERNEL=="kmem", MODE="0640", GROUP="kmem"
81KERNEL=="port", MODE="0640", GROUP="kmem"
82KERNEL=="full", MODE="0666"
83KERNEL=="null", MODE="0666"
84KERNEL=="zero", MODE="0666"
85KERNEL=="inotify", MODE="0666"
86KERNEL=="sgi_fetchop", MODE="0666"
87KERNEL=="sonypi", MODE="0666"
88KERNEL=="agpgart", GROUP="video"
89KERNEL=="nvram", GROUP="nvram"
90KERNEL=="rtc|rtc[0-9]*", GROUP="audio"
91KERNEL=="tpm*", MODE="0600", OWNER="tss", GROUP="tss"
92KERNEL=="fuse", GROUP="fuse"
93KERNEL=="kqemu", MODE="0666"
94KERNEL=="kvm", GROUP="kvm"
95KERNEL=="tun", MODE="0666",
96
97KERNEL=="cdemu[0-9]*", GROUP="cdrom"
98KERNEL=="pktcdvd[0-9]*", GROUP="cdrom"
99KERNEL=="pktcdvd", MODE="0644"
100
101KERNEL=="uverbs*", GROUP="rdma"
102KERNEL=="ucm*", GROUP="rdma"
103KERNEL=="rdma_ucm", GROUP="rdma"
104
105# printers and parallel devices
106SUBSYSTEM=="printer", GROUP="lp"
107SUBSYSTEM=="ppdev", GROUP="lp"
108KERNEL=="irlpt*", GROUP="lp"
109KERNEL=="pt[0-9]*", GROUP="tape"
110KERNEL=="pht[0-9]*", GROUP="tape"
111
112# sound devices
113SUBSYSTEM=="sound", GROUP="audio"
114
115# ieee1394 devices
116KERNEL=="raw1394", GROUP="disk"
117KERNEL=="dv1394*", GROUP="video"
118KERNEL=="video1394*", GROUP="video"
119
120# input devices
121KERNEL=="event[0-9]*", ATTRS{name}=="*dvb*|*DVB*|* IR *" \
122 MODE="0664", GROUP="video"
123KERNEL=="js[0-9]*", MODE="0664"
124KERNEL=="lirc[0-9]*", GROUP="video"
125
126# AOE character devices
127SUBSYSTEM=="aoe", MODE="0220", GROUP="disk"
128SUBSYSTEM=="aoe", KERNEL=="err", MODE="0440"
129
130LABEL="permissions_end"
131
diff --git a/recipes-core/udev/udev/run.rules b/recipes-core/udev/udev/run.rules
deleted file mode 100644
index 75d7137..0000000
--- a/recipes-core/udev/udev/run.rules
+++ /dev/null
@@ -1,14 +0,0 @@
1# debugging monitor
2RUN+="socket:/org/kernel/udev/monitor"
3
4# run a command on remove events
5ACTION=="remove", ENV{REMOVE_CMD}!="", RUN+="$env{REMOVE_CMD}"
6
7# ignore the events generated by virtual consoles
8KERNEL=="ptmx", OPTIONS+="last_rule"
9KERNEL=="console", OPTIONS+="last_rule"
10KERNEL=="tty" , OPTIONS+="last_rule"
11KERNEL=="tty[0-9]*", OPTIONS+="last_rule"
12KERNEL=="pty*", OPTIONS+="last_rule"
13SUBSYSTEM=="vc", OPTIONS+="last_rule"
14
diff --git a/recipes-core/udev/udev/udev-166-v4l1-1.patch b/recipes-core/udev/udev/udev-166-v4l1-1.patch
deleted file mode 100644
index 2086fe1..0000000
--- a/recipes-core/udev/udev/udev-166-v4l1-1.patch
+++ /dev/null
@@ -1,50 +0,0 @@
1Upstream-Status: Backport
2
3Submitted By: Matt Burgess <matthew_at_linuxfromscratch_dot_org>
4Date: 2011-03-26
5Initial Package Version: 166
6Upstream Status: From upstream
7Origin: http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=4ace8a43ac2cbbd4d6f5c29fc461c3caa8f8545b
8Description: Fixes a compilation error caused by the removal of the
9 Video for Linux 1 API from Linux kernels from 2.6.38
10 onwards.
11
12diff -Naur udev-166.orig/extras/v4l_id/v4l_id.c udev-166/extras/v4l_id/v4l_id.c
13--- udev-166.orig/extras/v4l_id/v4l_id.c 2009-12-03 12:45:03.000000000 +0000
14+++ udev-166/extras/v4l_id/v4l_id.c 2011-03-25 20:26:33.000000000 +0000
15@@ -28,7 +28,6 @@
16 #include <sys/types.h>
17 #include <sys/time.h>
18 #include <sys/ioctl.h>
19-#include <linux/videodev.h>
20 #include <linux/videodev2.h>
21
22 int main (int argc, char *argv[])
23@@ -39,7 +38,6 @@
24 };
25 int fd;
26 char *device;
27- struct video_capability v1cap;
28 struct v4l2_capability v2cap;
29
30 while (1) {
31@@ -82,19 +80,6 @@
32 if ((v2cap.capabilities & V4L2_CAP_RADIO) > 0)
33 printf("radio:");
34 printf("\n");
35- } else if (ioctl (fd, VIDIOCGCAP, &v1cap) == 0) {
36- printf("ID_V4L_VERSION=1\n");
37- printf("ID_V4L_PRODUCT=%s\n", v1cap.name);
38- printf("ID_V4L_CAPABILITIES=:");
39- if ((v1cap.type & VID_TYPE_CAPTURE) > 0)
40- printf("capture:");
41- if ((v1cap.type & VID_TYPE_OVERLAY) > 0)
42- printf("video_overlay:");
43- if (v1cap.audios > 0)
44- printf("audio:");
45- if ((v1cap.type & VID_TYPE_TUNER) > 0)
46- printf("tuner:");
47- printf("\n");
48 }
49
50 close (fd);
diff --git a/recipes-core/udev/udev/udev-cache b/recipes-core/udev/udev/udev-cache
deleted file mode 100644
index 77bbda6..0000000
--- a/recipes-core/udev/udev/udev-cache
+++ /dev/null
@@ -1,20 +0,0 @@
1#!/bin/sh -e
2
3### BEGIN INIT INFO
4# Provides: udev-cache
5# Required-Start: mountall
6# Required-Stop:
7# Default-Start: S
8# Default-Stop:
9# Short-Description: cache /dev to speedup the udev next boot
10### END INIT INFO
11
12[ -d /sys/class ] || exit 1
13[ -r /proc/mounts ] || exit 1
14[ -x /sbin/udevd ] || exit 1
15
16if [ ! -e /etc/dev.tar ]; then
17 (cd /; tar cf /etc/dev.tar dev)
18fi
19
20exit 0
diff --git a/recipes-core/udev/udev/udev.rules b/recipes-core/udev/udev/udev.rules
deleted file mode 100644
index a19d4a0..0000000
--- a/recipes-core/udev/udev/udev.rules
+++ /dev/null
@@ -1,116 +0,0 @@
1# There are a number of modifiers that are allowed to be used in some
2# of the different fields. They provide the following subsitutions:
3#
4# %n the "kernel number" of the device.
5# For example, 'sda3' has a "kernel number" of '3'
6# %e the smallest number for that name which does not matches an existing node
7# %k the kernel name for the device
8# %M the kernel major number for the device
9# %m the kernel minor number for the device
10# %b the bus id for the device
11# %c the string returned by the PROGRAM
12# %s{filename} the content of a sysfs attribute
13# %% the '%' char itself
14#
15
16# workaround for devices which do not report media changes
17SUBSYSTEMS=="ide", KERNEL=="hd[a-z]", ATTR{removable}=="1", \
18 ENV{ID_MODEL}=="IOMEGA_ZIP*", NAME="%k", OPTIONS+="all_partitions"
19SUBSYSTEMS=="ide", KERNEL=="hd[a-z]", ATTRS{media}=="floppy", \
20 OPTIONS+="all_partitions"
21
22# SCSI devices
23SUBSYSTEMS=="scsi", KERNEL=="sr[0-9]*", NAME="scd%n", SYMLINK+="sr%n"
24
25# USB devices
26SUBSYSTEMS=="usb", KERNEL=="auer[0-9]*", NAME="usb/%k"
27SUBSYSTEMS=="usb", KERNEL=="cpad[0-9]*", NAME="usb/%k"
28SUBSYSTEMS=="usb", KERNEL=="dabusb*", NAME="usb/%k"
29SUBSYSTEMS=="usb", KERNEL=="hiddev*", NAME="usb/%k"
30SUBSYSTEMS=="usb", KERNEL=="legousbtower*", NAME="usb/%k"
31SUBSYSTEMS=="usb", KERNEL=="lp[0-9]*", NAME="usb/%k"
32SUBSYSTEMS=="usb", KERNEL=="ttyUSB*", \
33 ATTRS{product}=="Palm Handheld*|Handspring Visor|palmOne Handheld", \
34 SYMLINK+="pilot"
35
36# usbfs-like devices
37SUBSYSTEM=="usb_device", PROGRAM="/bin/sh -c 'K=%k; K=$${K#usbdev}; printf bus/usb/%%03i/%%03i $${K%%%%.*} $${K#*.}'", ACTION=="add", \
38 NAME="%c"
39SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", NAME="bus/usb/$env{BUSNUM}/$env{DEVNUM}"
40
41# serial devices
42KERNEL=="capi", NAME="capi20", SYMLINK+="isdn/capi20"
43KERNEL=="capi[0-9]*", NAME="capi/%n"
44
45# video devices
46KERNEL=="dvb*", PROGRAM="/bin/sh -c 'K=%k; K=$${K#dvb}; printf dvb/adapter%%i/%%s $${K%%%%.*} $${K#*.}", ACTION=="add", \
47 NAME="%c"
48KERNEL=="card[0-9]*", NAME="dri/%k"
49
50# misc devices
51KERNEL=="hw_random", NAME="hwrng"
52KERNEL=="tun", NAME="net/%k"
53KERNEL=="evtchn", NAME="xen/%k"
54
55KERNEL=="cdemu[0-9]*", NAME="cdemu/%n"
56KERNEL=="pktcdvd[0-9]*", NAME="pktcdvd/%n"
57KERNEL=="pktcdvd", NAME="pktcdvd/control"
58
59KERNEL=="cpu[0-9]*", NAME="cpu/%n/cpuid"
60KERNEL=="msr[0-9]*", NAME="cpu/%n/msr"
61KERNEL=="microcode", NAME="cpu/microcode"
62
63KERNEL=="umad*", NAME="infiniband/%k"
64KERNEL=="issm*", NAME="infiniband/%k"
65KERNEL=="uverbs*", NAME="infiniband/%k"
66KERNEL=="ucm*", NAME="infiniband/%k"
67KERNEL=="rdma_ucm", NAME="infiniband/%k"
68
69# ALSA devices
70KERNEL=="controlC[0-9]*", NAME="snd/%k"
71KERNEL=="hwC[D0-9]*", NAME="snd/%k"
72KERNEL=="pcmC[D0-9cp]*", NAME="snd/%k"
73KERNEL=="midiC[D0-9]*", NAME="snd/%k"
74KERNEL=="timer", NAME="snd/%k"
75KERNEL=="seq", NAME="snd/%k"
76
77# ieee1394 devices
78KERNEL=="dv1394*", NAME="dv1394/%n"
79KERNEL=="video1394*", NAME="video1394/%n"
80
81# input devices
82KERNEL=="mice", NAME="input/%k"
83KERNEL=="mouse[0-9]*", NAME="input/%k"
84KERNEL=="event[0-9]*", NAME="input/%k"
85KERNEL=="js[0-9]*", NAME="input/%k"
86KERNEL=="ts[0-9]*", NAME="input/%k"
87KERNEL=="uinput", NAME="input/%k"
88
89# Zaptel
90KERNEL=="zapctl", NAME="zap/ctl"
91KERNEL=="zaptimer", NAME="zap/timer"
92KERNEL=="zapchannel", NAME="zap/channel"
93KERNEL=="zappseudo", NAME="zap/pseudo"
94KERNEL=="zap[0-9]*", NAME="zap/%n"
95
96# AOE character devices
97SUBSYSTEM=="aoe", KERNEL=="discover", NAME="etherd/%k"
98SUBSYSTEM=="aoe", KERNEL=="err", NAME="etherd/%k"
99SUBSYSTEM=="aoe", KERNEL=="interfaces", NAME="etherd/%k"
100SUBSYSTEM=="aoe", KERNEL=="revalidate", NAME="etherd/%k"
101
102# device mapper creates its own device nodes, so ignore these
103KERNEL=="dm-[0-9]*", OPTIONS+="ignore_device"
104KERNEL=="device-mapper", NAME="mapper/control"
105
106KERNEL=="rfcomm[0-9]*", NAME="%k", GROUP="users", MODE="0660"
107
108# Firmware Helper
109ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware.sh"
110
111# Samsung UARTS
112KERNEL=="s3c2410_serial[0-9]", NAME="ttySAC%n"
113
114# MXC UARTs
115KERNEL=="ttymxc[0-4]", NAME="ttymxc%n"
116
diff --git a/recipes-core/udev/udev_164.bb b/recipes-core/udev/udev_164.bb
deleted file mode 100644
index 6d71f4d..0000000
--- a/recipes-core/udev/udev_164.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1include udev.inc
2
3PR = "r10"
4
5SRC_URI += "file://udev-166-v4l1-1.patch"
6
7SRC_URI[md5sum] = "fddac2d54761ea34865af9467377ca9f"
8SRC_URI[sha256sum] = "c12e66280b5e1465f6587a8cfa47d7405c4caa7e52ce5dd13478d04f6ec05e5c"