summaryrefslogtreecommitdiffstats
path: root/recipes-core/udev/udev-extraconf_1.0.bbappend
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-09-06 12:51:44 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2012-09-07 17:37:49 -0300
commitdaa11cfa03c337998485d7db64244f3db04ab0fd (patch)
tree55e49d52550446c63b9bf001b319326f8ca0d835 /recipes-core/udev/udev-extraconf_1.0.bbappend
parentfa7ad4cc6cf5bc20cf7632ac1a22f3310149bfec (diff)
downloadmeta-fsl-arm-daa11cfa03c337998485d7db64244f3db04ab0fd.tar.gz
udev-extraconf: follow OE-Core bump for 1.0 version
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/udev/udev-extraconf_1.0.bbappend')
-rw-r--r--recipes-core/udev/udev-extraconf_1.0.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-core/udev/udev-extraconf_1.0.bbappend b/recipes-core/udev/udev-extraconf_1.0.bbappend
new file mode 100644
index 0000000..b8af0f1
--- /dev/null
+++ b/recipes-core/udev/udev-extraconf_1.0.bbappend
@@ -0,0 +1,19 @@
1# Freescale imx extra configuration udev rules
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4PRINC := "${@int(PRINC) + 1}"
5
6SRC_URI_append_mxs = " file://10-imx.rules"
7SRC_URI_append_mx5 = " file://10-imx.rules"
8SRC_URI_append_mx6 = " file://10-imx.rules"
9
10do_install_prepend () {
11 if [ -e "${WORKDIR}/10-imx.rules" ]; then
12 install -d ${D}${sysconfdir}/udev/rules.d
13 install -m 0644 ${WORKDIR}/10-imx.rules ${D}${sysconfdir}/udev/rules.d
14 fi
15}
16
17PACKAGE_ARCH_mxs = "${MACHINE_ARCH}"
18PACKAGE_ARCH_mx5 = "${MACHINE_ARCH}"
19PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}"