summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-03-18 15:02:37 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-03-18 16:08:04 -0300
commit9dd7dbc9f669637ade4bafa96bf74182c5c356ec (patch)
tree5bb4d9a3b07a1caa991d6f2e9cc8571d08223901 /recipes-bsp
parentd376e5306b3f920e3d0aca6f2c3eca61d14bfcf7 (diff)
downloadmeta-fsl-arm-9dd7dbc9f669637ade4bafa96bf74182c5c356ec.tar.gz
u-boot-fslc: Update to U-Boot 2016.03 based fork
This updates the fork for the 2016.03 release. Currently following patches are applied on top of it: fd6b196 warp7: Add initial support f9dc5fe wandboard: Drop revision specific DeviceTree support b3e771e mx6sabresd: Enable video interfaces in bootargs e0a65b1 Revert "embestmx6boards: convert to use config_distro_bootcmd.h" af0e438 iMX6: Change mmcroot to use fixed mmc block index for USDHC 36a641b embestmx6boards: Change default bootenv configuration f97660e mx6sabresd: Use LDO dtb file until LDO bypass support is added 4064b09 mx6slevk: Use LDO dtb file until LDO bypass support is added f854376 imx: mx7d: move MX7D to Kconfig entry 8a29233 imx: mx6sx: move MX6SX to Kconfig entry d85319f arm: mx6: Add CCV xPress board support fe7917e arm: mx6: Add UART8 base address for i.MX6UL 8730cc5 arm: imx6: Switch DDR3 calibration to wait_for_bit() 91c85e8 warp7: Add initial support ca3306a mx7_common: Put early/late init configs into board file 1dfebcc mx7: Distinguish between dual and solo versions dfcf27d mx7dsabresd: Define serial port locally 95817e0 mx7_common: Remove unexisting options 78eb121 arm: imx: Add support for GE Bx50v3 boards Change-Id: I0e7ddd021fd87ffe8a5ad6916fd1eb7a3243b21b Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.03.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.01.bb)8
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc.inc4
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2016.01.bb6
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2016.03.bb6
4 files changed, 12 insertions, 12 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.01.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.03.bb
index a0348c5..4ec0357 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.01.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.03.bb
@@ -1,14 +1,14 @@
1DESCRIPTION = "U-boot bootloader mxsboot tool" 1DESCRIPTION = "U-boot bootloader mxsboot tool"
2LICENSE = "GPLv2+" 2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95" 3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader" 4SECTION = "bootloader"
5DEPENDS = "openssl" 5DEPENDS = "openssl"
6PROVIDES = "u-boot-mxsboot" 6PROVIDES = "u-boot-mxsboot"
7 7
8PV = "v2016.01+git${SRCPV}" 8PV = "v2016.03+git${SRCPV}"
9 9
10SRCREV = "5da79530cef86a4e3a5e618b82f675da5bd3ca37" 10SRCREV = "fd6b196f574ca85d75d6bbe24cf9344e58366ae1"
11SRCBRANCH = "2016.01+fslc" 11SRCBRANCH = "2016.03+fslc"
12 12
13SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" 13SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
14 14
diff --git a/recipes-bsp/u-boot/u-boot-fslc.inc b/recipes-bsp/u-boot/u-boot-fslc.inc
index df67469..c61c950 100644
--- a/recipes-bsp/u-boot/u-boot-fslc.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc.inc
@@ -1,4 +1,4 @@
1# Copyright (C) 2012-2015 O.S. Systems Software LTDA. 1# Copyright (C) 2012-2016 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4require recipes-bsp/u-boot/u-boot.inc 4require recipes-bsp/u-boot/u-boot.inc
@@ -10,7 +10,7 @@ order to provide support for some backported features and fixes, or because it \
10was submitted for revision and it takes some time to become part of a stable \ 10was submitted for revision and it takes some time to become part of a stable \
11version, or because it is not applicable for upstreaming." 11version, or because it is not applicable for upstreaming."
12LICENSE = "GPLv2+" 12LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95" 13LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
14COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx6ul|mx7|vf)" 14COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx6ul|mx7|vf)"
15 15
16DEPENDS_mxs += "elftosb-native openssl-native" 16DEPENDS_mxs += "elftosb-native openssl-native"
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2016.01.bb b/recipes-bsp/u-boot/u-boot-fslc_2016.01.bb
deleted file mode 100644
index aee89c8..0000000
--- a/recipes-bsp/u-boot/u-boot-fslc_2016.01.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1include u-boot-fslc.inc
2
3PV = "v2016.01+git${SRCPV}"
4
5SRCREV = "5da79530cef86a4e3a5e618b82f675da5bd3ca37"
6SRCBRANCH = "2016.01+fslc"
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2016.03.bb b/recipes-bsp/u-boot/u-boot-fslc_2016.03.bb
new file mode 100644
index 0000000..2358de3
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc_2016.03.bb
@@ -0,0 +1,6 @@
1include u-boot-fslc.inc
2
3PV = "v2016.03+git${SRCPV}"
4
5SRCREV = "fd6b196f574ca85d75d6bbe24cf9344e58366ae1"
6SRCBRANCH = "2016.03+fslc"