summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-04-11 09:38:49 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-11 09:38:49 -0300
commit370a313c750d3a7d7171523a6d5fe66de45e931d (patch)
tree5d3324742308d735cac7ca4e431814ff51144748 /recipes-bsp
parent1a5c169afbdb936f2339c988fb1efccf8c95257e (diff)
downloadmeta-fsl-arm-370a313c750d3a7d7171523a6d5fe66de45e931d.tar.gz
imx-test: Fix build for X11 backend
The root case of the addition of the dependencies on the recipe was that it were not being correctly included in the .inc file. This fixes it and remove the duplication. Change-Id: Ie9ee5fbc2a61915ce109473f5df2b8e88d3966c4 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-test/imx-test.inc7
-rw-r--r--recipes-bsp/imx-test/imx-test_5.4.bb13
2 files changed, 3 insertions, 17 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc
index 3c463c7..1fcb632 100644
--- a/recipes-bsp/imx-test/imx-test.inc
+++ b/recipes-bsp/imx-test/imx-test.inc
@@ -11,10 +11,6 @@ DEPENDS_mx6sx = "virtual/kernel imx-lib"
11DEPENDS_mx6ul = "virtual/kernel imx-lib" 11DEPENDS_mx6ul = "virtual/kernel imx-lib"
12DEPENDS_mx7 = "virtual/kernel imx-lib" 12DEPENDS_mx7 = "virtual/kernel imx-lib"
13 13
14DEPENDS_append = " \
15 ${@base_contains('DISTRO_FEATURES', 'x11', 'libx11 libxdamage libxrender libxrandr', '', d)} \
16"
17
18LICENSE = "GPLv2" 14LICENSE = "GPLv2"
19LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 15LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
20 16
@@ -33,6 +29,9 @@ PLATFORM_mx6sx = "IMX6SX"
33PLATFORM_mx7 = "IMX7D" 29PLATFORM_mx7 = "IMX7D"
34PLATFORM_mx6ul = "IMX6UL" 30PLATFORM_mx6ul = "IMX6UL"
35 31
32PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
33PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr"
34
36# Required so the fixdep binary is generated 35# Required so the fixdep binary is generated
37addtask make_scripts after do_patch before do_compile 36addtask make_scripts after do_patch before do_compile
38do_make_scripts[lockfiles] = "${TMPDIR}/kernel-scripts.lock" 37do_make_scripts[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
diff --git a/recipes-bsp/imx-test/imx-test_5.4.bb b/recipes-bsp/imx-test/imx-test_5.4.bb
index de4e5ba..6a12c05 100644
--- a/recipes-bsp/imx-test/imx-test_5.4.bb
+++ b/recipes-bsp/imx-test/imx-test_5.4.bb
@@ -2,19 +2,6 @@
2 2
3include imx-test.inc 3include imx-test.inc
4 4
5DEPENDS_mx6q += "${@base_contains('DISTRO_FEATURES', 'x11', \
6 ' libx11 libxdamage libxrender libxrandr', '', d)}"
7DEPENDS_mx6dl += "${@base_contains('DISTRO_FEATURES', 'x11', \
8 ' libx11 libxdamage libxrender libxrandr', '', d)}"
9DEPENDS_mx6sl += "${@base_contains('DISTRO_FEATURES', 'x11', \
10 ' libx11 libxdamage libxrender libxrandr', '', d)}"
11DEPENDS_mx6sx += "${@base_contains('DISTRO_FEATURES', 'x11', \
12 ' libx11 libxdamage libxrender libxrandr', '', d)}"
13DEPENDS_mx6ul += "${@base_contains('DISTRO_FEATURES', 'x11', \
14 ' libx11 libxdamage libxrender libxrandr', '', d)}"
15DEPENDS_mx7d += "${@base_contains('DISTRO_FEATURES', 'x11', \
16 ' libx11 libxdamage libxrender libxrandr', '', d)}"
17
18SRC_URI[md5sum] = "46ddd6d1631cc0f7328383e13632d5bb" 5SRC_URI[md5sum] = "46ddd6d1631cc0f7328383e13632d5bb"
19SRC_URI[sha256sum] = "cae6ec9b4d5cc1c402a7683cc8c2c35cccdd9598283caefcea2804baa47a15b6" 6SRC_URI[sha256sum] = "cae6ec9b4d5cc1c402a7683cc8c2c35cccdd9598283caefcea2804baa47a15b6"
20 7