summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@nxp.com>2016-06-02 21:38:18 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-06-02 15:19:26 -0300
commit00b46e11e32f859a0d2dad5a5d53d5540be9c15e (patch)
treef9b823524479c28de96a085a6f610f4fe8b84181 /recipes-bsp
parent4cd53ccc5b8d2a85ac765c54a0594aa5fd852974 (diff)
downloadmeta-fsl-arm-00b46e11e32f859a0d2dad5a5d53d5540be9c15e.tar.gz
u-boot: fix build error under gcc6
Fix the following build error under gcc6: | ../include/linux/compiler-gcc.h:114:30: fatal error: linux/compiler-gcc6.h: No such file or directory | #include gcc_header(__GNUC__) Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1/fix-build-error-under-gcc6.patch91
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2015.01.bb4
2 files changed, 94 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ls1/fix-build-error-under-gcc6.patch b/recipes-bsp/u-boot/u-boot-ls1/fix-build-error-under-gcc6.patch
new file mode 100644
index 0000000..18c5e74
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-ls1/fix-build-error-under-gcc6.patch
@@ -0,0 +1,91 @@
1From 07373b2e477ae61f9f6a0e2eff41be3276d92923 Mon Sep 17 00:00:00 2001
2From: yocto <yocto@yocto.org>
3Date: Thu, 2 Jun 2016 03:21:51 -0500
4Subject: [PATCH] fix build error under gcc6
5
6Fix the following error:
7| ../include/linux/compiler-gcc.h:114:30: fatal error: linux/compiler-gcc6.h: No such file or directory
8| #include gcc_header(__GNUC__)
9
10Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
11
12Upstream-Status: Pending
13---
14 include/linux/compiler-gcc6.h | 65 +++++++++++++++++++++++++++++++++++++++++++
15 1 file changed, 65 insertions(+)
16 create mode 100644 include/linux/compiler-gcc6.h
17
18diff --git a/include/linux/compiler-gcc6.h b/include/linux/compiler-gcc6.h
19new file mode 100644
20index 0000000..c8c5659
21--- /dev/null
22+++ b/include/linux/compiler-gcc6.h
23@@ -0,0 +1,65 @@
24+#ifndef __LINUX_COMPILER_H
25+#error "Please don't include <linux/compiler-gcc5.h> directly, include <linux/compiler.h> instead."
26+#endif
27+
28+#define __used __attribute__((__used__))
29+#define __must_check __attribute__((warn_unused_result))
30+#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
31+
32+/* Mark functions as cold. gcc will assume any path leading to a call
33+ to them will be unlikely. This means a lot of manual unlikely()s
34+ are unnecessary now for any paths leading to the usual suspects
35+ like BUG(), printk(), panic() etc. [but let's keep them for now for
36+ older compilers]
37+
38+ Early snapshots of gcc 4.3 don't support this and we can't detect this
39+ in the preprocessor, but we can live with this because they're unreleased.
40+ Maketime probing would be overkill here.
41+
42+ gcc also has a __attribute__((__hot__)) to move hot functions into
43+ a special section, but I don't see any sense in this right now in
44+ the kernel context */
45+#define __cold __attribute__((__cold__))
46+
47+#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
48+
49+#ifndef __CHECKER__
50+# define __compiletime_warning(message) __attribute__((warning(message)))
51+# define __compiletime_error(message) __attribute__((error(message)))
52+#endif /* __CHECKER__ */
53+
54+/*
55+ * Mark a position in code as unreachable. This can be used to
56+ * suppress control flow warnings after asm blocks that transfer
57+ * control elsewhere.
58+ *
59+ * Early snapshots of gcc 4.5 don't support this and we can't detect
60+ * this in the preprocessor, but we can live with this because they're
61+ * unreleased. Really, we need to have autoconf for the kernel.
62+ */
63+#define unreachable() __builtin_unreachable()
64+
65+/* Mark a function definition as prohibited from being cloned. */
66+#define __noclone __attribute__((__noclone__))
67+
68+/*
69+ * Tell the optimizer that something else uses this function or variable.
70+ */
71+#define __visible __attribute__((externally_visible))
72+
73+/*
74+ * GCC 'asm goto' miscompiles certain code sequences:
75+ *
76+ * http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
77+ *
78+ * Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
79+ *
80+ * (asm goto is automatically volatile - the naming reflects this.)
81+ */
82+#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
83+
84+#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
85+#define __HAVE_BUILTIN_BSWAP32__
86+#define __HAVE_BUILTIN_BSWAP64__
87+#define __HAVE_BUILTIN_BSWAP16__
88+#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
89--
902.5.0
91
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb b/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
index ae31763..2695c14 100644
--- a/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
+++ b/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
@@ -12,7 +12,9 @@ LIC_FILES_CHKSUM = " \
12 12
13SRCBRANCH = "master" 13SRCBRANCH = "master"
14SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}" 14SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}"
15SRC_URI += "file://0001-uboot-support-gcc5.patch " 15SRC_URI += "file://0001-uboot-support-gcc5.patch \
16 file://fix-build-error-under-gcc6.patch \
17"
16SRCREV = "6ba8eedbcdc4b063f59a63e6288b938af739e8ad" 18SRCREV = "6ba8eedbcdc4b063f59a63e6288b938af739e8ad"
17 19
18LOCALVERSION ?= "+ls1" 20LOCALVERSION ?= "+ls1"