summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2015-09-17 14:27:37 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2015-09-18 16:09:57 -0300
commit1f2bdf48318f3443ec4ef781f772375695fcc1db (patch)
treeb34d548743575fddc5c04a94a6f0d4e012d6a2e8 /recipes-bsp/u-boot
parent11dc7f6d9a797afd0346fa8f44a7cf9b58b1090f (diff)
downloadmeta-fsl-arm-1f2bdf48318f3443ec4ef781f772375695fcc1db.tar.gz
u-boot-imx: Update to i.MX 6Quad Plus GA and 6UltraLite GA releases
QuadPlus and Ultralite were each standalone releases so keep baranches and commits specific to each standalone release. Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2015.04.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2015.04.bb b/recipes-bsp/u-boot/u-boot-imx_2015.04.bb
index ab53d9d..c7a4268 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2015.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2015.04.bb
@@ -8,9 +8,16 @@ PROVIDES += "u-boot"
8LICENSE = "GPLv2+" 8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" 9LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10 10
11SRCBRANCH = "imx_v2015.04_3.14.38_6ul7d_beta" 11SRCBRANCH_mx6 = "imx_v2015.04_3.14.38_6qp_ga"
12SRCREV_mx6 = "f80d628744bd1e669e365c52068067563b577e16"
13
14SRCBRANCH_mx6ul = "imx_v2015.04_3.14.38_6ul_ga"
15SRCREV_mx6ul = "5d63276bfebc82cffa10d66ddaa903dd2ab0df43"
16
17SRCBRANCH_mx7 = "imx_v2015.04_3.14.38_6ul_ga"
18SRCREV_mx7 = "5d63276bfebc82cffa10d66ddaa903dd2ab0df43"
19
12SRC_URI = "git://git.freescale.com/imx/uboot-imx.git;protocol=git;branch=${SRCBRANCH}" 20SRC_URI = "git://git.freescale.com/imx/uboot-imx.git;protocol=git;branch=${SRCBRANCH}"
13SRCREV = "b026e66a5bb6c2b6fda9e353dfe9061306c69da4"
14 21
15S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
16 23
@@ -19,4 +26,4 @@ inherit fsl-u-boot-localversion
19LOCALVERSION ?= "-${SRCBRANCH}" 26LOCALVERSION ?= "-${SRCBRANCH}"
20 27
21PACKAGE_ARCH = "${MACHINE_ARCH}" 28PACKAGE_ARCH = "${MACHINE_ARCH}"
22COMPATIBLE_MACHINE = "(mx6|mx7)" 29COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)"