summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
diff options
context:
space:
mode:
authorMahesh Mahadevan <mahesh.mahadevan@freescale.com>2012-10-15 12:31:15 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2012-10-15 15:36:49 -0300
commit39e506531df7dc2cdebe2d18efdd25fdefd2bed8 (patch)
tree05e3c5ce1c87e1ebd4686e5a33fde1ac3f0bce27 /recipes-bsp/u-boot/u-boot-imx_2009.08.bb
parentb1eaaef4221a9a6939ead863ee11c0d4d54e0d51 (diff)
downloadmeta-fsl-arm-39e506531df7dc2cdebe2d18efdd25fdefd2bed8.tar.gz
u-boot-imx: Fix the build and GIT repository location
1. u-boot-imx build was broken after making the switch to open source u-boot. Added UBOOT_MACHINE defines since the u-boot config names are different from that used in the denx GIT repository. Also added defines UBOOT_MAKE_TARGET & UBOOT_SUFFIX given the older version of the u-boot code used. 2. Added 'HOSTSTRIP=true' to EXTRA_OEMAKE for build to succeed. 3. Use git.freescale.com to get the u-boot source code. Signed-off-by: Mahesh Mahadevan <mahesh.mahadevan@freescale.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-imx_2009.08.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2009.08.bb27
1 files changed, 24 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
index c1268df..8bd8af7 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
@@ -11,12 +11,33 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b"
11 11
12DEPENDS_mxs += "elftosb-native" 12DEPENDS_mxs += "elftosb-native"
13 13
14PR = "r5" 14PR = "r6"
15 15
16SRC_URI = "git://opensource.freescale.com/pub/scm/imx/uboot-imx.git;tag=rel_imx_2.6.38_11.11.01;protocol=http \ 16# Revision of imx_2.6.35_10.12.01 branch
17 file://mx53_loco_bootenv.patch" 17SRCREV_mxs = "e4437f1c192a1a68028e6fcff3f50ff50352041d"
18
19# Revision of imx_2.6.35_11.09.01 branch
20SRCREV_mx5 = "897922d01c812be802e4a928b937535ea1b8e076"
21SRC_URI_append_imx5 = " \
22 file://mx53_loco_bootenv.patch \
23"
24
25# Revision of imx_2.6.35_11.11.01 branch
26SRCREV_mx6 = "daa30bb22e006d9f39298fb28ea8391ae4ccbc52"
27
28SRC_URI = "git://git.freescale.com/imx/uboot-imx.git"
29
30UBOOT_MACHINE_imx53qsb = "mx53_loco_config"
31UBOOT_MACHINE_imx53ard = "mx53_ard_ddr3_config"
32UBOOT_MACHINE_imx51evk = "mx51_bbg_config"
33UBOOT_MACHINE_imx6qsabrelite = "mx6q_sabrelite_config"
34UBOOT_MACHINE_imx28evk = "mx28_evk_config"
35
36UBOOT_MAKE_TARGET = "u-boot.bin"
37UBOOT_SUFFIX = "bin"
18 38
19S = "${WORKDIR}/git" 39S = "${WORKDIR}/git"
40EXTRA_OEMAKE += 'HOSTSTRIP=true'
20 41
21PACKAGE_ARCH = "${MACHINE_ARCH}" 42PACKAGE_ARCH = "${MACHINE_ARCH}"
22 43