summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2013-09-30 14:03:07 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2013-10-30 14:25:35 -0200
commit43df4cf13e834249a2505997e953c694af7107fe (patch)
treedf72df3079faf907f44227f0e37155cd20eb256a /recipes-bsp/imx-vpu
parent795e6fcebd82311ebb467cefba575d173dc33303 (diff)
downloadmeta-fsl-arm-43df4cf13e834249a2505997e953c694af7107fe.tar.gz
imx-vpu: Add 3.10.9-1.0.0 recipe
This was previously part of imx-lib but separated starting in 3.0.35-4.1.0 because vpu is Freescale Proprietary license. Note that libvpu was previously part of imx-lib but has been pulled out because vpu is now Freescale Proprietary license Change-Id: I3293b94ee3c3474d305c13c0c8c62480317713fc Signed-off-by: Lauren Post <lauren.post@freescale.com>
Diffstat (limited to 'recipes-bsp/imx-vpu')
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_3.10.9-1.0.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu/imx-vpu_3.10.9-1.0.0.bb b/recipes-bsp/imx-vpu/imx-vpu_3.10.9-1.0.0.bb
new file mode 100644
index 0000000..89b5225
--- /dev/null
+++ b/recipes-bsp/imx-vpu/imx-vpu_3.10.9-1.0.0.bb
@@ -0,0 +1,23 @@
1# Copyright (C) 2013 Freescale Semiconductor
2
3require recipes-bsp/imx-lib/imx-lib.inc
4
5inherit fsl-eula-unpack
6
7DESCRIPTION = "Freescale VPU library"
8LICENSE = "Proprietary"
9LIC_FILES_CHKSUM = "file://vpu/EULA.txt;md5=b063366b066c9f10037c59756a9ced54"
10
11PE = "1"
12
13SRC_URI = "${FSL_MIRROR}/imx-vpu-${PV}.bin;fsl-eula=true"
14SRC_URI[md5sum] = "61331c9ed2d4c1b3aeab9c35fd034ac3"
15SRC_URI[sha256sum] = "5dd86a26c8d3013e0d78308b1ccd8815730818e465787f55013b492d2d3c7710"
16
17do_compile () {
18 INCLUDE_DIR="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"
19
20 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all
21}
22
23COMPATIBLE_MACHINE = "(mx6)"