summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-bootlets
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-05-19 09:05:39 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2012-05-21 10:26:52 -0300
commitd2f2b73be28f3e10c2c6994bba2575c6fdbfe745 (patch)
tree6819e07801b311f7a38c93b85e1db51213c3dbe6 /recipes-bsp/imx-bootlets
parenta61f8c74c9945e9060d472c6c4db54eb63cfcbc8 (diff)
downloadmeta-fsl-arm-d2f2b73be28f3e10c2c6994bba2575c6fdbfe745.tar.gz
imx-bootlets: add 10.12.01
Every machine intending to use this, need to set IMXBOOTLETS_MACHINE variable to allow it to generate proper target code. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-bootlets')
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets/linux_ivt-fix-paths.patch28
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets/linux_prep-fix-cmdlines.patch30
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb67
3 files changed, 125 insertions, 0 deletions
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets/linux_ivt-fix-paths.patch b/recipes-bsp/imx-bootlets/imx-bootlets/linux_ivt-fix-paths.patch
new file mode 100644
index 0000000..2ce5a0f
--- /dev/null
+++ b/recipes-bsp/imx-bootlets/imx-bootlets/linux_ivt-fix-paths.patch
@@ -0,0 +1,28 @@
1imx-bootlets: Fix paths for used during boot stream generation
2
3This will be run during image generation thus this won't use a
4complete path to allow for relocation.
5
6Upstream-Status: Inappropriate [configuration]
7
8Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
9
10diff --git a/linux_ivt.bd b/linux_ivt.bd
11index 516f4f2..366ac22 100644
12--- a/linux_ivt.bd
13+++ b/linux_ivt.bd
14@@ -4,10 +4,10 @@ options {
15 flags = 0x01;
16 }
17 sources {
18- power_prep="./power_prep/power_prep";
19- sdram_prep="./boot_prep/boot_prep";
20- linux_prep="./linux_prep/output-target/linux_prep";
21- zImage="./zImage";
22+ power_prep="imx-bootlets-power_prep-@MACHINE@";
23+ sdram_prep="imx-bootlets-boot_prep-@MACHINE@";
24+ linux_prep="imx-bootlets-linux_prep-@MACHINE@";
25+ zImage="zImage-@MACHINE@.bin";
26 }
27
28 section (0) {
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets/linux_prep-fix-cmdlines.patch b/recipes-bsp/imx-bootlets/imx-bootlets/linux_prep-fix-cmdlines.patch
new file mode 100644
index 0000000..4fb4c51
--- /dev/null
+++ b/recipes-bsp/imx-bootlets/imx-bootlets/linux_prep-fix-cmdlines.patch
@@ -0,0 +1,30 @@
1imx-bootlets: Fix cmdlines for Linux boot
2
3This adapt the cmdlines for the partitioning layout used on the
4generated SD cards.
5
6Upstream-Status: Inappropriate [configuration]
7
8Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
9
10diff --git a/linux_prep/cmdlines/iMX28_EVK.txt b/linux_prep/cmdlines/iMX28_EVK.txt
11index 6bc36b9..6cf89a0 100644
12--- a/linux_prep/cmdlines/iMX28_EVK.txt
13+++ b/linux_prep/cmdlines/iMX28_EVK.txt
14@@ -1 +1 @@
15-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait
16+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait
17diff --git a/linux_prep/cmdlines/stmp378x_dev.txt b/linux_prep/cmdlines/stmp378x_dev.txt
18index 9a717eb..fdb7390 100644
19--- a/linux_prep/cmdlines/stmp378x_dev.txt
20+++ b/linux_prep/cmdlines/stmp378x_dev.txt
21@@ -1,6 +1,3 @@
22-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait lcd_panel=lms430 no_console_suspend
23-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait lcd_panel=lms350
24-console=ttyAM0,115200 ssp1=spi1 ubi.mtd=2 root=ubi0:rootfs0 rootfstype=ubifs lcd_panel=lms430
25-
26-
27-
28+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait ssp1=mmc lcd_panel=lms430 no_console_suspend
29+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait ssp1=mmc lcd_panel=lms350
30+console=ttyAMA0,115200 ssp1=spi1 ubi.mtd=2 root=ubi0:rootfs0 rootfstype=ubifs lcd_panel=lms430
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
new file mode 100644
index 0000000..941b458
--- /dev/null
+++ b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
@@ -0,0 +1,67 @@
1DESCRIPTION = "i.MXS boot streams"
2LICENSE = "GPL-2.0"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5SRC_URI = "http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${PV}.tar.gz \
6 file://linux_ivt-fix-paths.patch \
7 file://linux_prep-fix-cmdlines.patch"
8
9SRC_URI[md5sum] = "cf0ab3822dca694b930a051501c1d0e4"
10SRC_URI[sha256sum] = "63f6068ae36884adef4259bbb1fe2591755718f22c46d0a59d854883dfab1ffc"
11
12S = "${WORKDIR}/imx-bootlets-src-${PV}"
13
14# Disable parallel building or it may fail to build.
15PARALLEL_MAKE = ""
16
17EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
18
19# Ensure machine defines the IMXBOOTLETS_MACHINE
20python () {
21 if not d.getVar("IMXBOOTLETS_MACHINE", True):
22 PN = d.getVar("PN", True)
23 FILE = os.path.basename(d.getVar("FILE", True))
24 bb.debug(1, "To build %s, see %s for instructions on \
25 setting up your machine config" % (PN, FILE))
26 raise bb.parse.SkipPackage("because IMXBOOTLETS_MACHINE is not set")
27}
28
29do_configure () {
30 # Use machine specific binaries
31 sed -i 's,@MACHINE@,${MACHINE},g' linux_ivt.bd
32}
33
34do_compile () {
35 oe_runmake BOARD=${IMXBOOTLETS_MACHINE} linux_prep \
36 boot_prep \
37 power_prep
38}
39
40do_install () {
41 install -d ${D}/boot/
42 install -m 644 boot_prep/boot_prep power_prep/power_prep \
43 linux_prep/output-target/linux_prep linux_ivt.bd \
44 ${D}/boot
45}
46
47FILES_${PN} = "/boot"
48
49do_deploy () {
50 install -d ${DEPLOY_DIR_IMAGE}
51
52 for f in boot_prep/boot_prep \
53 power_prep/power_prep \
54 linux_prep/output-target/linux_prep \
55 linux_ivt.bd; do
56 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}"
57 symlink_name="imx-bootlets-`basename $f`-${MACHINE}"
58
59 install -m 644 ${S}/$f ${DEPLOY_DIR_IMAGE}/$full_name
60 (cd ${DEPLOY_DIR_IMAGE} ; rm -f $symlink_nake ; ln -sf $full_name $symlink_name)
61 done
62}
63
64addtask deploy before do_build after do_compile
65
66PACKAGE_ARCH = "${MACHINE_ARCH}"
67COMPATIBLE_MACHINE = "(mxs)"