summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-bootlets
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-06-16 09:51:49 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2012-07-10 14:34:20 -0300
commit8ee68d13dfd8efb99f154cce6ec3172c8137a0b1 (patch)
treedaa251378a2fc1503571d870cc4eacbb077fe70e /recipes-bsp/imx-bootlets
parenta207ac2953cdc046acef3190f58816df79119f1b (diff)
downloadmeta-fsl-arm-8ee68d13dfd8efb99f154cce6ec3172c8137a0b1.tar.gz
imx-bootlets: allow use of a zImage with appended device tree info
For use of kernels, with device tree, and imx-bootlets we need to append it to the kernel image and use it for the linux.sb file. To avoid changing the built kernel we append a -dtb suffix for the binary name. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-bootlets')
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch2
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb10
2 files changed, 7 insertions, 5 deletions
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch b/recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch
index abcf5b0..d54add1 100644
--- a/recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch
+++ b/recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch
@@ -22,7 +22,7 @@ index 516f4f2..366ac22 100644
22+ power_prep="imx-bootlets-power_prep-@MACHINE@"; 22+ power_prep="imx-bootlets-power_prep-@MACHINE@";
23+ sdram_prep="imx-bootlets-boot_prep-@MACHINE@"; 23+ sdram_prep="imx-bootlets-boot_prep-@MACHINE@";
24+ linux_prep="imx-bootlets-linux_prep-@MACHINE@"; 24+ linux_prep="imx-bootlets-linux_prep-@MACHINE@";
25+ zImage="zImage-@MACHINE@.bin"; 25+ zImage="zImage-@MACHINE@.bin@DTB@";
26 } 26 }
27 27
28 section (0) { 28 section (0) {
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
index d2f51fd..6cea049 100644
--- a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
+++ b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "i.MXS boot streams"
2LICENSE = "GPL-2.0" 2LICENSE = "GPL-2.0"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4 4
5PR = "r1" 5PR = "r2"
6 6
7SRC_URI = "http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${PV}.tar.gz \ 7SRC_URI = "http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${PV}.tar.gz \
8 file://linux-fix-paths.patch \ 8 file://linux-fix-paths.patch \
@@ -30,7 +30,8 @@ python () {
30 30
31do_configure () { 31do_configure () {
32 # Use machine specific binaries 32 # Use machine specific binaries
33 sed -i 's,@MACHINE@,${MACHINE},g' linux.bd 33 sed 's,@MACHINE@,${MACHINE},g;s,@DTB@,-dtb,g' < linux.bd > linux.bd-dtb
34 sed -i 's,@MACHINE@,${MACHINE},g;s,@DTB@,,g' linux.bd
34} 35}
35 36
36do_compile () { 37do_compile () {
@@ -42,7 +43,8 @@ do_compile () {
42do_install () { 43do_install () {
43 install -d ${D}/boot/ 44 install -d ${D}/boot/
44 install -m 644 boot_prep/boot_prep power_prep/power_prep \ 45 install -m 644 boot_prep/boot_prep power_prep/power_prep \
45 linux_prep/output-target/linux_prep linux.bd \ 46 linux_prep/output-target/linux_prep \
47 linux.bd linux.bd-dtb \
46 ${D}/boot 48 ${D}/boot
47} 49}
48 50
@@ -54,7 +56,7 @@ do_deploy () {
54 for f in boot_prep/boot_prep \ 56 for f in boot_prep/boot_prep \
55 power_prep/power_prep \ 57 power_prep/power_prep \
56 linux_prep/output-target/linux_prep \ 58 linux_prep/output-target/linux_prep \
57 linux.bd; do 59 linux.bd linux.bd-dtb; do
58 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}" 60 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}"
59 symlink_name="imx-bootlets-`basename $f`-${MACHINE}" 61 symlink_name="imx-bootlets-`basename $f`-${MACHINE}"
60 62