summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-bootlets
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-09-22 18:04:41 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2013-09-23 16:47:57 -0300
commit561842ac3e1e9f59536dbbbc4a81876f9e0df97b (patch)
tree01d6ef301265353702c55ce4bdf15a1eeaadcabe /recipes-bsp/imx-bootlets
parent49230044f3f539df519db8dce45246a79ddd7938 (diff)
downloadmeta-fsl-arm-561842ac3e1e9f59536dbbbc4a81876f9e0df97b.tar.gz
imx-bootlets: Add deploy in sstate-cache
The right way to support deployment of files is inheriting the deploy class so it is add to the sstate-cache. If we don't do that we end redoing the build without a real need. Change-Id: If0a0cdcfe8abf5b50b72a0c04c8d0d273ad1a91a Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-bootlets')
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
index dd34ba8..b96c1e9 100644
--- a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
+++ b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
@@ -14,6 +14,8 @@ SRC_URI[sha256sum] = "63f6068ae36884adef4259bbb1fe2591755718f22c46d0a59d854883df
14 14
15S = "${WORKDIR}/imx-bootlets-src-${PV}" 15S = "${WORKDIR}/imx-bootlets-src-${PV}"
16 16
17inherit deploy
18
17# Disable parallel building or it may fail to build. 19# Disable parallel building or it may fail to build.
18PARALLEL_MAKE = "" 20PARALLEL_MAKE = ""
19 21
@@ -56,7 +58,7 @@ do_install () {
56FILES_${PN} = "/boot" 58FILES_${PN} = "/boot"
57 59
58do_deploy () { 60do_deploy () {
59 install -d ${DEPLOY_DIR_IMAGE} 61 install -d ${DEPLOYDIR}
60 62
61 for f in boot_prep/boot_prep \ 63 for f in boot_prep/boot_prep \
62 power_prep/power_prep \ 64 power_prep/power_prep \
@@ -66,8 +68,8 @@ do_deploy () {
66 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}" 68 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}"
67 symlink_name="imx-bootlets-`basename $f`-${MACHINE}" 69 symlink_name="imx-bootlets-`basename $f`-${MACHINE}"
68 70
69 install -m 644 ${S}/$f ${DEPLOY_DIR_IMAGE}/$full_name 71 install -m 644 ${S}/$f ${DEPLOYDIR}/$full_name
70 (cd ${DEPLOY_DIR_IMAGE} ; rm -f $symlink_nake ; ln -sf $full_name $symlink_name) 72 (cd ${DEPLOYDIR} ; rm -f $symlink_nake ; ln -sf $full_name $symlink_name)
71 done 73 done
72} 74}
73 75