summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-imx/firmware-imx.inc
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-05-23 17:10:46 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2013-06-07 14:17:03 -0300
commitb48b63a7eaaffd6fb4814d1134fe9745c464bbe7 (patch)
treea1fc24a1a4ba82ecb8c149709f872fa23385ed16 /recipes-bsp/firmware-imx/firmware-imx.inc
parent60becee986ea14ac1297ccf45879808e67fea239 (diff)
downloadmeta-fsl-arm-b48b63a7eaaffd6fb4814d1134fe9745c464bbe7.tar.gz
firmware-imx: Remove Atheros firmware
The linux-firmware already provide the Atheros firmware so we should use it and avoid duplication. Change-Id: I5e8675612916ab20ae27e63aedba6758e9a17afb Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/firmware-imx/firmware-imx.inc')
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx.inc8
1 files changed, 3 insertions, 5 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx.inc b/recipes-bsp/firmware-imx/firmware-imx.inc
index f321617..43bdf2f 100644
--- a/recipes-bsp/firmware-imx/firmware-imx.inc
+++ b/recipes-bsp/firmware-imx/firmware-imx.inc
@@ -19,12 +19,10 @@ do_install() {
19 find ${D}/lib/firmware/ -name Android.mk -exec rm '{}' ';' 19 find ${D}/lib/firmware/ -name Android.mk -exec rm '{}' ';'
20 rm ${D}/lib/firmware/LICENCE.atheros_firmware \ 20 rm ${D}/lib/firmware/LICENCE.atheros_firmware \
21 ${D}/lib/firmware/README 21 ${D}/lib/firmware/README
22}
23
24PACKAGES += "${PN}-ath6k ${PN}-ar3k"
25 22
26FILES_${PN}-ath6k = "/lib/firmware/ath6k/*" 23 # FIXME: Remove firmware packaged in linux-firmware
27FILES_${PN}-ar3k = "/lib/firmware/ar3k/*" 24 rm -r ${D}/lib/firmware/ath6k ${D}/lib/firmware/ar3k
25}
28 26
29python populate_packages_prepend() { 27python populate_packages_prepend() {
30 vpudir = bb.data.expand('/lib/firmware/vpu', d) 28 vpudir = bb.data.expand('/lib/firmware/vpu', d)