summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-imx/firmware-imx.inc
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2015-09-17 14:27:38 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2015-09-21 16:26:29 -0300
commit075a5b1de5eaf8d598cbea97ca13032adc9bc464 (patch)
tree90279163e7be3be74a9c3bfe21e439e687f1eac3 /recipes-bsp/firmware-imx/firmware-imx.inc
parent1195b713ba5359aee817e2d8d6058d44b46cbed4 (diff)
downloadmeta-fsl-arm-075a5b1de5eaf8d598cbea97ca13032adc9bc464.tar.gz
firmware-imx: Update to 5.2 version
The package adds the EPDC waveforms and the needed changes to properly install those were done in the firmware-imx.inc file. Another change was to include the i.MX 7 in the COMPATIBLE_MACHINE list. Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/firmware-imx/firmware-imx.inc')
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx.inc13
1 files changed, 11 insertions, 2 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx.inc b/recipes-bsp/firmware-imx/firmware-imx.inc
index 558c624..fc49669 100644
--- a/recipes-bsp/firmware-imx/firmware-imx.inc
+++ b/recipes-bsp/firmware-imx/firmware-imx.inc
@@ -11,12 +11,17 @@ SRC_URI = "${FSL_MIRROR}/firmware-imx-${PV}.bin;fsl-eula=true"
11inherit fsl-eula-unpack 11inherit fsl-eula-unpack
12 12
13do_install() { 13do_install() {
14 install -d ${D}/lib/firmware 14 install -d ${D}/lib/firmware/imx
15 cp -rfv firmware/* ${D}/lib/firmware/ 15 cp -rfv firmware/* ${D}/lib/firmware/
16
17 mv ${D}/lib/firmware/epdc/ ${D}/lib/firmware/imx/epdc/
18 mv ${D}/lib/firmware/imx/epdc/epdc_ED060XH2C1.fw.nonrestricted ${D}/lib/firmware/imx/epdc/epdc_ED060XH2C1.fw
19
16 find ${D}/lib/firmware -type f -exec chmod 644 '{}' ';' 20 find ${D}/lib/firmware -type f -exec chmod 644 '{}' ';'
21 find ${D}/lib/firmware -type f -exec chown root:root '{}' ';'
17 22
18 # Remove files not going to be installed 23 # Remove files not going to be installed
19 find ${D}/lib/firmware/ -name Android.mk -exec rm '{}' ';' 24 find ${D}/lib/firmware/ -name '*.mk' -exec rm '{}' ';'
20} 25}
21 26
22python populate_packages_prepend() { 27python populate_packages_prepend() {
@@ -39,4 +44,8 @@ ALLOW_EMPTY_${PN} = "1"
39 44
40PACKAGES_DYNAMIC = "${PN}-vpu-* ${PN}-sdma-*" 45PACKAGES_DYNAMIC = "${PN}-vpu-* ${PN}-sdma-*"
41 46
47PACKAGES =+ "${PN}-epdc"
48
49FILES_${PN}-epdc = "/lib/firmware/imx/epdc/"
50
42PACKAGE_ARCH = "${MACHINE_SOCARCH}" 51PACKAGE_ARCH = "${MACHINE_SOCARCH}"