summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/elftosb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-06-01 19:28:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2012-06-01 19:28:51 -0300
commitc49ec9d065ae8546e07fd462e818ddf298778ad9 (patch)
tree856f57e40fa5d5db22d9e5ba3415ab030c604771 /recipes-bsp/elftosb
parentd7cd549e529238030f434bf0cb2e85bd3d917813 (diff)
downloadmeta-fsl-arm-c49ec9d065ae8546e07fd462e818ddf298778ad9.tar.gz
elftosb: don't use full path for headers
This fixes the building on new host distributions where header might move due multilib support and other possible changes in future. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/elftosb')
-rw-r--r--recipes-bsp/elftosb/elftosb_10.12.01.bb5
-rw-r--r--recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch42
2 files changed, 45 insertions, 2 deletions
diff --git a/recipes-bsp/elftosb/elftosb_10.12.01.bb b/recipes-bsp/elftosb/elftosb_10.12.01.bb
index 08cca38..827379e 100644
--- a/recipes-bsp/elftosb/elftosb_10.12.01.bb
+++ b/recipes-bsp/elftosb/elftosb_10.12.01.bb
@@ -5,11 +5,12 @@ DESCRIPTION = "Helper utility for freescale imx platforms"
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=172ede34353056ebec7a597d8459f029" 6LIC_FILES_CHKSUM = "file://COPYING;md5=172ede34353056ebec7a597d8459f029"
7SECTION = "bootloader" 7SECTION = "bootloader"
8PR = "r2" 8PR = "r3"
9BBCLASSEXTEND = "native" 9BBCLASSEXTEND = "native"
10 10
11SRC_URI = "http://repository.timesys.com/buildsources/e/elftosb/elftosb-${PV}/elftosb-${PV}.tar.gz \ 11SRC_URI = "http://repository.timesys.com/buildsources/e/elftosb/elftosb-${PV}/elftosb-${PV}.tar.gz \
12 file://cross-build.patch" 12 file://cross-build.patch \
13 file://don-t-use-full-path-for-headers.patch"
13SRC_URI[md5sum] = "e8005d606c1e0bb3507c82f6eceb3056" 14SRC_URI[md5sum] = "e8005d606c1e0bb3507c82f6eceb3056"
14SRC_URI[sha256sum] = "77bb6981620f7575b87d136d94c7daa88dd09195959cc75fc18b138369ecd42b" 15SRC_URI[sha256sum] = "77bb6981620f7575b87d136d94c7daa88dd09195959cc75fc18b138369ecd42b"
15 16
diff --git a/recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch b/recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch
new file mode 100644
index 0000000..8996ffb
--- /dev/null
+++ b/recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch
@@ -0,0 +1,42 @@
1elftosb: don't use full path for headers
2
3This fixes the building on new host distributions where header might
4move due multilib support and other possible changes in future.
5
6Upstream-Status: Pending
7
8Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
9---
10 common/stdafx.h | 2 +-
11 stdafx.h | 2 +-
12 2 files changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/common/stdafx.h b/common/stdafx.h
15index e6bf9dd..fb3c2d7 100644
16--- a/common/stdafx.h
17+++ b/common/stdafx.h
18@@ -27,7 +27,7 @@
19 // For Linux systems only, types.h only defines the signed
20 // integer types. This is not professional code.
21 // Update: They are defined in the header files in the more recent version of redhat enterprise gcc.
22-#include "/usr/include/sys/types.h"
23+#include <sys/types.h>
24 #include <stdint.h>
25 //typedef unsigned long uint32_t;
26 //typedef unsigned short uint16_t;
27diff --git a/stdafx.h b/stdafx.h
28index ce80458..6ff2f44 100644
29--- a/stdafx.h
30+++ b/stdafx.h
31@@ -27,7 +27,7 @@
32 // For Linux systems only, types.h only defines the signed
33 // integer types. This is not professional code.
34 // Update: They are defined in the header files in the more recent version of redhat enterprise gcc.
35-#include "/usr/include/sys/types.h"
36+#include <sys/types.h>
37 //typedef unsigned long uint32_t;
38 //typedef unsigned short uint16_t;
39 //typedef unsigned char uint8_t;
40--
411.7.2.5
42