summaryrefslogtreecommitdiffstats
path: root/qt5-layer
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-02-16 16:32:49 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-02-19 21:04:05 -0200
commit8b88ac20fcdb7f1b1bf93bf0dbafe4cef620ab7d (patch)
tree9272328e9ceb925095aa5e69d03b632aa085905f /qt5-layer
parent9b1ac9b52f1404c608824b39f526625c9bbd4b41 (diff)
downloadmeta-fsl-arm-8b88ac20fcdb7f1b1bf93bf0dbafe4cef620ab7d.tar.gz
qtbase: Remove distribution-related settings
The use of TSLib, ICU and availability of examples is a distribution configuration and not a BSP thing. Drop this settings from the bbappend. WARNING ------- This breaks QtWebKit based applications, as OE-Core and Poky distros does not add 'icu' to the DISTRO_FEATURES list. Change-Id: Ief633eab9473c3fddd359132ce7196e30b3ea293 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'qt5-layer')
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend4
1 files changed, 1 insertions, 3 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 64966c2..de33804 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -10,17 +10,15 @@ IS_MX6SL = "0"
10IS_MX6SL_mx6sl = "1" 10IS_MX6SL_mx6sl = "1"
11 11
12PACKAGECONFIG_GL_mx5 = "gles2" 12PACKAGECONFIG_GL_mx5 = "gles2"
13PACKAGECONFIG_append_mx5 = " tslib icu examples"
14 13
15PACKAGECONFIG_GL_mx6q = "gles2" 14PACKAGECONFIG_GL_mx6q = "gles2"
16PACKAGECONFIG_GL_mx6dl = "gles2" 15PACKAGECONFIG_GL_mx6dl = "gles2"
17PACKAGECONFIG_GL_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \ 16PACKAGECONFIG_GL_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \
18 ' gl', '', d)}" 17 ' gl', '', d)}"
19PACKAGECONFIG_append_mx6 = " tslib icu examples"
20QT_CONFIG_FLAGS_append_mx6q = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" 18QT_CONFIG_FLAGS_append_mx6q = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
21QT_CONFIG_FLAGS_append_mx6dl = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" 19QT_CONFIG_FLAGS_append_mx6dl = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
22QT_CONFIG_FLAGS_append_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \ 20QT_CONFIG_FLAGS_append_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \
23 ' -no-eglfs', ' -no-opengl -linuxfb -no-icu -no-eglfs', d)}" 21 ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}"
24 22
25do_configure_prepend_mx5() { 23do_configure_prepend_mx5() {
26 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf 24 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf