summaryrefslogtreecommitdiffstats
path: root/qt5-layer
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-03-06 14:47:40 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2014-03-11 08:09:21 -0300
commit5816e7cf5db6c8bf6ca098764388ab2017c84136 (patch)
tree56c032eb2f38146cd2e3cb681b42eaa1c7085580 /qt5-layer
parentd4fa96358924633abfe176ace836ef852fc69575 (diff)
downloadmeta-fsl-arm-5816e7cf5db6c8bf6ca098764388ab2017c84136.tar.gz
qtbase: Disable eglfs build for i.MX6 SoCs using X11
The eglfs hooks require the Framebuffer API calls which are not available when building for X11; to allow qtbase to build for X11 we must disable eglfs support due this restriction. A patch to workaround EGL initialization failure due visual mismatch has been included as well, forcing Visual ID 33. Change-Id: I564b0d30f137e55885268b656e68fdc3151fb93d Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'qt5-layer')
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch23
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend5
2 files changed, 28 insertions, 0 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch b/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch
new file mode 100644
index 0000000..b0be292
--- /dev/null
+++ b/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch
@@ -0,0 +1,23 @@
1Workaround EGL initialization failure due visual mismatch
2
3Error:
4
5Warning: EGL suggested using X Visual ID 33 (RGB888) for EGL config 28 (RGB444), but this is incompatable
6Unable to find an X11 visual which matches EGL config 28
7Could not initialize EGL
8Aborted
9
10Upstream-Status: Inappropriate [workaround]
11
12Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
13
14diff -Naur qtbase-opensource-src-5.1.1_original/src/platformsupport/eglconvenience/qxlibeglintegration.cpp qtbase-opensource-src-5.1.1/src/platformsupport/eglconvenience/qxlibeglintegration.cpp
15--- qtbase-opensource-src-5.1.1_original/src/platformsupport/eglconvenience/qxlibeglintegration.cpp 2013-12-25 19:08:42.163895341 -0800
16+++ qtbase-opensource-src-5.1.1/src/platformsupport/eglconvenience/qxlibeglintegration.cpp 2013-12-25 19:09:37.207893799 -0800
17@@ -180,5 +180,5 @@
18 }
19
20 qWarning("Unable to find an X11 visual which matches EGL config %d", configId);
21- return (VisualID)0;
22+ return (VisualID)33;
23 }
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 310d7f7..c1df764 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -1,5 +1,9 @@
1# Copyright (C) 2013 Eric Bénard - Eukréa Electromatique 1# Copyright (C) 2013 Eric Bénard - Eukréa Electromatique
2 2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
4
5SRC_URI += "file://Force_egl_visual_ID_33.patch"
6
3HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" 7HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}"
4 8
5PACKAGECONFIG_GL_mx5 = "gles2" 9PACKAGECONFIG_GL_mx5 = "gles2"
@@ -7,6 +11,7 @@ PACKAGECONFIG_append_mx5 = " tslib icu examples"
7 11
8PACKAGECONFIG_GL_mx6 = "gles2" 12PACKAGECONFIG_GL_mx6 = "gles2"
9PACKAGECONFIG_append_mx6 = " tslib icu examples" 13PACKAGECONFIG_append_mx6 = " tslib icu examples"
14QT_CONFIG_FLAGS_append_mx6 = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', '', d)}"
10 15
11do_configure_prepend_mx5() { 16do_configure_prepend_mx5() {
12 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf 17 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf