summaryrefslogtreecommitdiffstats
path: root/qt5-layer
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2014-09-09 21:06:45 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2014-09-15 09:34:38 -0300
commit55399e019633c0a6636c3733746d4b2af6ae76a6 (patch)
treee57f6e9eb4bccd26080d18848e1fe702e7d081ea /qt5-layer
parent1ed2b27171c4d553cc84655af9a19f50c3084199 (diff)
downloadmeta-fsl-arm-55399e019633c0a6636c3733746d4b2af6ae76a6.tar.gz
qtbase: Include Sololite changes.
Sololite x11 backend only supports mesa software rendering GL but does not support GLES. Sololite non-x11 backends (fb, wayland and dfb) do not support GL and GLES. Change qtbase recipe to support sololite qt for all backends. Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'qt5-layer')
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend20
1 files changed, 18 insertions, 2 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 20fc15f..64966c2 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -6,12 +6,21 @@ SRC_URI += "file://Force_egl_visual_ID_33.patch"
6 6
7HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" 7HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}"
8 8
9IS_MX6SL = "0"
10IS_MX6SL_mx6sl = "1"
11
9PACKAGECONFIG_GL_mx5 = "gles2" 12PACKAGECONFIG_GL_mx5 = "gles2"
10PACKAGECONFIG_append_mx5 = " tslib icu examples" 13PACKAGECONFIG_append_mx5 = " tslib icu examples"
11 14
12PACKAGECONFIG_GL_mx6 = "gles2" 15PACKAGECONFIG_GL_mx6q = "gles2"
16PACKAGECONFIG_GL_mx6dl = "gles2"
17PACKAGECONFIG_GL_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \
18 ' gl', '', d)}"
13PACKAGECONFIG_append_mx6 = " tslib icu examples" 19PACKAGECONFIG_append_mx6 = " tslib icu examples"
14QT_CONFIG_FLAGS_append_mx6 = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" 20QT_CONFIG_FLAGS_append_mx6q = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
21QT_CONFIG_FLAGS_append_mx6dl = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
22QT_CONFIG_FLAGS_append_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \
23 ' -no-eglfs', ' -no-opengl -linuxfb -no-icu -no-eglfs', d)}"
15 24
16do_configure_prepend_mx5() { 25do_configure_prepend_mx5() {
17 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf 26 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf
@@ -36,10 +45,17 @@ do_configure_prepend_mx6() {
36 # adapt qmake.conf to our needs 45 # adapt qmake.conf to our needs
37 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf 46 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf
38 if test ${HAS_X11} -eq 0; then 47 if test ${HAS_X11} -eq 0; then
48 if test ${IS_MX6SL} -eq 0; then
49
39 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF 50 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
40EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/qeglfshooks_imx6.cpp 51EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/qeglfshooks_imx6.cpp
41IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 52IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1
42EOF 53EOF
54 else
55cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
56IMX6_CFLAGS = -DLINUX=1
57EOF
58fi
43 # copy the hook in the mkspecs directory OE is using 59 # copy the hook in the mkspecs directory OE is using
44 cp ${S}/mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp ${S}/mkspecs/linux-oe-g++/ 60 cp ${S}/mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp ${S}/mkspecs/linux-oe-g++/
45 else 61 else