summaryrefslogtreecommitdiffstats
path: root/qt5-layer
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-08-05 08:50:26 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-08-06 09:29:58 -0300
commit3b698004698742130f87dd4d9edaabdf58c4e079 (patch)
tree5e722e51b9ce14dc5def3e9350a357146ca3835d /qt5-layer
parent860d66d32f3071dbd07f21c73ec1e06d5566c5ca (diff)
downloadmeta-fsl-arm-3b698004698742130f87dd4d9edaabdf58c4e079.tar.gz
Drop Freescale official Linux kernel for i.MX23, i.MX28 and i.MX5 SoC families
The Linux kernel provided by Freescale for i.MX28 and i.MX5 is too old (2.6.35.3) and there are no plans to upgrade it, as the OE-Core is going to use GCC 5.2 as default compiler soon and it is not possible to compile this kernel with the new toolchain, thus the removal. The metadata related to the i.MX23, i.MX28 and i.MX5 SoC family, which is dependant of this Linux kernel support, has been removed in this commit so if someone ever wants to bring it back it is easy to find out all the necessary changes. The recipes affected are: - alsa-state - amd-gpu-x11-bin - gtk+3 - imx-lib - imx-test - imx-vpu - libfslcodec - linux-imx - mesa - qt4-embedded-free - qt4-x11-free - qtbase - xf86-video-imxfb Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Acked-by: Daiane Angolini <daiane.angolini@freescale.com>
Diffstat (limited to 'qt5-layer')
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend22
1 files changed, 0 insertions, 22 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index e0979bf..2803d0a 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -9,9 +9,6 @@ HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}"
9IS_MX6SL = "0" 9IS_MX6SL = "0"
10IS_MX6SL_mx6sl = "1" 10IS_MX6SL_mx6sl = "1"
11 11
12PACKAGECONFIG_GL_mx5 = "gles2"
13QT_CONFIG_FLAGS_append_mx5 = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
14
15PACKAGECONFIG_GL_mx6q = "gles2" 12PACKAGECONFIG_GL_mx6q = "gles2"
16PACKAGECONFIG_GL_mx6dl = "gles2" 13PACKAGECONFIG_GL_mx6dl = "gles2"
17PACKAGECONFIG_GL_mx6sx = "gles2" 14PACKAGECONFIG_GL_mx6sx = "gles2"
@@ -22,25 +19,6 @@ QT_CONFIG_FLAGS_append_mx6sx = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no
22QT_CONFIG_FLAGS_append_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', \ 19QT_CONFIG_FLAGS_append_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', \
23 ' -no-opengl -linuxfb -no-eglfs', d)}" 20 ' -no-opengl -linuxfb -no-eglfs', d)}"
24 21
25do_configure_prepend_mx5() {
26 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf
27
28 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
29IMX5_CFLAGS = -D_LINUX=1
30QMAKE_LIBS_EGL += -lEGL
31QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL
32QMAKE_LIBS_OPENVG += -lOpenVG -lEGL
33
34QMAKE_CFLAGS_RELEASE += \$\$IMX5_CFLAGS
35QMAKE_CXXFLAGS_RELEASE += \$\$IMX5_CFLAGS
36QMAKE_CFLAGS_DEBUG += \$\$IMX5_CFLAGS
37QMAKE_CXXFLAGS_DEBUG += \$\$IMX5_CFLAGS
38
39load(qt_config)
40
41EOF
42}
43
44do_configure_prepend_mx6() { 22do_configure_prepend_mx6() {
45 # adapt qmake.conf to our needs 23 # adapt qmake.conf to our needs
46 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf 24 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf