summaryrefslogtreecommitdiffstats
path: root/openembedded-layer
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2015-01-08 15:07:11 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-13 11:07:12 -0200
commit568439bd74971f28aafa2baa608ded9b37f93fa6 (patch)
tree8259fdd16f57e4c5eebe2598c2a1ab19e3e0573c /openembedded-layer
parent19ef29d440c4a2934d2533f3ed1d8a1e8c06365b (diff)
downloadmeta-fsl-arm-568439bd74971f28aafa2baa608ded9b37f93fa6.tar.gz
asf : add recipes for Layerscape1 support
1. ASF depend on ipsec-tools in meta-openembeded. 2. ASF is Linux kernel implementation for accelerating the data pat processing on the Freescale family of processors Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'openembedded-layer')
-rw-r--r--openembedded-layer/recipes-kernel/asf/asf_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-kernel/asf/asf_git.bb b/openembedded-layer/recipes-kernel/asf/asf_git.bb
new file mode 100644
index 0000000..676c547
--- /dev/null
+++ b/openembedded-layer/recipes-kernel/asf/asf_git.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
2SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=sdk-v1.7.x"
7SRCREV = "16eb472d6b2b34c8b605a86c469611bc8ddec1c9"
8
9inherit module
10
11S = "${WORKDIR}/git/asfmodule"
12
13EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
14export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
15
16INHIBIT_PACKAGE_STRIP = "1"
17
18do_install(){
19 mkdir -p ${D}/${libexecdir}
20 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/asf
21 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
22 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
23 cp -rf ${S}/scripts ${D}/${libexecdir}/
24}
25
26FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
27RDEPENDS_${PN} += "ipsec-tools"