summaryrefslogtreecommitdiffstats
path: root/efl-layer
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-10-22 21:11:12 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-10-24 18:35:18 -0200
commit3c3b70694910652aa471d5195bf88b2f5d394336 (patch)
treed0da93fb3c76bcefeb41a64fffe9dcdcd6485e2c /efl-layer
parentddd2feebff74d0fff7ebaca4089d524e4c31ce5c (diff)
downloadmeta-fsl-arm-3c3b70694910652aa471d5195bf88b2f5d394336.tar.gz
efl: fix build with current master meta-oe/oe-core
fixes: | In file included from /home/a.mueller/tmp/oe-core-glibc/sysroots/zeravarimx6q/usr/include/EGL/eglplatform.h:38:0, | from /home/a.mueller/tmp/oe-core-glibc/sysroots/zeravarimx6q/usr/include/EGL/egl.h:39, | from ../src/modules/evas/engines/gl_common/evas_gl_api_ext.h:7, | from ../src/modules/evas/engines/gl_common/evas_gl_core_private.h:5, | from modules/evas/engines/gl_generic/evas_engine.c:2: | /home/a.mueller/tmp/oe-core-glibc/sysroots/zeravarimx6q/usr/include/EGL/eglvivante.h:266:2: error: #error "Platform not recognized" | #error "Platform not recognized" | ^ Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'efl-layer')
-rw-r--r--efl-layer/recipes-efl/efl/efl/0001-Add-preprocessor-definitions-for-Vivante-GLES-header.patch20
1 files changed, 14 insertions, 6 deletions
diff --git a/efl-layer/recipes-efl/efl/efl/0001-Add-preprocessor-definitions-for-Vivante-GLES-header.patch b/efl-layer/recipes-efl/efl/efl/0001-Add-preprocessor-definitions-for-Vivante-GLES-header.patch
index 53f0a52..77717ac 100644
--- a/efl-layer/recipes-efl/efl/efl/0001-Add-preprocessor-definitions-for-Vivante-GLES-header.patch
+++ b/efl-layer/recipes-efl/efl/efl/0001-Add-preprocessor-definitions-for-Vivante-GLES-header.patch
@@ -11,8 +11,8 @@ Upstream-Status: Pending
11Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> 11Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
12--- 12---
13 m4/evas_check_engine.m4 | 4 ++-- 13 m4/evas_check_engine.m4 | 4 ++--
14 src/Makefile_Evas.am | 2 ++ 14 src/Makefile_Evas.am | 3 ++
15 2 files changed, 4 insertions(+), 2 deletions(-) 15 2 files changed, 5 insertions(+), 2 deletions(-)
16 16
17diff --git a/m4/evas_check_engine.m4 b/m4/evas_check_engine.m4 17diff --git a/m4/evas_check_engine.m4 b/m4/evas_check_engine.m4
18index 3fd4890..35d1c5f 100644 18index 3fd4890..35d1c5f 100644
@@ -34,7 +34,7 @@ diff --git a/src/Makefile_Evas.am b/src/Makefile_Evas.am
34index 644391b..6232f78 100644 34index 644391b..6232f78 100644
35--- a/src/Makefile_Evas.am 35--- a/src/Makefile_Evas.am
36+++ b/src/Makefile_Evas.am 36+++ b/src/Makefile_Evas.am
37@@ -632,6 +632,7 @@ lib_evas_libevas_la_LIBADD += @evas_engine_gl_common_libs@ 37@@ -745,6 +745,7 @@ lib_evas_libevas_la_LIBADD += @evas_engine_gl_common_libs@
38 else 38 else
39 noinst_LTLIBRARIES += modules/evas/engines/gl_common/libevas_engine_gl_common.la 39 noinst_LTLIBRARIES += modules/evas/engines/gl_common/libevas_engine_gl_common.la
40 modules_evas_engines_gl_common_libevas_engine_gl_common_la_SOURCES = $(GL_COMMON_SOURCES) 40 modules_evas_engines_gl_common_libevas_engine_gl_common_la_SOURCES = $(GL_COMMON_SOURCES)
@@ -42,9 +42,17 @@ index 644391b..6232f78 100644
42 modules_evas_engines_gl_common_libevas_engine_gl_common_la_CPPFLAGS = -I$(top_builddir)/src/lib/efl \ 42 modules_evas_engines_gl_common_libevas_engine_gl_common_la_CPPFLAGS = -I$(top_builddir)/src/lib/efl \
43 -I$(top_srcdir)/src/lib/evas/include \ 43 -I$(top_srcdir)/src/lib/evas/include \
44 -I$(top_srcdir)/src/lib/evas/cserve2 \ 44 -I$(top_srcdir)/src/lib/evas/cserve2 \
45@@ -736,6 +737,7 @@ else 45@@ -766,6 +767,7 @@ modules_evas_engines_gl_generic_module_la_CFLAGS = \
46 engineglx11pkgdir = $(libdir)/evas/modules/engines/gl_x11/$(MODULE_ARCH) 46 -I$(top_srcdir)/src/lib/evas/cserve2 \
47 engineglx11pkg_LTLIBRARIES = modules/evas/engines/gl_x11/module.la 47 -I$(top_srcdir)/src/modules/evas/engines/gl_common \
48 -I$(top_builddir)/src/modules/evas/engines/gl_generic \
49+-DLINUX \
50 @evas_engine_gl_common_cflags@ \
51 @EVAS_CFLAGS@
52 modules_evas_engines_gl_generic_module_la_LIBADD = \
53@@ -897,6 +899,7 @@ install_engineglx11pkgLTLIBRARIES = install-engineglx11pkgLTLIBRARIES
54 $(install_engineglx11pkgLTLIBRARIES): install-libLTLIBRARIES
55
48 modules_evas_engines_gl_x11_module_la_SOURCES = $(GL_X11_SOURCES) 56 modules_evas_engines_gl_x11_module_la_SOURCES = $(GL_X11_SOURCES)
49+modules_evas_engines_gl_x11_module_la_CFLAGS = -DLINUX 57+modules_evas_engines_gl_x11_module_la_CFLAGS = -DLINUX
50 modules_evas_engines_gl_x11_module_la_CPPFLAGS = -I$(top_builddir)/src/lib/efl \ 58 modules_evas_engines_gl_x11_module_la_CPPFLAGS = -I$(top_builddir)/src/lib/efl \