summaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-04-14 16:23:52 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-15 18:21:47 +0000
commit93c4f272e0a362602f9953b02eaa44d451601b3a (patch)
tree43d8f42d62cfd6cbdbb2d4c3170a243e9b0b350a /classes
parent682b957545172a79cfb19108a9d0b61209f8671e (diff)
downloadmeta-fsl-arm-93c4f272e0a362602f9953b02eaa44d451601b3a.tar.gz
mfgtool-initramfs-image.bbclass: Fix parsing when using a barebox based machine
When building for cfa100xx machines, for meta-fsl-arm-extra, the parsing is aborted with: ,---- | ERROR: No IMAGE_CMD defined for IMAGE_FSTYPES entry | 'barebox.mxsboot-sdcard' - possibly invalid type name or missing | support class | ERROR: Failed to parse recipe: | .../sources/meta-fsl-arm/recipes-fsl/images/fsl-image-mfgtool-initramfs.bb `---- This error was caused by the image not providing all the filesystem types as in fact it generates a Gzipped CPIO filesystem and does not inherit the default ones. To solve the error we ought to include the override for 'mxs' SoC family so the right setting is used as well in this set of SoCs. Change-Id: If6e657793ed7af07decac217f6b3371fad1f521c Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'classes')
-rw-r--r--classes/mfgtool-initramfs-image.bbclass3
1 files changed, 2 insertions, 1 deletions
diff --git a/classes/mfgtool-initramfs-image.bbclass b/classes/mfgtool-initramfs-image.bbclass
index dee3137..42792f6 100644
--- a/classes/mfgtool-initramfs-image.bbclass
+++ b/classes/mfgtool-initramfs-image.bbclass
@@ -4,7 +4,7 @@
4# image provides the utilities which are used, in the target, during 4# image provides the utilities which are used, in the target, during
5# the process and receive the commands from the MfgTool application. 5# the process and receive the commands from the MfgTool application.
6# 6#
7# Copyright 2014 (C) O.S. Systems Software LTDA. 7# Copyright 2014, 2016 (C) O.S. Systems Software LTDA.
8 8
9DEPENDS += "u-boot-mfgtool linux-mfgtool" 9DEPENDS += "u-boot-mfgtool linux-mfgtool"
10 10
@@ -13,6 +13,7 @@ FEATURE_PACKAGES_extfs = "packagegroup-fsl-mfgtool-extfs"
13FEATURE_PACKAGES_f2fs = "packagegroup-fsl-mfgtool-f2fs" 13FEATURE_PACKAGES_f2fs = "packagegroup-fsl-mfgtool-f2fs"
14 14
15IMAGE_FSTYPES = "cpio.gz.u-boot" 15IMAGE_FSTYPES = "cpio.gz.u-boot"
16IMAGE_FSTYPES_mxs = "cpio.gz.u-boot"
16IMAGE_ROOTFS_SIZE ?= "8192" 17IMAGE_ROOTFS_SIZE ?= "8192"
17IMAGE_CLASSES = "image_types_uboot" 18IMAGE_CLASSES = "image_types_uboot"
18 19