summaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-06-10 12:34:38 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2016-06-16 09:36:06 -0300
commit3dc53f9b4d20a528d229d9f29ed3885fa6561787 (patch)
tree06d7941b0925c31a1be1bb0616ed3450f121bee0 /classes
parent00b46e11e32f859a0d2dad5a5d53d5540be9c15e (diff)
downloadmeta-fsl-arm-3dc53f9b4d20a528d229d9f29ed3885fa6561787.tar.gz
fsl-kernel-localversion: Configure kernel in a separate task
As it is implemented right now this class overwrites the .config file making it impossible for any other layer to configure the kernel in a .bbappend to the kernel recipe. By doing it in a separate task before do_configure we ensure that recipe .bbappends can make further kernel configurations in do_configure_prepend. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'classes')
-rw-r--r--classes/fsl-kernel-localversion.bbclass3
1 files changed, 2 insertions, 1 deletions
diff --git a/classes/fsl-kernel-localversion.bbclass b/classes/fsl-kernel-localversion.bbclass
index 1004e35..42c2b17 100644
--- a/classes/fsl-kernel-localversion.bbclass
+++ b/classes/fsl-kernel-localversion.bbclass
@@ -22,7 +22,7 @@ kernel_conf_variable() {
22 fi 22 fi
23} 23}
24 24
25do_configure_prepend() { 25do_preconfigure() {
26 echo "" > ${B}/.config 26 echo "" > ${B}/.config
27 CONF_SED_SCRIPT="" 27 CONF_SED_SCRIPT=""
28 28
@@ -37,3 +37,4 @@ do_configure_prepend() {
37 printf "%s%s" +g $head > ${S}/.scmversion 37 printf "%s%s" +g $head > ${S}/.scmversion
38 fi 38 fi
39} 39}
40addtask preconfigure before do_configure after do_patch