summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-05-01 16:00:43 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2014-05-05 09:34:23 -0300
commite39dc2c1dc05f9a25bb1f80a3926d932e99beb8e (patch)
tree10d0e9dbe0967b4b643e692572d7c78c903170c2
parent700af12aa8e2fe7b739c246abd5b1cb237b2eb06 (diff)
downloadmeta-fsl-arm-e39dc2c1dc05f9a25bb1f80a3926d932e99beb8e.tar.gz
gst-fsl-plugin: Remove unused patches
Following patches: - configure.ac-Fix-checking-for-include-headers-in-mul.patch - makefile.am-fix-aac-for-imx6.patch - remove-GST_INFO-in-mfw_gst_utils.h.patch were unused, so remove them. Change-Id: I3e0bc71ec8a64059d63e74ee46cdd89cfd599a82 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch63
-rw-r--r--recipes-multimedia/gstreamer/gst-fsl-plugin/makefile.am-fix-aac-for-imx6.patch11
-rw-r--r--recipes-multimedia/gstreamer/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch40
3 files changed, 0 insertions, 114 deletions
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch b/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch
deleted file mode 100644
index 02b5208..0000000
--- a/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch
+++ /dev/null
@@ -1,63 +0,0 @@
1From be38dc1816d4de1a1b463988763f50226eb8417f Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Thu, 7 Nov 2013 10:50:51 -0200
4Subject: [PATCH] configure.ac: Fix checking for include headers in multiple
5 paths
6Organization: O.S. Systems Software LTDA.
7
8This fixes the support for proper detecting Freescale specific headers
9in include/linux and include/uapi.
10
11Without this patch we have the configure log with the same feature in
12'enabled' and 'disabled' state and it was impossible to override the
13CPPFLAGS.
14
15Upstream-Status: Pending
16
17Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
18---
19 configure.ac | 19 ++++++++-----------
20 1 file changed, 8 insertions(+), 11 deletions(-)
21
22diff --git a/configure.ac b/configure.ac
23index d74ee0e..f11c76c 100755
24--- a/configure.ac
25+++ b/configure.ac
26@@ -58,13 +58,9 @@ AC_DEFUN([CHECK_DISABLE_FEATURE],
27 [use_[$1]=$enableval],
28 [use_[$1]=yes])
29 if test "$use_[$1]" = "yes"; then
30- SAVE_CPPFLAGS="$CPPFLAGS"
31- CPPFLAGS=`$PKG_CONFIG --cflags libfslaudiocodec`
32- CPPFLAGS+=`$PKG_CONFIG --cflags libfslvideocodec`
33- CPPFLAGS+=`$PKG_CONFIG --cflags libfslparser`
34- CPPFLAGS+=`$PKG_CONFIG --cflags libfslvpuwrap`
35- AC_CHECK_HEADERS([$4], HAVE_[$3]=yes, HAVE_[$3]=no && break)
36- CPPFLAGS="$SAVE_CPPFLAGS"
37+ for h in "$4"; do
38+ AC_CHECK_HEADERS([$h], HAVE_[$3]=yes && break, HAVE_[$3]=no)
39+ done
40 if test "x$HAVE_[$3]" = "xyes"; then
41 enabled_feature="$enabled_feature\n\t\t[$5]"
42 else
43@@ -283,12 +279,13 @@ CHECK_DISABLE_FEATURE(beep, [Disable beep audio decoder], [BEEP], [fsl_unia.h],
44
45 CHECK_DISABLE_FEATURE(v4lsink, [Disable fsl v4l sink], [V4L_SINK], [linux/videodev2.h], [plugin: v4lsink])
46
47+# Allow headers to be inside include/uapi and include/linux
48 saved_CFLAGS="$CFLAGS"
49 CFLAGS="$CFLAGS $IPU_CFLAGS"
50-CHECK_DISABLE_FEATURE(isink, [Disable fsl ipu sink], [I_SINK], [linux/mxcfb.h], [plugin: isink])
51-CHECK_DISABLE_FEATURE(isink, [Disable fsl ipu sink], [I_SINK], [uapi/mxcfb.h], [plugin: isink])
52-CHECK_DISABLE_FEATURE(ipucsc, [Disable fsl ipu csc], [I_CSC], [linux/mxcfb.h], [plugin: ipucsc])
53-CHECK_DISABLE_FEATURE(ipucsc, [Disable fsl ipu csc], [I_CSC], [uapi/mxcfb.h], [plugin: ipucsc])
54+
55+CHECK_DISABLE_FEATURE(isink, [Disable fsl ipu sink], [I_SINK], [linux/mxcfb.h uapi/mxcfb.h], [plugin: isink])
56+CHECK_DISABLE_FEATURE(ipucsc, [Disable fsl ipu csc], [I_CSC], [linux/mxcfb.h uapi/mxcfb.h], [plugin: ipucsc])
57+
58 CFLAGS=$saved_CFLAGS
59
60 CHECK_DISABLE_FEATURE(ipulib, [Disable ipu lib], [IPU_LIB], [mxc_ipu_hl_lib.h], [library: libipu])
61--
621.8.4.rc3
63
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin/makefile.am-fix-aac-for-imx6.patch b/recipes-multimedia/gstreamer/gst-fsl-plugin/makefile.am-fix-aac-for-imx6.patch
deleted file mode 100644
index d12dc33..0000000
--- a/recipes-multimedia/gstreamer/gst-fsl-plugin/makefile.am-fix-aac-for-imx6.patch
+++ /dev/null
@@ -1,11 +0,0 @@
1--- a/Makefile.am 2013-09-10 20:52:22.000000000 +0200
2+++ b/Makefile.am 2013-12-05 18:26:24.964585163 +0100
3@@ -928,7 +928,7 @@
4 tools/gplay
5
6 SUBDIRS = $(AUDIODIRS) $(LIBSDIRS) $(BASEDIRS) $(VPUWRAPDIRS) $(WMA8ENC_DIR) $(MP3ENC_DIR) \
7- $(H264DEC_DIR) $(MPEG2DEC_DIR) $(MPEG4DEC_DIR) $(WMV9MPDEC_DIR) $(WMV78DEC_DIR) \
8+ $(H264DEC_DIR) $(MPEG2DEC_DIR) $(MPEG4DEC_DIR) $(WMV9MPDEC_DIR) $(WMV78DEC_DIR) $(AACDEC_DIR)\
9 $(DOWNMIX_DIR) $(AMRDEC_DIR) $(IPUDIRS) $(TOOLDIRS)
10
11 endif
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch b/recipes-multimedia/gstreamer/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch
deleted file mode 100644
index e06a250..0000000
--- a/recipes-multimedia/gstreamer/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 28ad25933dc51d8af13927a9943a353677c31a3a Mon Sep 17 00:00:00 2001
2From: Lyon Wang <lyon.wang@freescale.com>
3Date: Tue, 22 Oct 2013 16:15:43 +0800
4Subject: [PATCH] remove GST_INFO in mfw_gst_utils.h
5
6GST_INFO() should not be used in the global header
7or it will cause some macro definiation error.
8
9so comment the GST_INFO() in the mfw_gst_utils.h
10
11Upstream-Status: Backport [GIT]
12---
13 inc/plugin/mfw_gst_utils.h | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/inc/plugin/mfw_gst_utils.h b/inc/plugin/mfw_gst_utils.h
17index 366d50e..c1b6f90 100755
18--- a/inc/plugin/mfw_gst_utils.h
19+++ b/inc/plugin/mfw_gst_utils.h
20@@ -876,7 +876,7 @@ getChipCodeFromSocid (void)
21 }
22 fclose(fp);
23
24- GST_INFO("SOC is %s\n", soc_name);
25+ //GST_INFO("SOC is %s\n", soc_name);
26
27 int num = sizeof(soc_info) / sizeof(SOC_INFO);
28 int i;
29@@ -913,7 +913,7 @@ getChipCode (void)
30 }
31
32 kv = ((kv_major << 16) + (kv_minor << 8) + kv_rel);
33- GST_INFO("kernel:%s, %d.%d.%d\n", sys_name.release, kv_major, kv_minor, kv_rel);
34+ //GST_INFO("kernel:%s, %d.%d.%d\n", sys_name.release, kv_major, kv_minor, kv_rel);
35
36 if (kv < KERN_VER(3, 10, 0))
37 return getChipCodeFromCpuinfo();
38--
391.7.9.5
40