summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-20 20:50:36 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 14:07:16 -0300
commit999fcacda8f8f1af19e2ca783a0790c2dec92173 (patch)
tree6812d2dc42cb40acf5d864bfbd86b460ed5c3b23
parent7fd852118c38424e3de4721989f1ae4ac2b5dfd9 (diff)
downloadmeta-fsl-arm-999fcacda8f8f1af19e2ca783a0790c2dec92173.tar.gz
mesa: Fix override of x11 GLX support for i.MX6
The replacement of --enable-glx-tls for --enable-glx was not working due the way the variables are expanded. To fix the issue an annonymous function has been added to mangle it just before its use. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend12
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 5030e7a..f8cf1bc 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -18,6 +18,17 @@ USE_VIV_LIBGL_mx6q = "yes"
18USE_VIV_LIBGL_mx6dl = "yes" 18USE_VIV_LIBGL_mx6dl = "yes"
19USE_VIV_LIBGL_mx6sx = "yes" 19USE_VIV_LIBGL_mx6sx = "yes"
20 20
21# FIXME: mesa should support 'x11-no-tls' option
22python () {
23 overrides = d.getVar("OVERRIDES", True).split(":")
24 if "mx6" not in overrides:
25 return
26
27 extra_oeconf = d.getVar("EXTRA_OECONF", True)
28 extra_oeconf = extra_oeconf.replace("--enable-glx-tls", "--enable-glx")
29 d.setVar("EXTRA_OECONF", extra_oeconf)
30}
31
21# FIXME: Dirty hack to allow use of Vivante GPU libGL binary 32# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
22do_install_append_mx6 () { 33do_install_append_mx6 () {
23 if [ "${USE_VIV_LIBGL}" = "yes" ]; then 34 if [ "${USE_VIV_LIBGL}" = "yes" ]; then
@@ -26,4 +37,3 @@ do_install_append_mx6 () {
26 ${D}${includedir}/GL/glext.h 37 ${D}${includedir}/GL/glext.h
27 fi 38 fi
28} 39}
29EXTRA_OECONF_mx6 := "${@'${EXTRA_OECONF}'.replace('--enable-glx-tls','--enable-glx')}"