summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Martinez Canillas <javier.martinez@collabora.co.uk>2013-01-25 12:30:51 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2013-01-25 09:38:53 -0200
commit92669a8d0ef193d836c3b15b22b16ab5190a5663 (patch)
tree12d223861048a588a6f9f51af9d6308d3166335a
parenta757dcae8b204a2e08f75779393bff6075e064ce (diff)
downloadmeta-fsl-arm-92669a8d0ef193d836c3b15b22b16ab5190a5663.tar.gz
linux-imx (3.0.35): enable netfilter support
The Netfilter packet filtering framework is useful for so many use cases that most people will build kernels with it enabled. So, it could probably make sense to have it enabled by default. Signed-off-by: Javier Martinez Canillas <javier.martinez@collabora.co.uk>
-rw-r--r--recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/defconfig1
-rw-r--r--recipes-kernel/linux/linux-imx-3.0.35/mx6/defconfig1
-rw-r--r--recipes-kernel/linux/linux-imx_3.0.35.bb2
3 files changed, 3 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/defconfig b/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/defconfig
index 4941948..632fb3a 100644
--- a/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/defconfig
+++ b/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/defconfig
@@ -65,6 +65,7 @@ CONFIG_IP_PNP_DHCP=y
65CONFIG_IP_PNP_BOOTP=y 65CONFIG_IP_PNP_BOOTP=y
66# CONFIG_INET_LRO is not set 66# CONFIG_INET_LRO is not set
67# CONFIG_IPV6 is not set 67# CONFIG_IPV6 is not set
68CONFIG_NETFILTER=y
68CONFIG_LLC2=y 69CONFIG_LLC2=y
69CONFIG_CAN=y 70CONFIG_CAN=y
70CONFIG_CAN_RAW=y 71CONFIG_CAN_RAW=y
diff --git a/recipes-kernel/linux/linux-imx-3.0.35/mx6/defconfig b/recipes-kernel/linux/linux-imx-3.0.35/mx6/defconfig
index b5d222d..0b59757 100644
--- a/recipes-kernel/linux/linux-imx-3.0.35/mx6/defconfig
+++ b/recipes-kernel/linux/linux-imx-3.0.35/mx6/defconfig
@@ -67,6 +67,7 @@ CONFIG_IP_PNP_DHCP=y
67CONFIG_IP_PNP_BOOTP=y 67CONFIG_IP_PNP_BOOTP=y
68# CONFIG_INET_LRO is not set 68# CONFIG_INET_LRO is not set
69# CONFIG_IPV6 is not set 69# CONFIG_IPV6 is not set
70CONFIG_NETFILTER=y
70CONFIG_LLC2=y 71CONFIG_LLC2=y
71CONFIG_CAN=y 72CONFIG_CAN=y
72CONFIG_CAN_RAW=y 73CONFIG_CAN_RAW=y
diff --git a/recipes-kernel/linux/linux-imx_3.0.35.bb b/recipes-kernel/linux/linux-imx_3.0.35.bb
index 149366b..b0870a2 100644
--- a/recipes-kernel/linux/linux-imx_3.0.35.bb
+++ b/recipes-kernel/linux/linux-imx_3.0.35.bb
@@ -3,7 +3,7 @@
3 3
4include linux-imx.inc 4include linux-imx.inc
5 5
6PR = "${INC_PR}.9" 6PR = "${INC_PR}.10"
7 7
8COMPATIBLE_MACHINE = "(mx6)" 8COMPATIBLE_MACHINE = "(mx6)"
9 9