summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-01-06 15:27:31 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2014-01-06 15:46:17 -0200
commit5ede821064bfe6b94500a113c05d03d15c63af5e (patch)
treec8036ac04dad1c708e5bc9a2a12de7c24e8cd80a
parenta99e70cbb501f992abb8f80218fc5fb2a4fd6224 (diff)
downloadmeta-fsl-arm-5ede821064bfe6b94500a113c05d03d15c63af5e.tar.gz
u-boot-imx: Add branch information
The new BitBake fetching code requires the revision to be available in a know branch so we need to provide this information here. This patch fixes 2009.08 and 2013.04 recipes. Change-Id: Id4bbdcadb72e09eb7880ecf19b49bba0ede64f8e Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2009.08.bb10
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2013.04.bb6
2 files changed, 8 insertions, 8 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
index 8460399..2db9db2 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
@@ -1,4 +1,4 @@
1# Copyright (C) 2011-2013 Freescale Semiconductor 1# Copyright (C) 2011-2014 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4DESCRIPTION = "bootloader for imx platforms" 4DESCRIPTION = "bootloader for imx platforms"
@@ -13,16 +13,16 @@ DEPENDS_mxs += "elftosb-native"
13 13
14PR = "r15" 14PR = "r15"
15 15
16# Revision of imx_2.6.35_10.12.01 branch 16SRCBRANCH_mx5 = "imx_v2009.08_10.12.01"
17SRCREV_mxs = "e4437f1c192a1a68028e6fcff3f50ff50352041d" 17SRCREV_mxs = "e4437f1c192a1a68028e6fcff3f50ff50352041d"
18 18
19# Revision of imx_2.6.35_11.09.01 branch 19SRCBRANCH_mx5 = "imx_v2009.08_11.09.01"
20SRCREV_mx5 = "897922d01c812be802e4a928b937535ea1b8e076" 20SRCREV_mx5 = "897922d01c812be802e4a928b937535ea1b8e076"
21SRC_URI_append_imx5 = " \ 21SRC_URI_append_imx5 = " \
22 file://mx53_loco_bootenv.patch \ 22 file://mx53_loco_bootenv.patch \
23" 23"
24 24
25# Revision of imx_3.0.35_4.0.0 branch 25SRCBRANCH_mx6 = "imx_v2009.08_3.0.35_4.0.0"
26SRCREV_mx6 = "5899674bf39544bec47e209649a723cf7348d3ba" 26SRCREV_mx6 = "5899674bf39544bec47e209649a723cf7348d3ba"
27SRC_URI_append_mx6 = " \ 27SRC_URI_append_mx6 = " \
28 file://mx6q_sabreauto-Fix-the-patch-for-the-default-environ.patch \ 28 file://mx6q_sabreauto-Fix-the-patch-for-the-default-environ.patch \
@@ -31,7 +31,7 @@ SRC_URI_append_mx6 = " \
31 file://mx6dl_sabresd-Change-default-environment-to-work-wit.patch \ 31 file://mx6dl_sabresd-Change-default-environment-to-work-wit.patch \
32" 32"
33 33
34SRC_URI = "git://git.freescale.com/imx/uboot-imx.git" 34SRC_URI = "git://git.freescale.com/imx/uboot-imx.git;branch=${SRCBRANCH}"
35 35
36UBOOT_MACHINE_imx53qsb = "mx53_loco_config" 36UBOOT_MACHINE_imx53qsb = "mx53_loco_config"
37UBOOT_MACHINE_imx53ard = "mx53_ard_ddr3_config" 37UBOOT_MACHINE_imx53ard = "mx53_ard_ddr3_config"
diff --git a/recipes-bsp/u-boot/u-boot-imx_2013.04.bb b/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
index f96b159..ffa91c8 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
@@ -1,4 +1,4 @@
1# Copyright (C) 2013 Freescale Semiconductor 1# Copyright (C) 2013, 2014 Freescale Semiconductor
2 2
3DESCRIPTION = "bootloader for imx platforms" 3DESCRIPTION = "bootloader for imx platforms"
4require recipes-bsp/u-boot/u-boot.inc 4require recipes-bsp/u-boot/u-boot.inc
@@ -8,8 +8,8 @@ PROVIDES += "u-boot"
8LICENSE = "GPLv2+" 8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" 9LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
10 10
11# revision of 3.10.9-1.0.0 alpha branch 11SRCBRANCH = "imx_v2013.04_3.10.9_1.0.0_alpha"
12SRC_URI = "git://git.freescale.com/imx/uboot-imx.git;protocol=git;branch=imx_v2013.04" 12SRC_URI = "git://git.freescale.com/imx/uboot-imx.git;protocol=git;branch=${SRCBRANCH}"
13SRCREV = "d20319c25d27c38fd531e0ea97b5661268449de6" 13SRCREV = "d20319c25d27c38fd531e0ea97b5661268449de6"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"