summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Voltz <andy.voltz@timesys.com>2013-07-26 13:51:50 -0400
committerOtavio Salvador <otavio@ossystems.com.br>2013-07-29 14:00:21 -0300
commit547315e01ab1c802d8490cc087a9affa0ad6c6ee (patch)
tree83f22207647b56a3f4e3bb5665e6b34a00c50bb4
parent664f87b8fdf013ae073f523835f9eb8e508f8c6e (diff)
downloadmeta-fsl-arm-547315e01ab1c802d8490cc087a9affa0ad6c6ee.tar.gz
twr-vf65gs10: Add machine support for Vybrid Tower VF65GS10
Change-Id: I51e1b780c7860a16d722f49072915ad194fd5df7 Signed-off-by: Andy Voltz <andy.voltz@timesys.com>
-rw-r--r--conf/machine/include/imx-base.inc1
-rw-r--r--conf/machine/twr-vf65gs10.conf21
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2013.07.bb2
3 files changed, 23 insertions, 1 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index b7d04b1..bd293fd 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -18,6 +18,7 @@ UBOOT_ENTRYPOINT_mx51 = "0x90008000"
18UBOOT_ENTRYPOINT_mx53 = "0x70008000" 18UBOOT_ENTRYPOINT_mx53 = "0x70008000"
19UBOOT_ENTRYPOINT_mx6 = "0x10008000" 19UBOOT_ENTRYPOINT_mx6 = "0x10008000"
20UBOOT_ENTRYPOINT_mx6sl = "0x80008000" 20UBOOT_ENTRYPOINT_mx6sl = "0x80008000"
21UBOOT_ENTRYPOINT_vf60 = "0x80008000"
21 22
22PREFERRED_VERSION_xserver-xorg_mx6 = "2:1.11.4" 23PREFERRED_VERSION_xserver-xorg_mx6 = "2:1.11.4"
23 24
diff --git a/conf/machine/twr-vf65gs10.conf b/conf/machine/twr-vf65gs10.conf
new file mode 100644
index 0000000..00fdff4
--- /dev/null
+++ b/conf/machine/twr-vf65gs10.conf
@@ -0,0 +1,21 @@
1#@TYPE: Machine
2#@NAME: Freescale Vybrid TWR-VF65GS10
3#@SOC: vf60
4#@DESCRIPTION: Machine configuration for Freescale Vybrid TWR-VF65GS10
5
6include conf/machine/include/imx-base.inc
7include conf/machine/include/tune-cortexa5.inc
8
9SOC_FAMILY = "vf60"
10
11PREFERRED_PROVIDER_virtual/kernel = "linux-timesys"
12PREFERRED_PROVIDER_u-boot = "u-boot-fslc"
13
14UBOOT_MACHINE = "vf610twr_config"
15
16SDCARD_ROOTFS ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ext3"
17IMAGE_FSTYPES ?= "tar.bz2 ext3 sdcard"
18
19SERIAL_CONSOLE = "115200 ttyLP1"
20
21MACHINE_FEATURES = "apm usbgadget usbhost vfat alsa touchscreen"
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2013.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2013.07.bb
index 3098fdb..5845569 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2013.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2013.07.bb
@@ -2,7 +2,7 @@ require recipes-bsp/u-boot/u-boot.inc
2 2
3LICENSE = "GPLv2+" 3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" 4LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
5COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6)" 5COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6|vf60)"
6 6
7DEPENDS_mxs += "elftosb-native" 7DEPENDS_mxs += "elftosb-native"
8 8