summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-07-01 15:37:06 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-09-08 11:00:30 -0300
commit46acd9129018d3bca6426623b21610426edbeefd (patch)
tree07af9ec75571c2417570d90885e3b1035fcbcc2d
parent24ffaab8f084b1cabf2a9bb5ba333c85a409298d (diff)
downloadmeta-fsl-arm-46acd9129018d3bca6426623b21610426edbeefd.tar.gz
qtbase: Refactor code to use the new overrides
The recipe has been reworked to use the 'imxgpu2d' and 'imxgpu3d' feature overrides. While on that, the i.MX6SL specific code has been reworked to used when only 2D GPU support is available. Change-Id: I8fade08f54bd74e1dfd46b59711f6896c0bc7e6e Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend23
1 files changed, 11 insertions, 12 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index d336c0f..3b99886 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -1,25 +1,24 @@
1# Copyright (C) 2013 Eric Bénard - Eukréa Electromatique 1# Copyright (C) 2013 Eric Bénard - Eukréa Electromatique
2# Copyright (C) 2016 O.S. Systems Software LTDA.
2 3
3HAS_X11 = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" 4HAS_X11 = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 1, 0, d)}"
4 5
5IS_MX6SL = "0" 6IMXGPU_imxgpu3d = "3d"
6IS_MX6SL_mx6sl = "1" 7IMXGPU_imxgpu2d = "2d"
7 8
8PACKAGECONFIG_GL_mx6q = "gles2" 9PACKAGECONFIG_GL_imxgpu3d = "gles2"
9PACKAGECONFIG_GL_mx6dl = "gles2" 10PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}"
10PACKAGECONFIG_GL_mx6sx = "gles2" 11
11PACKAGECONFIG_GL_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}" 12QT_CONFIG_FLAGS_APPEND = ""
12QT_CONFIG_FLAGS_append_mx6q = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" 13QT_CONFIG_FLAGS_APPEND_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}"
13QT_CONFIG_FLAGS_append_mx6dl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" 14QT_CONFIG_FLAGS_APPEND_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
14QT_CONFIG_FLAGS_append_mx6sx = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" 15QT_CONFIG_FLAGS_append = " ${QT_CONFIG_FLAGS_APPEND}"
15QT_CONFIG_FLAGS_append_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', \
16 ' -no-opengl -linuxfb -no-eglfs', d)}"
17 16
18do_configure_prepend_mx6() { 17do_configure_prepend_mx6() {
19 # adapt qmake.conf to our needs 18 # adapt qmake.conf to our needs
20 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf 19 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf
21 if test ${HAS_X11} -eq 0; then 20 if test ${HAS_X11} -eq 0; then
22 if test ${IS_MX6SL} -eq 0; then 21 if [ "${IMXGPU}" = "3d"; then
23 22
24 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF 23 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
25IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 24IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1