summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-01-22 09:10:22 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2013-01-22 09:11:50 -0200
commit17f43574a70ea27627235c574a4fff1a247dea91 (patch)
tree06245cc3f861916a66ac0f3e39e2bfc5dd3a1e9e
parent327c3cf5d86863291a237ff2bbbf7608864c8192 (diff)
downloadmeta-fsl-arm-17f43574a70ea27627235c574a4fff1a247dea91.tar.gz
linux-imx (3.0.35): Fix imx6sabrelite patch to remove eGalax change
The eGalax change is now applied in all linux-imx-3.0.35 kernels so we need to remove this from the patch. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch50
-rw-r--r--recipes-kernel/linux/linux-imx_3.0.35.bb2
2 files changed, 1 insertions, 51 deletions
diff --git a/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch b/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch
index d0b6b0a..48cf7a7 100644
--- a/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch
+++ b/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch
@@ -5085,23 +5085,6 @@ new mode 100644
5085index 7cf975a..a2589e4 5085index 7cf975a..a2589e4
5086--- a/drivers/input/touchscreen/Kconfig 5086--- a/drivers/input/touchscreen/Kconfig
5087+++ b/drivers/input/touchscreen/Kconfig 5087+++ b/drivers/input/touchscreen/Kconfig
5088@@ -199,6 +199,16 @@ config TOUCHSCREEN_ELAN
5089 To compile this driver as a module, choose M here: the
5090 module will be called elan-touch.
5091
5092+config TOUCHSCREEN_EGALAX_SINGLE_TOUCH
5093+ bool "EETI eGalax touchscreen as single-touch"
5094+ default N
5095+ depends on TOUCHSCREEN_EGALAX
5096+ help
5097+ If you say yes here you get single-touch touchscreen support
5098+ on the eGalax I2C controller.
5099+ If you say "no", you'll get the normal multi-touch.
5100+
5101+
5102 config TOUCHSCREEN_FUJITSU
5103 tristate "Fujitsu serial touchscreen"
5104 select SERIO
5105@@ -282,6 +292,22 @@ config TOUCHSCREEN_MAX11801 5088@@ -282,6 +292,22 @@ config TOUCHSCREEN_MAX11801
5106 To compile this driver as a module, choose M here: the 5089 To compile this driver as a module, choose M here: the
5107 module will be called max11801_ts. 5090 module will be called max11801_ts.
@@ -5166,39 +5149,6 @@ index e614512..eac3453
5166diff --git a/drivers/input/touchscreen/da9052_tsi_filter.c b/drivers/input/touchscreen/da9052_tsi_filter.c 5149diff --git a/drivers/input/touchscreen/da9052_tsi_filter.c b/drivers/input/touchscreen/da9052_tsi_filter.c
5167old mode 100755 5150old mode 100755
5168new mode 100644 5151new mode 100644
5169diff --git a/drivers/input/touchscreen/egalax_ts.c b/drivers/input/touchscreen/egalax_ts.c
5170index fff8afe..0b6cde7 100644
5171--- a/drivers/input/touchscreen/egalax_ts.c
5172+++ b/drivers/input/touchscreen/egalax_ts.c
5173@@ -139,7 +139,7 @@ retry:
5174 events[id].x = x;
5175 events[id].y = y;
5176
5177-#ifdef FORCE_SINGLE_POINTER_SUPPORT
5178+#ifdef CONFIG_TOUCHSCREEN_EGALAX_SINGLE_TOUCH
5179 input_report_abs(input_dev, ABS_X, x);
5180 input_report_abs(input_dev, ABS_Y, y);
5181 input_event(data->input_dev, EV_KEY, BTN_TOUCH, 1);
5182@@ -166,7 +166,7 @@ retry:
5183 dev_dbg(&client->dev, "release id:%d\n", id);
5184 events[id].valid = 0;
5185 events[id].status = 0;
5186-#ifdef FORCE_SINGLE_POINTER_SUPPORT
5187+#ifdef CONFIG_TOUCHSCREEN_EGALAX_SINGLE_TOUCH
5188 input_report_key(input_dev, BTN_TOUCH, 0);
5189 input_report_abs(input_dev, ABS_PRESSURE, 0);
5190 #else
5191@@ -256,8 +256,9 @@ static int __devinit egalax_ts_probe(struct i2c_client *client,
5192 __set_bit(ABS_PRESSURE, input_dev->absbit);
5193 input_set_abs_params(input_dev, ABS_X, 0, 32767, 0, 0);
5194 input_set_abs_params(input_dev, ABS_Y, 0, 32767, 0, 0);
5195+ input_set_abs_params(input_dev, ABS_PRESSURE, 0, 1, 0, 0);
5196
5197-#ifndef FORCE_SINGLE_POINTER_SUPPORT
5198+#ifndef CONFIG_TOUCHSCREEN_EGALAX_SINGLE_TOUCH
5199 input_set_abs_params(input_dev, ABS_MT_POSITION_X, 0, 32767, 0, 0);
5200 input_set_abs_params(input_dev, ABS_MT_POSITION_Y, 0, 32767, 0, 0);
5201 input_set_abs_params(input_dev, ABS_MT_TOUCH_MAJOR, 0, 255, 0, 0);
5202diff --git a/drivers/input/touchscreen/ft5x06_ts.c b/drivers/input/touchscreen/ft5x06_ts.c 5152diff --git a/drivers/input/touchscreen/ft5x06_ts.c b/drivers/input/touchscreen/ft5x06_ts.c
5203new file mode 100644 5153new file mode 100644
5204index 0000000..89b5726 5154index 0000000..89b5726
diff --git a/recipes-kernel/linux/linux-imx_3.0.35.bb b/recipes-kernel/linux/linux-imx_3.0.35.bb
index 9c4b0be..149366b 100644
--- a/recipes-kernel/linux/linux-imx_3.0.35.bb
+++ b/recipes-kernel/linux/linux-imx_3.0.35.bb
@@ -3,7 +3,7 @@
3 3
4include linux-imx.inc 4include linux-imx.inc
5 5
6PR = "${INC_PR}.8" 6PR = "${INC_PR}.9"
7 7
8COMPATIBLE_MACHINE = "(mx6)" 8COMPATIBLE_MACHINE = "(mx6)"
9 9