summaryrefslogtreecommitdiffstats
path: root/recipes-core/net-persistent-mac/net-persistent-mac.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/net-persistent-mac/net-persistent-mac.bb')
-rw-r--r--recipes-core/net-persistent-mac/net-persistent-mac.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-core/net-persistent-mac/net-persistent-mac.bb b/recipes-core/net-persistent-mac/net-persistent-mac.bb
new file mode 100644
index 0000000..17111c0
--- /dev/null
+++ b/recipes-core/net-persistent-mac/net-persistent-mac.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Network device MAC persistency"
2DESCRIPTION = "Provides support to store/restore the MAC of a specific network device"
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6
7inherit update-rc.d
8
9INITSCRIPT_NAME = "net-persistent-mac"
10INITSCRIPT_PARAMS = "start 39 S ."
11
12SRC_URI = "file://init \
13 file://default"
14
15do_install () {
16 install -d ${D}${sysconfdir}/init.d
17 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/${PN}
18
19 install -d ${D}${sysconfdir}/default
20 install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/${PN}
21}
22
23PACKAGE_ARCH = "${MACHINE_ARCH}"