summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-script-boundary_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-script-boundary_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-script-boundary_git.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-script-boundary_git.bb b/recipes-bsp/u-boot/u-boot-script-boundary_git.bb
new file mode 100644
index 0000000..b39d963
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-script-boundary_git.bb
@@ -0,0 +1,68 @@
1LICENSE = "GPLv2+"
2LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
3DEPENDS = "u-boot-mkimage-native"
4
5PV = "v2014.01+git${SRCPV}"
6
7SRCREV = "aed9475361820a65e37ed936c833322cbbc0f2b5"
8SRCBRANCH = "v2014.04-20140419"
9SRC_URI = "git://github.com/boundarydevices/u-boot-imx6.git;branch=${SRCBRANCH}"
10
11S = "${WORKDIR}/git"
12
13inherit deploy
14
15do_mkimage () {
16
17 boarddir=nitrogen6x;
18 if test "${MACHINE}" = "nitrogen6x-lite"; then
19 boarddir=nit6xlite;
20 fi
21
22 # allow deploy to use the ${MACHINE} name to simplify things
23 if [ ! -d board/boundary/${MACHINE} ]; then
24 mkdir board/boundary/${MACHINE}
25 fi
26 bootscript=board/boundary/${boarddir}/6x_bootscript-yocto.txt;
27 if ! [ -f $bootscript ]; then
28 bootscript=board/boundary/${boarddir}/6x_bootscript-yocto.txt;
29 fi
30 echo "bootscript == $bootscript"
31
32 upgradescript=board/boundary/${boarddir}/6x_upgrade.txt;
33 if ! [ -f $upgradescript ]; then
34 upgradescript=board/boundary/nitrogen6x/6x_upgrade.txt;
35 fi
36
37 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
38 -n "boot script" -d $bootscript \
39 board/boundary/${MACHINE}/6x_bootscript
40
41 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
42 -n "upgrade script" -d $upgradescript \
43 board/boundary/${MACHINE}/6x_upgrade
44}
45
46addtask mkimage after do_compile before do_install
47
48do_deploy () {
49 install -d ${DEPLOYDIR}
50 install ${S}/board/boundary/${MACHINE}/6x_bootscript \
51 ${DEPLOYDIR}/6x_bootscript-${MACHINE}-${PV}-${PR}
52 install ${S}/board/boundary/${MACHINE}/6x_upgrade \
53 ${DEPLOYDIR}/6x_upgrade-${MACHINE}-${PV}-${PR}
54
55 cd ${DEPLOYDIR}
56 rm -f 6x_bootscript-${MACHINE} 6x_upgrade-${MACHINE}
57 ln -sf 6x_bootscript-${MACHINE}-${PV}-${PR} 6x_bootscript-${MACHINE}
58 ln -sf 6x_upgrade-${MACHINE}-${PV}-${PR} 6x_upgrade-${MACHINE}
59}
60
61addtask deploy after do_install before do_build
62
63do_compile[noexec] = "1"
64do_install[noexec] = "1"
65do_populate_sysroot[noexec] = "1"
66
67PACKAGE_ARCH = "${MACHINE_ARCH}"
68COMPATIBLE_MACHINE = "(nitrogen6x|nitrogen6x-lite)"