summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-cubox-i_2013.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-cubox-i_2013.10.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-cubox-i_2013.10.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-cubox-i_2013.10.bb b/recipes-bsp/u-boot/u-boot-cubox-i_2013.10.bb
new file mode 100644
index 0000000..1a4593c
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-cubox-i_2013.10.bb
@@ -0,0 +1,27 @@
1require recipes-bsp/u-boot/u-boot.inc
2
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://Licenses/README;md5=bc069111b5e5b1ed8bed98ae73b596ec"
5
6PROVIDES += "u-boot"
7
8PV = "v2013.10+git${SRCPV}"
9
10SRCREV = "e313a3a86ee97d5e3c3d9667c951775159f595b8"
11SRC_URI = " \
12 git://github.com/SolidRun/u-boot-imx6.git;branch=imx6 \
13 file://uEnv.txt \
14 "
15
16S = "${WORKDIR}/git"
17
18UENV_FILENAME ?= "uEnv-${MACHINE}.txt"
19
20deploy_uenv () {
21 install ${WORKDIR}/uEnv.txt ${DEPLOYDIR}/${UENV_FILENAME}
22}
23
24do_deploy[postfuncs] += "deploy_uenv"
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27COMPATIBLE_MACHINE = "cubox-i"