summaryrefslogtreecommitdiffstats
path: root/recipes-support/opencv/opencv_4.6.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/opencv/opencv_4.6.0.imx.bb')
-rw-r--r--recipes-support/opencv/opencv_4.6.0.imx.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-support/opencv/opencv_4.6.0.imx.bb b/recipes-support/opencv/opencv_4.6.0.imx.bb
index 54beed06..e3f03379 100644
--- a/recipes-support/opencv/opencv_4.6.0.imx.bb
+++ b/recipes-support/opencv/opencv_4.6.0.imx.bb
@@ -3,8 +3,7 @@
3# recipe. The second section customizes the recipe for i.MX. 3# recipe. The second section customizes the recipe for i.MX.
4 4
5########## meta-openembedded copy ########### 5########## meta-openembedded copy ###########
6# Upstream hash: 6b7cf95e75cbfc08cf1f6eddc7ce3f6a0a39edcf 6# Upstream hash: 72dc42966be7da07f9553f75b825123b81704f0b
7# plus LICENSE_FLAGS_ACCEPTED fix
8 7
9SUMMARY = "Opencv : The Open Computer Vision Library" 8SUMMARY = "Opencv : The Open Computer Vision Library"
10HOMEPAGE = "http://opencv.org/" 9HOMEPAGE = "http://opencv.org/"
@@ -59,6 +58,7 @@ SRC_URI = "git://github.com/opencv/opencv.git;name=opencv;branch=master;protocol
59 file://0001-Dont-use-isystem.patch \ 58 file://0001-Dont-use-isystem.patch \
60 file://download.patch \ 59 file://download.patch \
61 file://0001-Make-ts-module-external.patch \ 60 file://0001-Make-ts-module-external.patch \
61 file://0001-Add-missing-header-for-LIBAVCODEC_VERSION_INT.patch \
62 " 62 "
63SRC_URI:append:riscv64 = " file://0001-Use-Os-to-compile-tinyxml2.cpp.patch;patchdir=contrib" 63SRC_URI:append:riscv64 = " file://0001-Use-Os-to-compile-tinyxml2.cpp.patch;patchdir=contrib"
64 64
@@ -117,7 +117,7 @@ EXTRA_OECMAKE:remove:x86 = " -DENABLE_SSE41=1 -DENABLE_SSE42=1"
117 117
118PACKAGECONFIG ??= "gapi python3 eigen jpeg png tiff v4l libv4l gstreamer samples tbb gphoto2 \ 118PACKAGECONFIG ??= "gapi python3 eigen jpeg png tiff v4l libv4l gstreamer samples tbb gphoto2 \
119 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk", "", d)} \ 119 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk", "", d)} \
120 ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "libav", "", d)}" 120 ${@bb.utils.contains_any("LICENSE_FLAGS_ACCEPTED", "commercial_ffmpeg commercial", "libav", "", d)}"
121 121
122# TBB does not build for powerpc so disable that package config 122# TBB does not build for powerpc so disable that package config
123PACKAGECONFIG:remove:powerpc = "tbb" 123PACKAGECONFIG:remove:powerpc = "tbb"
@@ -257,19 +257,19 @@ SUMMARY = "Opencv : The Open Computer Vision Library, i.MX Fork"
257LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 257LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
258 258
259# Replace the opencv URL with the fork 259# Replace the opencv URL with the fork
260SRCREV_opencv = "d3440df40a6e90cd1d2a1b729bcbc16aa4d42f5d"
261OPENCV_SRC ?= "git://github.com/nxp-imx/opencv-imx.git;protocol=https;branch=master"
262SRCBRANCH = "4.6.0_imx"
263SRC_URI:remove = "git://github.com/opencv/opencv.git;name=opencv;branch=master;protocol=https" 260SRC_URI:remove = "git://github.com/opencv/opencv.git;name=opencv;branch=master;protocol=https"
264SRC_URI =+ "${OPENCV_SRC};branch=${SRCBRANCH};name=opencv" 261SRC_URI =+ "${OPENCV_SRC};branch=${SRCBRANCH};name=opencv"
262OPENCV_SRC ?= "git://github.com/nxp-imx/opencv-imx.git;protocol=https;branch=master"
263SRCBRANCH = "4.6.0_imx"
264SRCREV_opencv = "d3440df40a6e90cd1d2a1b729bcbc16aa4d42f5d"
265 265
266# Add opencv_extra 266# Add opencv_extra
267SRCREV_extra = "936854e2b666853d6d0732a8eabc2d699f4fa3d8"
268SRC_URI += " \ 267SRC_URI += " \
269 git://github.com/opencv/opencv_extra.git;destsuffix=extra;name=extra;branch=master;protocol=https \ 268 git://github.com/opencv/opencv_extra.git;destsuffix=extra;name=extra;branch=master;protocol=https \
270 file://0001-Add-smaller-version-of-download_models.py.patch;patchdir=../extra \ 269 file://0001-Add-smaller-version-of-download_models.py.patch;patchdir=../extra \
271" 270"
272SRCREV_FORMAT:append = "_extra" 271SRCREV_FORMAT:append = "_extra"
272SRCREV_extra = "936854e2b666853d6d0732a8eabc2d699f4fa3d8"
273 273
274# Patch DNN example 274# Patch DNN example
275SRC_URI += " \ 275SRC_URI += " \