summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-client_3.2.0.imx.bb2
-rw-r--r--recipes-security/optee-imx/optee-os_3.2.0.imx.bb2
-rw-r--r--recipes-security/optee-imx/optee-test_3.2.0.imx.bb2
-rw-r--r--recipes-security/optee/optee-client-qoriq.bb2
-rw-r--r--recipes-security/optee/optee-os-qoriq_git.bb2
-rw-r--r--recipes-security/optee/optee-test-qoriq_git.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
index d3ad9c0d..7e4f9b09 100644
--- a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b"
8inherit pythonnative systemd 8inherit pythonnative systemd
9 9
10SRCBRANCH = "imx_4.14.78_1.0.0_ga" 10SRCBRANCH = "imx_4.14.78_1.0.0_ga"
11OPTEE_CLIENT_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-client.git;protocol=https" 11OPTEE_CLIENT_SRC ?= "git://github.com/nxp-imx/imx-optee-client.git;protocol=https"
12SRC_URI = "${OPTEE_CLIENT_SRC};branch=${SRCBRANCH}" 12SRC_URI = "${OPTEE_CLIENT_SRC};branch=${SRCBRANCH}"
13 13
14SRCREV = "d06647d201520ac57f1331e97db6138d63bc2666" 14SRCREV = "d06647d201520ac57f1331e97db6138d63bc2666"
diff --git a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
index f4fc26e7..6d6889c3 100644
--- a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
@@ -10,7 +10,7 @@ inherit deploy pythonnative autotools
10DEPENDS = "python-pycrypto-native u-boot-mkimage-native" 10DEPENDS = "python-pycrypto-native u-boot-mkimage-native"
11 11
12SRCBRANCH = "imx_4.14.78_1.0.0_ga" 12SRCBRANCH = "imx_4.14.78_1.0.0_ga"
13OPTEE_OS_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https" 13OPTEE_OS_SRC ?= "git://github.com/nxp-imx/imx-optee-os.git;protocol=https"
14SRC_URI = "${OPTEE_OS_SRC};branch=${SRCBRANCH}" 14SRC_URI = "${OPTEE_OS_SRC};branch=${SRCBRANCH}"
15SRCREV = "6a52487eb0ff664e4ebbd48497f0d3322844d51d" 15SRCREV = "6a52487eb0ff664e4ebbd48497f0d3322844d51d"
16 16
diff --git a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
index 245685f5..16625a60 100644
--- a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
@@ -12,7 +12,7 @@ inherit pythonnative
12FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 12FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
13 13
14SRCBRANCH = "imx_4.14.78_1.0.0_ga" 14SRCBRANCH = "imx_4.14.78_1.0.0_ga"
15OPTEE_TEST_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https" 15OPTEE_TEST_SRC ?= "git://github.com/nxp-imx/imx-optee-test.git;protocol=https"
16 16
17SRC_URI = "${OPTEE_TEST_SRC};branch=${SRCBRANCH} \ 17SRC_URI = "${OPTEE_TEST_SRC};branch=${SRCBRANCH} \
18 file://0001-regression-4011-correct-potential-overflow.patch \ 18 file://0001-regression-4011-correct-potential-overflow.patch \
diff --git a/recipes-security/optee/optee-client-qoriq.bb b/recipes-security/optee/optee-client-qoriq.bb
index 4d1caa16..0eaf6160 100644
--- a/recipes-security/optee/optee-client-qoriq.bb
+++ b/recipes-security/optee/optee-client-qoriq.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
6 6
7inherit pythonnative systemd 7inherit pythonnative systemd
8 8
9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_client;nobranch=1 \ 9SRC_URI = "git://github.com/nxp-qoriq/optee_client;protocol=https;nobranch=1 \
10" 10"
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
diff --git a/recipes-security/optee/optee-os-qoriq_git.bb b/recipes-security/optee/optee-os-qoriq_git.bb
index fbde2616..64b96aa6 100644
--- a/recipes-security/optee/optee-os-qoriq_git.bb
+++ b/recipes-security/optee/optee-os-qoriq_git.bb
@@ -9,7 +9,7 @@ DEPENDS = "python-pycrypto-native"
9inherit deploy pythonnative 9inherit deploy pythonnative
10 10
11SRCREV = "4e8d2e5307b99a91a0cac3ea3560ecb7d62898d6" 11SRCREV = "4e8d2e5307b99a91a0cac3ea3560ecb7d62898d6"
12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_os;nobranch=1 \ 12SRC_URI = "git://github.com/nxp-qoriq/optee_os;protocol=https;nobranch=1 \
13 file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \ 13 file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \
14 file://0001-Fix-alignment-of-data-for-mempool_alloc_pool.patch \ 14 file://0001-Fix-alignment-of-data-for-mempool_alloc_pool.patch \
15 " 15 "
diff --git a/recipes-security/optee/optee-test-qoriq_git.bb b/recipes-security/optee/optee-test-qoriq_git.bb
index 1c6ca22e..eea88c18 100644
--- a/recipes-security/optee/optee-test-qoriq_git.bb
+++ b/recipes-security/optee/optee-test-qoriq_git.bb
@@ -8,7 +8,7 @@ DEPENDS = "optee-client-qoriq optee-os-qoriq python-pycrypto-native"
8 8
9inherit pythonnative 9inherit pythonnative
10 10
11SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_test;nobranch=1 \ 11SRC_URI = "git://github.com/nxp-qoriq/optee_test;protocol=https;nobranch=1 \
12 file://0001-fix-build-failure-with-GCC-9.patch \ 12 file://0001-fix-build-failure-with-GCC-9.patch \
13" 13"
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"